"Large Font" style option does not work

Bug #908926 reported by Daniel Richard G. on 2011-12-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Fix Released
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Medium
Lionel Le Folgoc
Precise
Medium
Lionel Le Folgoc
Quantal
Medium
Lionel Le Folgoc

Bug Description

[Impact]
* Accessibility option "Large Font" does not work.

[Test case]
* Click on the accessibility icon on the top panel.
* Select "Large Font" option.
* Nothing happens.
* Install lightdm-gtk-greeter from -proposed
* Restart your computer and repeat the steps above.
* Font size should increase, and be restored to its initial value when you uncheck the option.

[Regression Potential]
* GtkSettings seems to ignore invalid font-name strings (otherwise the current code would break), so it's fine.

This concerns lightdm 1.0.6-0ubuntu1.2 in Ubuntu Oneiric.

I am using LightDM as part of a stock Xubuntu install. The "High Contrast" style option (in the menu activated by clicking the second-from-the-right icon in the top-right corner) works, but "Large Font" does not.

Lionel Le Folgoc (mrpouit) wrote :

I think the current code behaves incorrectly when the font name contains spaces. The attached patch works for me.

Changed in lightdm (Ubuntu):
status: New → Confirmed
tags: added: patch
Robert Ancell (robert-ancell) wrote :

Do you want to maintain the GTK greeter? I can give you commit access and then you can fix it directly.

Lionel Le Folgoc (mrpouit) wrote :

Yes, I'd appreciate that if you don't mind (not that I'm sure I'll be able/have enough time to maintain it properly, but at least I can commit bugfixes when you can't). Thanks.

(anyway I'll check with the other "users" of this greeter, e.g. lubuntu and ubuntu-studio, too).

affects: lightdm (Ubuntu) → lightdm-gtk-greeter (Ubuntu)
Changed in lightdm-gtk-greeter (Ubuntu):
importance: Undecided → Low
no longer affects: lightdm-gtk-greeter
Lionel Le Folgoc (mrpouit) wrote :

I committed my patch.

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
Changed in lightdm-gtk-greeter (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in lightdm-gtk-greeter (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in lightdm-gtk-greeter (Ubuntu Quantal):
importance: Low → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in lightdm-gtk-greeter (Ubuntu Precise):
assignee: nobody → Lionel Le Folgoc (mrpouit)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.1.6-0ubuntu1

---------------
lightdm-gtk-greeter (1.1.6-0ubuntu1) quantal; urgency=low

  * New upstream bugfix release, including:
    - Fix 'Large Font' option for fontnames containing spaces lp: #908926
    - Fix 'Cancel' button action, and clear the error label. lp: #983152
 -- Lionel Le Folgoc <email address hidden> Sun, 01 Jul 2012 13:16:54 +0200

Changed in lightdm-gtk-greeter (Ubuntu Quantal):
status: Triaged → Fix Released
description: updated

Hello Daniel, or anyone else affected,

Accepted lightdm-gtk-greeter into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lightdm-gtk-greeter/1.1.5-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lightdm-gtk-greeter (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Lionel Le Folgoc (mrpouit) wrote :

Hi,

Could someone (other than me because I'm the uploader) test and confirm this fix with the package from precise-proposed, please? Thanks.

Chris Halse Rogers (raof) wrote :

@Lionel - you're welcome to test and verify your own uploads, particularly if (a) you're very confident in the fix, and (b) no-one else has stepped up to test for a while.

GridCube (gridcube) wrote :

I tested the proposed fix of lightdm-gtk-greeter and it does resizes the fonts on demand now.

GridCube (gridcube) on 2012-12-13
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.1.5-0ubuntu1.1

---------------
lightdm-gtk-greeter (1.1.5-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches:
    - 01_fix-large-font-option.patch: fix 'Large Font' option for
      fontnames containing spaces. lp: #908926
    - 02_fix-cancel-button.patch: fix Cancel button action, and clear
      the error label after cancellation. lp: #983152
 -- Lionel Le Folgoc <email address hidden> Tue, 23 Oct 2012 13:45:50 +0200

Changed in lightdm-gtk-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers