greeter hang with 100% CPU with black display

Bug #1897491 reported by Steve Arnold on 2020-09-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 20.04.1 LTS
Release: 20.04

lightdm-gtk-greeter:
  Installed: 2.0.8-1ubuntu1
  Candidate: 2.0.8-1ubuntu1
  Version table:
 *** 2.0.8-1ubuntu1 100
        100 /var/lib/dpkg/status
     2.0.6-0ubuntu1 500
        500 http://ports.ubuntu.com focal/universe armhf Packages

Chromebook armv7 install of focal tarball, followed by manual upgrade and xubuntu-desktop install. Selecting lightdm display manager results in the above behavior. Switching to gdm3 *does* work, however, requiring a full gnome-desktop install seems to defeat the purpose of xubuntu-desktop.

The workarounds using Memlock in the service file for lightdm have no affect, and neither does a native arm package rebuild of 2.0.6. The one thing that *does* work (besides switching to gnome) is building the debian 2.0.8 package using ubuntu deb tarball. Otherwise all you get are the log errors shown below.

The greeter log shows the following:

** Message: 19:40:54.740: Starting lightdm-gtk-greeter 2.0.6 (Sep 18 2018, 01:17:10)

(process:5105): GLib-ERROR **: 19:40:54.851: creating thread 'gmain': Error creating thread: Resource temporarily unavailable
** Message: 19:51:32.569: Starting lightdm-gtk-greeter 2.0.6 (Sep 18 2018, 01:17:10)

(process:5597): GLib-ERROR **: 19:51:32.571: creating thread 'gmain': Error creating thread: Resource temporarily unavailable
** Message: 20:07:27.951: Starting lightdm-gtk-greeter 2.0.6 (Sep 18 2018, 01:17:10)

(process:6133): GLib-ERROR **: 20:07:27.954: creating thread 'gmain': Error creating thread: Resource temporarily unavailable
** Message: 20:09:14.102: Starting lightdm-gtk-greeter 2.0.6 (Sep 18 2018, 01:17:10)

(process:6244): GLib-ERROR **: 20:09:14.105: creating thread 'gmain': Error creating thread: Resource temporarily unavailable
** Message: 20:10:52.081: Starting lightdm-gtk-greeter 2.0.6 (Sep 18 2018, 01:17
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.9
Architecture: armhf
CasperMD5CheckResult: skip
CurrentDesktop: XFCE
DistroRelease: Ubuntu 20.04
Package: lightdm-gtk-greeter 2.0.8-1ubuntu1 [origin: unknown]
PackageArchitecture: armhf
Tags: third-party-packages focal
Uname: Linux 5.8.12 armv7l
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio bluetooth cdrom cloud9ide dialout dip docker eqep floppy gpio i2c iio input kmem netdev plugdev pwm remoteproc spi systemd-journal tisdk users video weston-launch xenomai
_MarkForUpload: True

Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1897491

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

apport information

tags: added: apport-collected focal third-party-packages
description: updated

apport information

apport information

Steve Arnold (nerdboy) wrote :

Sorry, if I follow these instructions:

"UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again."

then it is impossible to login and do any of this stuff using the desktop. Is there some info I can collect manually via a console login?

Matinal Sun (matinal981922) wrote :

I have encountered this problem in the armhf board too. I employed Xubuntu 20.04 on both RK3399(aarch64) and RK3288(armhf). Then I found that the lightdm-greater cannot work in RK3288. The log is the same as Steve said. I attempted to avoid this problem by logging in automatically. It's a trick to use Xubuntu with a problematic greeter since it still goes to a black screen if I want to change users or reactiong. Do you find any solutions to resolve this problem?

Steve Arnold (nerdboy) wrote :

PING: can you just update your LTS package to 2.0.8 please? The current one is *broken* on armv7. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers