High cpu usage when lightdm screenlock is active

Bug #1509780 reported by Norbert Schulze on 2015-10-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Fix Released
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
High
Unassigned

Bug Description

When my system ist going to screenlock the cpu usage goes to 100 percent and the fanspeed goes up. When i switch with STRG+ALT+F1 to a terminal before the screenlock ist active, the system works fine.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lightdm 1.16.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Oct 25 11:08:38 2015
EcryptfsInUse: Yes
LightdmGreeterLog:
 ** Message: Starting lightdm-gtk-greeter 2.0.1 (Aug 7 2015, 01:24:18)
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/30_xubuntu.conf
 upstart: indicator-application-main-Prozess (1164) wurde mit dem Status 1 beendet
LightdmGreeterLogOld:
 ** Message: Starting lightdm-gtk-greeter 2.0.1 (Aug 7 2015, 01:24:18)
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/30_xubuntu.conf
 upstart: indicator-application-main-Prozess (1074) wurde von TERM-Signal beendet
 upstart: indicator-messages-main-Prozess (1072) wurde von TERM-Signal beendet
SourcePackage: lightdm
UpgradeStatus: Upgraded to wily on 2015-10-10 (15 days ago)

Norbert Schulze (n-schulze) wrote :
Robert Ancell (robert-ancell) wrote :

What does 'top' say is the process that is using 100% CPU? It's probably the greeter or a child process, not lightdm.

Changed in lightdm (Ubuntu):
status: New → Incomplete

When the screenlocks by light-locker, the lightdm-gtk-greeter uses
100% CPU. This happens only, when i use my fujitsu ultrabook on
portreplikator with a second monitor.

Regards
Norbert

2015-10-28 3:46 GMT+01:00 Robert Ancell <email address hidden>:
> What does 'top' say is the process that is using 100% CPU? It's probably
> the greeter or a child process, not lightdm.

affects: lightdm (Ubuntu) → lightdm-gtk-greeter (Ubuntu)
Changed in lightdm-gtk-greeter (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Changed in lightdm-gtk-greeter (Ubuntu):
importance: Undecided → High
LittleHorror (littlehorror) wrote :

Same issue, seems to only happen when external monitors are connected to the laptop (Thinkpad T460p with docking station). Xorg also experiences higher than normal CPU usage during those periods. Greeter itself seems to work at least partially (sluggish, text missing from error messages).

LittleHorror (littlehorror) wrote :

Also it seems quite related to bug 1410406, although in this case greeter does show up eventually.

Sean Davis (bluesabre) wrote :

Pretty sure I've identified and resolved the root cause for this issue. Fix committed below.

https://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/revision/382

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Sean Davis (bluesabre) on 2018-02-20
Changed in lightdm-gtk-greeter:
milestone: none → 2.0.4
Sean Davis (bluesabre) on 2018-02-20
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 2.0.4-1ubuntu1

---------------
lightdm-gtk-greeter (2.0.4-1ubuntu1) bionic; urgency=medium

  * New upstream release.
    - Fix: black screen after booting, 100% CPU usage (LP: #1410406, #1509780)
  * Merge with Debian unstable. Remaining changes:
    - debian/{01_ubuntu.conf,60-lightdm-gtk-greeter.conf,rules} add and
      install.
    - debian/control:
      + Build-Depends on liblightdm-gobject-1-dev instead on
        liblightdm-gobject-dev as it's non-existing in archive.
      + Add budgie-lightdm-theme to break/replaces due to conflicting
        budgie-desktop greeter icon (LP: #1669818)
      + Install desktop-base as a suggestion, not as a recommendation
        (LP: #1669818)
    - debian/copyright: update copyright for lightdm-gtk-greeter.
    - debian/lightdm-gtk-greeter.{preinst,postinst,postrm}: migrate post-1.0.0
      configuration to conf.d/01_ubuntu.conf.
    - debian/lightdm-gtk-greeter.maintscript: drop obsolete version of Ubuntu
      config from /etc.

 -- Sean Davis <email address hidden> Wed, 21 Feb 2018 21:45:55 -0500

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers