lightdm has black greeter background

Bug #1466191 reported by Brendan Perrine on 2015-06-17
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lightdm-gtk-greeter (Ubuntu)
Medium
Unassigned
lubuntu-default-settings (Ubuntu)
Medium
Julien Lavergne

Bug Description

To reproduce zsync http://cdimage.ubuntu.com/lubuntu/daily-live/20150617/wily-desktop-amd64.iso.zsync and install it and go through the installtion process. I chose manual partitioning and an xfs / partition. I then went through the install and hit enter and rebooted and started to boot plymouth came up and then I saw the top panel of lightdm the box to enter my password but there was no bacground.

lightdm-gtk-greeter:
  Installed: 2.0.1-1ubuntu1
  Candidate: 2.0.1-1ubuntu1
  Version table:
 *** 2.0.1-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

I expected the lightdm screen to have the defualt lubuntu background on first boot. Instead this did not show in lightdm but the background appeared once I logged in to a lubuntu session.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lightdm-gtk-greeter 2.0.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-20.20-generic 3.19.8
Uname: Linux 3.19.0-20-generic x86_64
ApportVersion: 2.17.3-0ubuntu4
Architecture: amd64
CurrentDesktop: LXDE
Date: Wed Jun 17 11:44:22 2015
InstallationDate: Installed on 2015-06-17 (0 days ago)
InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150617)
SourcePackage: lightdm-gtk-greeter
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1466191

tags: added: iso-testing
Brendan Perrine (walterorlin) wrote :

I also got this in a lubuntu desktop i386 vm.

tags: added: i386
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

I see this issue, also when I logout from the live session.

Changed in lightdm-gtk-greeter (Ubuntu):
importance: Undecided → Medium
Andrew P. (kalgasnik) wrote :

Can someone of lubuntu users compare content of /etc/lightdm/ in 15.04 and 15.10?

Brendan Perrine (walterorlin) wrote :

lightdm-gtk-greeter.conf from wily which seems to have all settings for the greeter commented out and not applied.

Brendan Perrine (walterorlin) wrote :

This is the lightdm conf from vivid of lightdm-gtk-greeter.conf which is a simlink to the -ubuntu version with a users version.

users.conf on both greeters appears to be the same.

Martin Wimpress (flexiondotorg) wrote :

So, something has changed in the way lightdm-gtk-greeter is packaged and works. The work around is to do the following:

sudo cp /etc/lightdm/lightdm-gtk-greeter-ubuntu-mate.conf /etc/lightdm/lightdm-gtk-greeter-ubuntu-mate.conf.d/50_ubuntu-mate.conf

summary: - lightdm boots to black background at greeter for latest lubuntu
+ lightdm has black greeter background for Lubuntu and Ubuntu MATE 15.10

Fix released for Ubuntu MATE 15.10 Alpha 1.

summary: - lightdm has black greeter background for Lubuntu and Ubuntu MATE 15.10
+ lightdm has black greeter background for Lubuntu
Rafael Laguna (rafaellaguna) wrote :

Confirmed.

Henk Terhell (hterhell) wrote :

Also Xubuntu Wily has black greeter background.

summary: - lightdm has black greeter background for Lubuntu
+ lightdm has black greeter background
Julien Lavergne (gilir) on 2015-10-13
Changed in lubuntu-default-settings (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.44

---------------
lubuntu-default-settings (0.44) wily; urgency=medium

  [ Julien Lavergne ]
  * src/etc/xdg/xdg-Lubuntu/xfce4/xfconf/xfce-perchannel-xml
   - Add xfce4-power-manager.xml to enable the tray icon of xfce4-power-manager
     by default.
  * debian/lubuntu-default-settings.install
   - Install xfce4 specific settings.
  * src/etc/lightdm/lightdm-gtk-greeter.conf.d/30_lubuntu.conf:
   - Move the lightdm-gtk-greeter config file to the new location
     (LP: #1466191)
   - Update lightdm-gtk-greeter config file with the new options.
  * src/etc/xdg/lubuntu/lightdm:
   - Remove the old location of lightdm-gtk-greeter config file.
  * debian/lubuntu-default-settings.dirs
   - Remove /etc/lightdm now that it's created.
  * debian/control
   - Increase the depends on lightdm-gtk-greeter.
  * debian/lubuntu-default-settings.postinst
  * debian/lubuntu-default-settings.postrm
  * debian/lubuntu-default-settings.preinst
  * debian/lubuntu-default-settings.prerm
   - Update with the new lightdm-gtk-greeter config file.

  [ Krytarik Raido ]
  * src/usr/share/lubuntu/openbox/rc.xml & nexus-rc.xml:
   - Don't reserve space for the panel at the bottom on
     horizontal window tiling anymore. (LP: #1266138)

 -- Julien Lavergne <email address hidden> Wed, 14 Oct 2015 07:46:28 +0200

Changed in lubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
Walter Lapchynski (wxl) wrote :

I can confirm this fixed in Lubuntu i386 Alpha 1.

Walter Lapchynski (wxl) wrote :

I would seem to think it would be fair to render the bug against lightdm-gtk-greeter Invalid since the change in its packaging doesn't necessarily seem to be a bug. If someone feels otherwise, I suggest opening a new bug.

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers