gray screen shown when external monitor connected on resume from suspend

Bug #1448761 reported by Suraj N. Kurapati on 2015-04-26
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Medium
Unassigned

Bug Description

After resuming from suspend, the Xubuntu login screen is completely gray if an external monitor is connected (see step 5 in the procedure below). This problem started occurring after I upgraded to Xubuntu 15.04; it never occurred under the previous Xubuntu 14.10 version.

1. Connect external monitor to laptop's HDMI port.

2. Choose external monitor as the sole display to use (do not use laptop's internal display at all: no mirroring or extending).

3. Suspend the laptop (put it to sleep) by closing the lid.

4. Wake up the laptop by opening the lid.

5. The screen is now completely gray on both the external monitor and the laptop's internal display. The mouse pointer is also visible and it responds to movements from the laptop's internal touchpad.

6. Disconnect the external monitor by unplugging the HDMI cable.

7. The regular login screen now appears.

8. Reconnect the external monitor by plugging in the HDMI cable.

9. The screen is now completely gray again, just like in step 5.

Please fix this gray screen issue! Thanks for your consideration.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: lightdm-gtk-greeter 2.0.0-0ubuntu1
Uname: Linux 3.19.4-031904-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Apr 26 12:24:08 2015
InstallationDate: Installed on 2015-02-16 (68 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: lightdm-gtk-greeter
UpgradeStatus: Upgraded to vivid on 2015-04-25 (0 days ago)

Suraj N. Kurapati (sunaku) wrote :
description: updated
description: updated
description: updated
description: updated
Andrew P. (kalgasnik) wrote :

Can you check trunk version?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Changed in lightdm-gtk-greeter (Ubuntu):
importance: Undecided → Medium
Suraj N. Kurapati (sunaku) wrote :

I obtained the trunk like this:

%?master ~/lab> bzr branch lp:lightdm-gtk-greeter/trunk lightdm-gtk-greeter
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
Branched 326 revisions.

Then I tried to build it:

%?master ~/lab> cd lightdm-gtk-greeter
lightdm-gtk-greeter:326 ~/lab/lightdm-gtk-greeter> ./autogen.sh
You need to install gnome-common from the GNOME CVS
exit 1

Then I installed dependencies:

lightdm-gtk-greeter:326 ~/lab/lightdm-gtk-greeter> sudo apt-get build-dep lightdm-gtk-greeter
[sudo] password for sunny:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  gir1.2-gtk-2.0 gir1.2-ido3-0.1 gir1.2-xkl-1.0 icu-devtools intltool libatk-bridge2.0-dev libatk1.0-dev libatspi2.0-dev libcairo-script-interpreter2 libcairo2-dev
  libdbus-1-dev libdbus-glib-1-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgtk-3-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libicu-dev libido3-0.1-dev
  libindicator-dev libindicator3-dev liblightdm-gobject-1-dev libmirclient-dev libmircommon-dev libpango1.0-dev libpcre3-dev libpcrecpp0 libpixman-1-dev libprotobuf-dev
  libprotobuf-lite9 libwayland-dev libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxdamage-dev libxfixes-dev libxi-dev libxkbcommon-dev
  libxklavier-dev libxml2-dev libxml2-utils libxtst-dev x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-record-dev
0 upgraded, 48 newly installed, 0 to remove and 1 not upgraded.
Need to get 17.1 MB of archives.
After this operation, 105 MB of additional disk space will be used.
Do you want to continue? [Y/n]
...

After all that, I tried building again:

lightdm-gtk-greeter:326 ~/lab/lightdm-gtk-greeter> ./autogen.sh
You need to install gnome-common from the GNOME CVS
exit 1

Now I give up. Is there an easier way to test trunk?

Andrew P. (kalgasnik) wrote :

Just use this PPA:
https://launchpad.net/~lightdm-gtk-greeter-team/+archive/ubuntu/daily
You can click "details" and download .deb file directly.

Suraj N. Kurapati (sunaku) wrote :

Thanks Andrew, that was much easier!

I'm happy to report that lightdm-gtk-greeter_201504260116~ubuntu15.04.1_amd64.deb (89.6 KiB) fixed the problem for me.

Henning Hoefer (hoeferh) wrote :

Same Problem here (however, a single mouse click makes everything redraw correctly).

The daily version fixed this issue for me.

Sean Davis (bluesabre) on 2015-05-21
Changed in lightdm-gtk-greeter:
milestone: none → 2.0.1
Sean Davis (bluesabre) on 2015-05-21
Changed in lightdm-gtk-greeter:
status: New → Fix Released
Adrian Guenter (adrianguenter) wrote :

Vivid is still on 2.0.0 for this package so unless you're on Wily you'll need to grab 2.0.1 from:
https://launchpad.net/ubuntu/wily/amd64/lightdm-gtk-greeter/2.0.1-2ubuntu1
...or, if you're the adventurous sort, you can grab a daily as Andrew suggested above before the release was made.

This issue was also happening to me on boot, not just resume, with an external monitor connected (via VGA) in 15.04. Appears to be 100% fixed here as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers