black screen after booting, 100% cpu usage

Bug #1410406 reported by Daniel Kessel on 2015-01-13
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
lightdm-gtk-greeter (Arch Linux)
New
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

After booting, I get no login screen, but a black screen. inspecting the running processes in a vterm, I see lightdm-gtk-greeter consuming 100% of one processor.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: lightdm-gtk-greeter 1.9.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-8.9-generic 3.18.1
Uname: Linux 3.18.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.15.1-0ubuntu2
Architecture: amd64
Date: Tue Jan 13 19:14:47 2015
InstallationDate: Installed on 2014-12-30 (14 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141229)
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm-gtk-greeter
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel Kessel (dkessel) wrote :
Alistair Buxton (a-j-buxton) wrote :

Can you try to figure out what it is doing? eg

strace -p `pidof lightdm-gtk-greeter`

or

gdb -p `pidof lightdm-gtk-greeter`

Daniel Kessel (dkessel) wrote :
Daniel Kessel (dkessel) wrote :

I have attached both the strace and the gdb log. It looks like I am missing debug symbols for gdb to work properly. I hope one of these files helps finding the problem.

Daniel Kessel (dkessel) wrote :

Another gdb trace. The process was in another library this time, it seems.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Changed in lightdm-gtk-greeter (Ubuntu):
importance: Undecided → Critical
Sean Davis (bluesabre) wrote :

lightdm-gtk-greeter 2.0 is now in vivid, can you please test with that version?

Daniel Kessel (dkessel) wrote :

The bug does not happen anymore.

Josef Jedlicka (josef-jedlicka) wrote :

I can confirm this error in Xubuntu 15.04. The error is in deed fixed by installing updates. However the issue appears again with multiple monitors.
If you click anywhere the login window will be displayed. This issue is fixed by inserting

active-monitor=0 on the end of file /etc/lightdm/lightdm-gtk-greeter.conf

Andrew P. (kalgasnik) wrote :

Please check version from this PPA (without active-monitor=0):
https://code.launchpad.net/~kalgasnik/+archive/ubuntu/lightdm-gtk-greeter-post-2.0.0

That didn't help at all, this package caused even more troubles and lightdm service failed to start.

Andrew P. (kalgasnik) wrote :

Add this option to lightdm-gtk-greeter.conf:
allow-debugging=true
and post /var/log/lightdm/x-*-greeter.log (the newest) here

Pw1 (pw1) wrote :

I've just upgraded from Xubuntu 14.10 to 15.04. After rebooting I was presented with a blank screen. Switching to a terminal I could see that lightdm-gtk-greeter was consuming 100%. After that I switched back to the graphical environment. Then I clicked the left-mouse button at a random position and the normal login screen came up and I could log in.

I added the allow-debugging=true option to lightdm-gtk-greeter.conf and restarted. I attached the resulting x-0-greeter-log.

After that added the option active-monitor=0 as suggested in one of the comments above. This workaround solves the problem for me. After the reboot the login screen comes up immediately.

Reed O'Brien (reedobrien) wrote :

This still occurs with lightdm-gtk-greeter 2.0.0-0ubuntu1 in 15.04 and multiple monitors per #1448214

Reed O'Brien (reedobrien) wrote :

This still occurs with lightdm-gtk-greeter 2.0.0-0ubuntu1 in 15.04 and multiple monitors per bug #1448214

sorry for the echo...

Andrew P. (kalgasnik) wrote :

So, have you tested proposed branch (without active-monitor workaround)?

Pw1 (pw1) wrote :

I hadn't tried that one yet. But I tried it now.

I installed lightdm-gtk-greeter 201503290547~ubuntu15.04.1 from https://code.launchpad.net/~kalgasnik/+archive/ubuntu/lightdm-gtk-greeter-post-2.0.0
and removed the active-monitor option.

This fix solved the problem for me. After the reboot the login screen comes up right away.

Andrew P. (kalgasnik) wrote :

Could you post new greeter log?

Pw1 (pw1) wrote :

Yes, here is is. The greeter log with lightdm-gtk-greeter 201503290547~ubuntu15.04.1 installed and no active-monitor option.

Andrew P. (kalgasnik) wrote :

Thanks, just another check - looks as expected.

Changed in lightdm-gtk-greeter:
status: New → Confirmed
Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Triaged
Andrew P. (kalgasnik) on 2015-05-19
Changed in lightdm-gtk-greeter:
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2015-05-21
Changed in lightdm-gtk-greeter:
milestone: none → 2.0.1
Martin Smat (msmat) wrote :

I still have the problem even after updating lightdm-gtk-greeter to version 2.0.1.
Attached is the x-0-greeter-log.

Andrew P. (kalgasnik) wrote :

1. About the bug. The algorithm that detects monitors overlapping must be a little "smarter". It's solvable, just need some time to fix. You can use "active-monitor" as workaround.
2. You still will have some issues with your monitors even with that fix.
Each your monitor displays the same area (see attachment). Search "lightdm dual" or "lightdm resolution" for fix.

Martin Smat (msmat) wrote :

Thank you, Andrew, for a prompt answer. I used the workaround with "active-monitor" already before 2.0.1. I only hoped the new bug fix would solve this problem. It obviously helped to many others but in some specific configurations like mine it still fails. I will patiently wait for a "smarter" algorithm and in the meantime I will use the suggested workaround and will take a look at including xrandr script in my lightdm.conf.

Hacksign (evilsign) wrote :

still black screen after logined in from command 'dm-tool lock'.

Sean Davis (bluesabre) wrote :
Changed in lightdm-gtk-greeter:
milestone: 2.0.1 → none
status: Fix Released → Fix Committed
Sean Davis (bluesabre) on 2018-02-20
Changed in lightdm-gtk-greeter:
milestone: none → 2.0.4
Sean Davis (bluesabre) on 2018-02-20
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 2.0.4-1ubuntu1

---------------
lightdm-gtk-greeter (2.0.4-1ubuntu1) bionic; urgency=medium

  * New upstream release.
    - Fix: black screen after booting, 100% CPU usage (LP: #1410406, #1509780)
  * Merge with Debian unstable. Remaining changes:
    - debian/{01_ubuntu.conf,60-lightdm-gtk-greeter.conf,rules} add and
      install.
    - debian/control:
      + Build-Depends on liblightdm-gobject-1-dev instead on
        liblightdm-gobject-dev as it's non-existing in archive.
      + Add budgie-lightdm-theme to break/replaces due to conflicting
        budgie-desktop greeter icon (LP: #1669818)
      + Install desktop-base as a suggestion, not as a recommendation
        (LP: #1669818)
    - debian/copyright: update copyright for lightdm-gtk-greeter.
    - debian/lightdm-gtk-greeter.{preinst,postinst,postrm}: migrate post-1.0.0
      configuration to conf.d/01_ubuntu.conf.
    - debian/lightdm-gtk-greeter.maintscript: drop obsolete version of Ubuntu
      config from /etc.

 -- Sean Davis <email address hidden> Wed, 21 Feb 2018 21:45:55 -0500

Changed in lightdm-gtk-greeter (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers