AccountsService conflicts with configured logon background

Bug #1306362 reported by Chris Page on 2014-04-11
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Fix Released
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

I changed the lightdm-gtk-greeter.conf to

[greeter]
background=#152233

but it instead displays the new xfce default wallpaper and in a way that doesn't fit the 2nd screen.

I do this because my 2nd screen is a plasma and any pattern left sitting on screen burns into it.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lightdm 1.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Apr 10 21:39:37 2014
InstallationDate: Installed on 2014-04-11 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140410)
LightdmGreeterLog:
 ** (lightdm-gtk-greeter:1479): WARNING **: Failed to load user image: Failed to open file '/home/chris/.face': No such file or directory
 init: indicator-bluetooth main process (1516) killed by TERM signal
 init: indicator-power main process (1518) killed by TERM signal
 init: indicator-application main process (1522) killed by TERM signal
 init: indicator-datetime main process (1519) killed by TERM signal
LightdmGreeterLogOld:
 ** (lightdm-gtk-greeter:2842): WARNING **: Failed to load user image: Failed to open file '/home/chris/.face': No such file or directory
 init: indicator-bluetooth main process (2876) killed by TERM signal
 init: indicator-power main process (2879) killed by TERM signal
 init: indicator-application main process (2894) killed by TERM signal
 init: indicator-datetime main process (2881) killed by TERM signal
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Page (chris-page1980-d) wrote :
affects: lightdm (Ubuntu) → lightdm-gtk-greeter (Ubuntu)
Simon Steinbeiß (ochosi) wrote :

Currently the accountsservice background setting can't be disabled, the linked branch will help with your problem.

Chris Page (chris-page1980-d) wrote :

In case any body winds up here I was able to remove the login wallpaper by editing the file in /var/lib/AccountsService/users/

Chris Page (chris-page1980-d) wrote :

editing the file in /var/lib/AccountsService/users/ only worked untill the 2nd reboot so I gave up and edited the actual wallpaper it-self in /usr/share/xfce4/backdrops/

Sean Davis (bluesabre) on 2014-04-30
summary: - lightdm logon background
+ AccountsService conflicts with configured logon background
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Andrew P. (kalgasnik) on 2014-05-30
Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Ole Jon Bjørkum (oj88) wrote :

Will this be fixed in Xubuntu 14.04?

Simon Steinbeiß (ochosi) wrote :

Depends a bit on our time-resources whether we do another 1.8 bugfix release and then backport it to trusty to be honest.

Ole Jon Bjørkum (oj88) wrote :

A workaround for me is to make the wallpaper readable only by the user. So I have my wallpaper in the Pictures folder in my home folder, and by giving it chmod 600 permissions (or my home folder 700 as I usually do), LightDM can no longer access it and follows lightdm.conf instead.

Chris Page (chris-page1980-d) wrote :

Once I disabled guest login for Xubuntu the conflict sorta went away, I don't think it really fixed it but it started paying attention to the lightdm.conf.

Chris Page (chris-page1980-d) wrote :

echo -e '[SeatDefaults]\nallow-guest=false' | sudo tee /etc/lightdm/lightdm.conf.d/50-noguest.conf

Ole Jon Bjørkum (oj88) wrote :

Disabling guest login doesn't fix it for me (there's no guest login in the login greeter anyway). Xubuntu 14.04 32-bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.9.0-0ubuntu1

---------------
lightdm-gtk-greeter (1.9.0-0ubuntu1) utopic; urgency=medium

  * New upstream release,
    - Fixes AccountsService logon background conflict (LP: #1306362)
    - Fixes Login screen wallpaper doesn't fill screen (LP: #1325719)
    - Fixes user-supplied default user image (LP: #1317236)
    - Fixes mouse-cursor theme changing after logon (LP: #1024482)
 -- Sean Davis <email address hidden> Wed, 20 Aug 2014 19:39:03 -0400

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Fix Released
Aaditya Bagga (chk1827) wrote :

Updating to lightdm-gtk-greeter-1.9.0-0ubuntu2 as provided by ~daniel-mehrmann works for me, with only a minor quibble: when logging out my user background is shown for a couple of seconds before the background specified in /etc/lightdm/lightdm-gtk-greeter.conf takes over.

Simon Steinbeiß (ochosi) wrote :

@chk1827: Note that your issue is a completely different bug altogether and has been reported here: https://launchpad.net/bugs/1614474

Sean Davis (bluesabre) on 2017-09-06
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions