Please upload lightdm-gtk-greeter-1.8.2 to trusty

Bug #1286949 reported by Sean Davis on 2014-03-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

lightdm-gtk-greeter 1.8.2 has been released. Please sponsor an upload to the trusty archives.

lightdm-gtk-greeter (1.8.2-1ubuntu1) UNRELEASED; urgency=medium

  * New upstream release.
    - Fixes segfault on uninstalled session (LP: #1272910)
    - Prefer the system default language over English (LP: #1276072)
    - Remember last session and language per user (LP: #1282139)
  * debian/lightdm-gtk-greeter-ubuntu.conf
    - Updated per new template, replaced deprecated "show-indicators" key
  * debian/patches/series
  * debian/patches/update-session-language.patch
    - Removed as fix is included upstream in 1.8.2

 -- Sean Davis <email address hidden> Sun, 02 Mar 2014 19:43:01 -0500

Sean Davis (bluesabre) wrote :

Attaching debdiff

from lightdm-gtk-greeter_1.8.1-1ubuntu2
to lightdm-gtk-greeter_1.8.2-1ubuntu1

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :

This package has been installed as tested in the following PPA:

https://launchpad.net/~lightdm-gtk-greeter-team/+archive/stable

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Sean,
I don't see that the fix of bug #1276072 is included in the debdiff, even if the changelog states it is.

Sean Davis (bluesabre) wrote :

Hi Gunnar,

Maybe I misunderstood? I understood that there were two merge proposals for that bug,

The first, which makes the fallback work correctly (the original bug), was applied here:
https://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/1.8/revision/245

The second, was decided to not be applied yet as it would require updated translations.
https://code.launchpad.net/~gunnarhj/lightdm-gtk-greeter/guest-session

Is this correct, or was there another item that needed to be included in this fix as well?

Gunnar Hjalmarsson (gunnarhj) wrote :

It's correct.

I thought that the fallback (revision 245) was not included in the debdiff, but when I took a closer look I saw that it is. My mistake.

Sorry.

Sean Davis (bluesabre) wrote :

Ok, good. I was worried that I had missed something. Thanks for keeping an eye out!

Dmitry Shachnev (mitya57) wrote :

Hi Sean, I have some questions about this:

- lightdm-gtk-greeter-ui.h looks like an auto-generated file, should it really be part of source tarball? I think it's better to generate it at build time.
- Did you borrow pantheon_badge-symbolic.svg from some other project (like, elementary)? If yes, you may need to add a copyright entry for it.

Also, please add a proper Debian merge changelog entry for *every* -1ubuntu1 upload. If you don't merge with Debian, then make the upload versioned -0ubuntu1.

I am uploading this anyway, but please do answer my questions.

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.8.2-1ubuntu1

---------------
lightdm-gtk-greeter (1.8.2-1ubuntu1) trusty; urgency=medium

  * Merge with Debian unstable, remaining changes:
    - debian/rules:
      + add indicators to dh_auto_configure
    - debian/control:
      + add depends for indicator support
      + add depends for liblightdm-gobject-1-dev (ubuntu naming is different)
      + fix binary-control-field-duplicates-source lintian tag
    - debian/copyright:
      + fix wiki-copyright-format-uri lintian tag
      + fix obsolete-field-in-dep5-copyright lintian tags
      + add missing license information
    - debian/lightdm-gtk-greeter-ubuntu.conf,
    - debian/lightdm-gtk-greeter.install,
    - debian/lightdm-gtk-greeter.{post,pre}{inst,rm},
    - debian/60-lightdm-gtk-greeter.conf:
      + install and remove ubuntu conf files
  * New upstream release (LP: #1286949).
    - Fixes segfault on uninstalled session (LP: #1272910)
    - Prefer the system default language over English (LP: #1276072)
    - Remember last session and language per user (LP: #1282139)
  * debian/lightdm-gtk-greeter-ubuntu.conf:
    - Updated per new template, replaced deprecated "show-indicators" key
  * debian/patches/update-session-language.patch:
    - Removed as fix is included upstream in 1.8.2
 -- Sean Davis <email address hidden> Sun, 02 Mar 2014 19:43:01 -0500

Changed in lightdm-gtk-greeter (Ubuntu):
status: Fix Committed → Fix Released
Sean Davis (bluesabre) wrote :

Hi Dmitry,

Thanks for the versioning info, I'll improve upon this in the future. To answer your questions...

lightdm-gtk-greeter-ui.h is auto-generated, but it is auto-generated by make distcheck, so the native source tarball creation outputs this file. I'll see if there is some control for this.

I believe that Simon may have actually drawn the pantheon badge himself, but I'll pull him in on the discussion.

Thanks,
Sean

Simon Steinbeiß (ochosi) wrote :

Hi everyone,
with regards to the badges, those were all created by me, some of them are derivative though of original GPL3-licensed logos. Since the greeter is also released under GPL3 I presumed (with my probably flimsy knowledge of GPL3) that it is OK to just redistribute the derivative works (=badges) under the same license.
However, the devil may be in the details, so if we need to reference all projects/authors of the badges/logos, I'm totally happy to do that.

Cheers,
Simon

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers