Xubuntu/Lubuntu daily image does not lead to a working desktop in a live session

Bug #1257372 reported by Paul White on 2013-12-03
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lightdm-gtk-greeter (Ubuntu)
High
Robert Ancell

Bug Description

Running the latest (20131203) daily image does not produce a working desktop and stalls at the main Xubuntu splash/startup screen. Yesterday's image worked fine. For what it's worth today's Ubuntu 64-bit image works fine on the hardware I have available.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1257372

tags: added: iso-testing
Paul White (paulw2u) wrote :

Same problem also affecting Lubuntu image.

summary: - Xubuntu Live image does not produce a working desktop
+ Xubuntu/Lubuntu daily image does not lead to a working desktop in a live
+ session
tags: added: lubuntu

This but affects me too (20131203 lubuntu i386)

ObrienDave (truckinpapa) wrote :

Also happens in the 20131206 Xubuntu 64bit daily build

Paul White (paulw2u) on 2013-12-06
tags: added: ppc
Jack Fromm (jjfrv8) wrote :

Problem still present in the 20131209 Xubuntu i386 daily build.

Paul White (paulw2u) wrote :

This bug may be a duplicate of bug #1257760 which has been logged against Kubuntu but as they configure the installer in a slightly different manner I haven't marked it as a duplicate. Kubuntu have at least fixed the problem although it hasn't filtered through to the live ISO yet.

I'm disappointed to find that only two of the five main flavours are currently producing live ISO images that can actually be used to install the flavour of my choice.

Elfy (elfy) wrote :

Pretty sure that the bug is that - if not exactly it's very close.

Start the iso - press any key - then remove quiet splash from the boot line - I see lightdm not starting

Elfy (elfy) wrote :

this bug seems to have been raised against just the manual test rather than a package - I've added lightdm

no longer affects: lightdm
Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)

Hello,

I have a couple questions on this bug, and what package it is filed
against.

I filed a bug on this for the PPC Live CD--https://bugs.launchpad.net/
bugs/1258303. It was marked as a duplicate of this bug--https://
bugs.launchpad.net/ubuntu-manual-tests/+bug/1257372.

I used the linked page below to determine what package to file the bug
against:

https://wiki.ubuntu.com/Bugs/FindRightPackage#Kernel

On the above mentioned page, it says:

"When installing Ubuntu (or Derivatives)

If you encounter a bug when installing Ubuntu, Kubuntu, Edubuntu, or
other derivatives, the bug is probably one of a small set of packages.

***If you encounter the bug when booting the Live CD (or alternative
installer), file the bug against the kernel.***
If you encounter the bug when installing Ubuntu from the Desktop CD
(most common method), the package is ubiquity. (See DebuggingUbiquity/
AttachingLogs.)
If you encounter the bug when installing from the Alternate or Server
CDs, the package is debian-installer."

I added the asterisks *** to highlight the area I thought was relevant.

With this information in mind, I ran "ubuntu-bug Linux" from a console
and filed the bug against the kernel. Was that the wrong package to
file it against? If so, what am I missing?

I'm trying to understand this so I don't make the same mistake in the
future.

Best regards,
Keith

On Dec 9, 2013, at 2:15 PM, Elfy wrote:

> this bug seems to have been raised against just the manual test rather
> than a package - I've added lightdm
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1258303).
> https://bugs.launchpad.net/bugs/1257372
>
> Title:
> Xubuntu/Lubuntu daily image does not lead to a working desktop in a
> live session
>
> Status in Light Display Manager:
> New
> Status in Ubuntu Manual Tests:
> New
>
> Bug description:
> Running the latest (20131203) daily image does not produce a working
> desktop and stalls at the main Xubuntu splash/startup screen.
> Yesterday's image worked fine. For what it's worth today's Ubuntu
> 64-bit image works fine on the hardware I have available.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lightdm/+bug/1257372/+subscriptions

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.6.1-0ubuntu2

---------------
lightdm-gtk-greeter (1.6.1-0ubuntu2) trusty; urgency=low

  * debian/40-lightdm-gtk-greeter.conf:
  * debian/lightdm-gtk-greeter.install:
  * debian/lightdm-gtk-greeter.postinst:
  * debian/lightdm-gtk-greeter.postrm:
    - Install lightdm configuration for greeter instead of using deprecated
      lightdm-set-defaults (LP: #1257372)
 -- Robert Ancell <email address hidden> Tue, 10 Dec 2013 09:08:05 +1300

Changed in lightdm-gtk-greeter (Ubuntu):
status: Triaged → Fix Released
Paul White (paulw2u) on 2013-12-11
Changed in ubuntu-manual-tests:
status: New → Invalid
no longer affects: ubuntu-manual-tests
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers