Unable to change session or language after logout

Bug #1213837 reported by N1ck 7h0m4d4k15 on 2013-08-19
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Light Display Manager
LightDM GTK+ Greeter
lightdm-gtk-greeter (Fedora)
Fix Released
lightdm-gtk-greeter (Ubuntu)
Sean Davis

Bug Description

Lubuntu Saucy Daily (2013/08/17).

I downloaded and installed the latest iso of Lubuntu 13.10 Saucy Salamander. The problem is that I cannot select another session if I logout. I can select a session in first place though.
Lubuntu comes by default with 4-5 Xsessions (Lubuntu Netbook, Lubuntu Games...etc)

To reproduce,

login to Lubuntu session normally, then logout and click the icon (up right) to select another session (Lubntu Netbook, Lubuntu Games.. etc). The icon does not respont.


ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lightdm 1.7.9-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Mon Aug 19 11:33:54 2013
InstallationDate: Installed on 2013-08-17 (1 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130817)
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

N1ck 7h0m4d4k15 (nick-athens30) wrote :
amjjawad  (amjjawad) on 2013-08-19
summary: - I cannot select an Xsession after logout - Lubuntu 13.10 (2013/08/19)
+ I cannot select an Xsession after logout from Lubuntu Saucy Daily
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

Could it be this bug, that is affecting you too, or is it another bug?


Best regards

description: updated
N1ck 7h0m4d4k15 (nick-athens30) wrote :

Maybe, I cannot select a language.
Neither the language icon works. But I don't know if we can mark this bug as a duplicate of

The additional problem here is that I cannot select another Session.


Description of problem:
After logout from session lightdm didn't display the login button.
I've only the possibility to 'unlock' which brings my session back.
But i can't switch session or language in this login mask.
Those possibilities was fix with lightdm-gtk-1.6.0-3.
The only way to have the normal login window is to restart the system complete or from rescue target.
Now you see also the missing menus.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. logout from session
2. try to switch session in lightdm

Actual results:
no login button and switcher/language menu after logout

Expected results:
login button and switcher/language menu after logout

I'm not shure if this is related to the issue but this policy rule prevent me from rebooting without admin password.

        <action id="org.freedesktop.login1.reboot-multiple-sessions">
                <description>Reboot the system while other users are logged in</description>
                <message>Authentication is required for rebooting the system while other users are logged in.</message>
                <annotate key="org.freedesktop.policykit.imply">org.freedesktop.login1.reboot</annotate>

This indicates that another session still exits, but which?
Also i'm still wondering why power off is allowed.

        <action id="org.freedesktop.login1.power-off-multiple-sessions">
                <description>Power off the system while other users are logged in</description>
                <message>Authentication is required for powering off the system while other users are logged in.</message>
                <annotate key="org.freedesktop.policykit.imply">org.freedesktop.login1.power-off</annotate>

N1ck 7h0m4d4k15 (nick-athens30) wrote :

If I restart LightDM, then I can select a session.
By this I can understand that the "change session" icon works only the first time. Something is happening when you login and from that time onwards the icon becomes unresponsive.
You must restart LightDM in order to somehow "reset" it and icon becomes responsive again.


amjjawad  (amjjawad) wrote :

Fresh Install for Saucy Daily Build (18-08-2013) on Virtual Box version 4.2.16 - Same Problem.

N1ck 7h0m4d4k15 (nick-athens30) wrote :

What I've found (and maybe help developers) is that if I login and logout from the Guest Account, the Icons (both "change session" and "change language") are fully responsive.

Maybe something with user settings ?


Bug affects me too: saucy daily 20130825.

workaround from comment #7 works for me too.

It seems that a login from a session don't terminate the session.
Output of login after a system start.

[rave@mother ~]$ loginctl list-sessions
        c1 995 lightdm seat0
         1 1000 rave seat0

2 sessions listed.

After a logout/login.

[rave@mother ~]$ loginctl list-sessions
         1 1000 rave seat0
        c2 995 lightdm seat0
         2 1000 rave seat0

3 sessions listed.

The old session is well listed.

Seems that the old session isn't terminate is a normal behaviour, my results for f18/19.

[rave@mother ~]$ loginctl list-sessions
         1 1000 rave seat0

1 sessions listed.

[rave@mother ~]$ loginctl list-sessions
         1 1000 rave seat0
         2 1000 rave seat0

sudodus (nio-wiklund) wrote :

Can we assume this is the same bug?

Tested in an installed Lubuntu Desktop i386 for Saucy Beta 1:

*Before I have logged in*

The session-selector works. I can run an Openbox session, and it works
well. The language-selector works too, and lets me change language (from
Swedish to English).

It is possible to change to high contrast but it works only while the
login screen is shown. Big fonts are 'selected' but never shown.

It is possible to shutdown and reboot. (I have not tested hibernation,
so I don't know about that.)

*After I have logged in and have logged out*

The session-selector and language-selector are *dead* (no pull-down menu).

It is possible to change to high contrast but it works only while the
login screen is shown. Big fonts are 'selected' but never shown.

It is possible to shutdown.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
sudodus (nio-wiklund) wrote :

Nik.Th's workaround from comment #7 works for me too.

I also notice that is takes long time (longer than I would expect) from the logout command until the login screen is displayed. Maybe it indicates some problem, for example trying to write something, that is not possible?

This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:

amjjawad  (amjjawad) wrote :

Any chance this could be somehow related?


Simon Steinbeiß (ochosi) wrote :

Yes, these two bugs are related. Somehow lightdm broke our log-out routine in the greeter (or there's really something else going on, logging out takes equally long in Xubuntu).

However we've worked on a patch for this that should also work on earlier lightdm-versions, it's half-ready, hopefully fully ready very soon.
That patch doesn't address the logout-delay though.

Simon Steinbeiß (ochosi) wrote :

Folks, we've pushed our fix to a new greeter version and it would be great if you could test whether this works.
All you have to do add this PPA to your sources:https://launchpad.net/~lightdm-gtk-greeter-team/+archive/daily
(e.g. by running "sudo add-apt-repository ppa:lightdm-gtk-greeter-team/daily", then "sudo apt-get update" in the terminal)

Then you can easily upgrade your greeter to version 1.6.1 via update-manager or via "sudo apt-get dist-upgrade" in the terminal.
Please let us know how it goes so this fix can be uploaded asap.

amjjawad  (amjjawad) wrote :


I am on Ubuntu GNOME Saucy right now and everything works just fine, as jbicha told you last night, I don't think we are affected by that :)

But anyway, I am subscirbed to these two bugs!

Oh Yeah ! :-)

This bug has been resolved.

Thank you @Simon Steinbeiß.
We are now able to select Xsessions and/or Languages without a problem.

Although the logout process is still buggy ? but this has nothing to do with the bug here. When I say buggy I mean it has a delay time more than usual.

I will mark this as Fix Released.

Thank you again.

Ah, Fix Committed I meant (sorry).

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Committed

Package changed because of comment #14, that points out that the affected package is lightdm-gtk-greeter (instead of lightdm)

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
affects: lightdm (Ubuntu) → lightdm-gtk-greeter (Ubuntu)
Changed in lightdm:
status: New → Invalid
Sean Davis (bluesabre) on 2013-09-18
Changed in lightdm-gtk-greeter:
milestone: none → 1.6.1
status: Fix Committed → Fix Released
Sean Davis (bluesabre) on 2013-09-18
summary: - I cannot select an Xsession after logout from Lubuntu Saucy Daily
+ Unable to change session or language after logout
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.6.1-0ubuntu1

lightdm-gtk-greeter (1.6.1-0ubuntu1) saucy; urgency=low

  [ Sean Davis ]
  * New upstream release. (LP: #1226921)
    - Fix inability to change session/language on logout (lp: #1213837)

  [ Daniel Holbach ]
  * d/watch: updated.
 -- Sean Davis <email address hidden> Tue, 17 Sep 2013 23:01:53 -0400

Changed in lightdm-gtk-greeter (Ubuntu):
status: Fix Committed → Fix Released
Pasi Lallinaho (knome) on 2013-09-18
Changed in lightdm-gtk-greeter (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)

*** Bug 1005233 has been marked as a duplicate of this bug. ***

lightdm-gtk-1.6.1-1.fc20 has been submitted as an update for Fedora 20.

Package lightdm-gtk-1.6.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-gtk-1.6.1-1.fc20'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

lightdm-gtk-1.6.1-1.fc20 has been pushed to the Fedora 20 stable repository. If problems still persist, please make note of it in this bug report.

sudodus (nio-wiklund) wrote :

I don't think it was fixed. The behavior was in some way improved, but the bug was never fixed for the *live* session.

What can I do more than report that it is still there? It should be easy for any developer to test it and find out how it appears.

Best regards

amjjawad  (amjjawad) wrote :


Are you still think this bug is alive?

sudodus (nio-wiklund) wrote :

This bug has reappeared in the live session of Wily Werewolf.

It is possible to select the Lubuntu Netbook and Openbox sessions in an installed system, but when I logout and try to do it in a live system, I get into the standard Lubuntu session.

Phill Whiteside (phillw) wrote :

IIRC, Netbook was dropped as an option, not aware of the OpenBox session as an option.

Phill Whiteside (phillw) wrote :

The extra sessions where removed as a default at install, they are now available as an extra package by the name of

sudodus (nio-wiklund) wrote :

They are available in the installed system of Wily, but not in the live system (they were available 'live too' in previous versions).

sudodus (nio-wiklund) wrote :

... and there is a dropdown menu for this purpose in the live session, but it does not work.

Phill Whiteside (phillw) wrote :

nio, I'll ask Julien if he can include the package in the seed for the LiveCD. I think it will depend on his workload, but no harm in asking :)

David Pearson (akxwi-dave) wrote :

Xubuntu xenial daily, you can select the different session but, when you log back in it defaults to the original ( i.e select xfce but it logs into xubuntu session)

Changed in lightdm-gtk-greeter (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.