upgrading from Quantal to Raring causes corrupted graphics for greeter window

Bug #1164192 reported by Kaj Ailomaa on 2013-04-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

This happened as a part of upgrading Ubuntu Studio Quantal to Ubuntu Studio Raring.
Ubuntu Studio uses the XFCE desktop system, with a similar config to Xubuntu.

Result of the upgrade, when booting into the greeter, is a lack of background (expected user chosen wallpaper) - instead a collage of fragments of what seems to be things stored in the graphic card RAM.
Also, the actual box for logging in looks thematically corrupted.

I'm willing to help debuggin this, if needed.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: lightdm-gtk-greeter 1.5.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-14.9-lowlatency 3.8.4
Uname: Linux 3.8.0-14-lowlatency i686
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
Date: Thu Apr 4 00:30:33 2013
InstallationDate: Installed on 2013-01-19 (74 days ago)
InstallationMedia: Ubuntu-Studio 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
MarkForUpload: True
SourcePackage: lightdm-gtk-greeter
UpgradeStatus: Upgraded to raring on 2013-04-03 (0 days ago)

Kaj Ailomaa (zequence) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1164192

tags: added: iso-testing
Kaj Ailomaa (zequence) wrote :

I did an upgrade on another machine, and while the background wallpaper loaded fine here (amd graphic card), the login window box had a corrupted theme, just like before.

Kaj Ailomaa (zequence) wrote :

..seems like the "corrupted" theming was not because of the upgrade, as that happens with a fresh install as well (only talking about the window box for choosing users, etc).
The corrupted background is still a problem though. I will try to see if that only happens during an upgrade or not.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :

Raring is no longer supported. This bug has been fixed in LightDM GTK+ Greeter 1.8

Changed in lightdm-gtk-greeter (Ubuntu):
status: Confirmed → Fix Released
Changed in lightdm-gtk-greeter:
status: New → Fix Released
milestone: none → 1.8.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers