xul-ext-* are not compatible with Firefox 57+

Bug #1736029 reported by Norbert
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
classic-theme-restorer (Ubuntu)
Undecided
Unassigned
colorfultabs (Ubuntu)
Undecided
Unassigned
firefox-branding-iceweasel (Ubuntu)
Undecided
Unassigned
firefox-kwallet5 (Ubuntu)
Undecided
Unassigned
form-history-control (Ubuntu)
Undecided
Unassigned
https-finder (Ubuntu)
Undecided
Unassigned
lightbeam (Ubuntu)
Undecided
Unassigned
mozilla-password-editor (Ubuntu)
Undecided
Unassigned
pdf.js (Ubuntu)
Undecided
Unassigned
self-destructing-cookies (Ubuntu)
Undecided
Unassigned
spdy-indicator (Ubuntu)
Undecided
Unassigned
ublock-origin (Ubuntu)
Undecided
Unassigned
video-without-flash (Ubuntu)
Undecided
Unassigned
xul-ext-exteditor (Ubuntu)
Undecided
Unassigned
y-u-no-validate (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install modern Ubuntu with all updates and all xul-ext- extensions
2. Launch Firefox 57 or newer
3. Go to Tools|Add-ons, Legacy Extensions and find Ubuntu Modifications 3.3 and others marked as LEGACY.

Expected results:
Ubuntu Modifications and others are compatible with modern Firefox.

Actual results:
Ubuntu Modifications and others are not compatible with modern Firefox, it does not fit Mozilla's trends (https://support.mozilla.org/en-US/kb/firefox-add-technology-modernizing?as=u&utm_source=inproduct).

Note:
for Ubuntu Modifications (ubufox) see bug 1711778.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xul-ext-ubufox 3.3-0ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-17.20-generic 4.13.8
Uname: Linux 4.13.0-17-generic x86_64
ApportVersion: 2.20.8-0ubuntu2
Architecture: amd64
CurrentDesktop: MATE
Date: Mon Dec 4 00:33:54 2017
PackageArchitecture: all
SourcePackage: ubufox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Norbert (nrbrtx) wrote :
description: updated
summary: - xul-ext-ubufox is not compatible with Firefox 57+
+ xul-ext-* are not compatible with Firefox 57+
Norbert (nrbrtx)
no longer affects: ubufox (Ubuntu)
description: updated
no longer affects: colorediffs-extension (Ubuntu)
no longer affects: firefox-kwallet5 (Ubuntu)
no longer affects: lightning-extension (Ubuntu)
no longer affects: torbirdy (Ubuntu)
no longer affects: tbdialout (Ubuntu)
Norbert (nrbrtx)
no longer affects: mozvoikko (Ubuntu)
tags: added: artful trusty xenial zesty
Norbert (nrbrtx)
tags: removed: artful trusty zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers