No menus for Netbeans on Ambiance gtk2

Bug #991009 reported by Ilan Tal on 2012-04-29
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Undecided
Unassigned
light-themes (Ubuntu)
Undecided
Unassigned

Bug Description

I just upgraded to Ubuntu 12.04. Netbeans is my most important application and I just discovered it no longer has any menus. This is a disaster for me. I was using Netbeans 7.1.1 so I did a complete removal with a fresh install of the newer version 7.1.2. The problem exists in the newer version as well.

I noticed type face on the projects was bold for all projects, making it impossible to distinguish the current main project from all the others. Thus I wanted to see if I could fix that from within Netbeans, only discover that ALL my menu items were gone. Then I did the upgrade to 7.1.2.

Could someone confirm this on another upgraded 12.04?

Thanks,
Ilan

Ilan Tal (ilan-tal) wrote :

This bug isn't connected to unity. Since it is so important to me I decided to see if Unity-2D would do the job. No, same problem. Then I tried Gnome classic. Same problem.
Whatever used to make the Netbeans menu appear on the top status bar is now broken. I just checked that the Firefox menu appears as expected so it is something connected to Netbeans (and maybe other things as well).

Ilan Tal (ilan-tal) wrote :

Sorry to bother again but I see it is a problem of colors. The menus appear inside Netbeans, not on the top status bar. The trouble is that the colors are screwed up and I can't see anything where the menus should be. If I click on the place where the menus should be then the color changes for the current menu changes and I can see it.
I can't see the menu item next to it, but at least I can see the items on the menu (which means I can work again).

This is probably the reason for my initial complaint, i.e. there is no longer any difference between normal and bold so that I can't tell what is the main project.

So, if the colors are scewed up, how can I fix them?

Ilan Tal (ilan-tal) wrote :

I finally got to the bottom of it. It is the ambiance color scheme. It has a black background with black text written over. That turns out to be invisible. I went to Radiance and now I can actually see the text which is written there.

Netbeans keeps crashing the system and error reports are being sent which will hopefully show what exactly is going on.

So the bottom line is there is no longer any disaster, but the ambiance needs to be fixed.

Ilan Tal (ilan-tal) wrote :

Another thing which has to be fixed in all color schemes is the text intensity. In Ubuntu 11.04 Netbeans showed the text as the main project in bold and all the other projects in plain text. It was then obvious which project was set to the main project. In 12.04 ALL the projects turn up in bold text so one can no longer tell which one is the main project.
This was the point which initially set me off to see what was "wrong". Now it is clear that it is because the color scheme in 12.04 has been screwed up (in Radiance as well). Not a killer bug, but it needs to be fixed. (Maybe it is a font problem?)

affects: unity (Ubuntu) → indicator-appmenu (Ubuntu)
Bilal Akhtar (bilalakhtar) wrote :

NetBeans has menus in my case. Can you log into a guest user profile and see if the issue exists there?

Also, do you have appmenu-gtk3 installed? Probably the fact that it's removed is hiding the menu AND not displaying it inside the window either.

Ilan Tal (ilan-tal) wrote :

I tried logging in as guest, but I am using the latest Netbeans 7.1.2 which isn't in the repository. It is in my /home directory, so guest doesn't see it.
I don't know how you are seeing menus if you are using Ambiance. I started to use Radiance to solve the problem.
Since Netbeans is so central to my workflow I also posted a message in their forum and got a lot of useful help

http://forums.netbeans.org/viewtopic.php?t=47823&sid=d029aa1b6fa5e98eecbed2db071fbd70

The most useful tip was to append "--laf Metal" to the execute command. The Metal look and feel solves the problem for me. It also solves the ugly bold text, so I can now tell which is the main project.

Apparently the problem is already known since another person reported:

Hi guys, you may have noticed that a new LTS been released several hours ago.
It has a bug in a default gtk2 theme "Ambiance".
All java applications menus will have a black font on a black background.
Bug already reported on launchpad, but have no idea when it will be fixed, so here is a solution:
sudo vim /usr/share/themes/Ambiance/gtk-2.0/gtkrc

Find a row 338 with contents:
style "menu" {

and make it look like this:
style "menu" = "dark" {

save and your java menus will be fine.

Bilal Akhtar (bilalakhtar) wrote :

Seems like a bug with light-themes then,

affects: indicator-appmenu (Ubuntu) → light-themes (Ubuntu)
summary: - No menus for Netbeans
+ No menus for Netbeans on Ambiance
summary: - No menus for Netbeans on Ambiance
+ No menus for Netbeans on Ambiance gtk2
Changed in indicator-appmenu:
status: New → Invalid
Andrea Cimitan (cimi) wrote :

it's a bug in java...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed

SOLVED WITHOUT EDITING ANY FILE ;-) <br/>

follow me here... <br/>

open terminal and type: <br/>

sudo add-apt-repository ppa:marko-techytalk.info/light-themes <br/>
after installing light-themes, initiate them by following command: <br/>

sudo apt-get update && sudo apt-get upgrade<br/>

and enjoy...<br/>

SOLVED WITHOUT EDITING ANY FILE ;-)

follow me here...

open terminal and type:

sudo add-apt-repository ppa:marko-techytalk.info/light-themes

after installing light-themes, initiate them by following command:

sudo apt-get update && sudo apt-get upgrade

and enjoy...

Ilan Tal (ilan-tal) wrote :

Glad to see that someone has found a solution. The next step would be for marko-techytalk to merge the fix to the official repository. Everyone should get the fix, not just those who happen to get your message about the additional repository.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers