UIFe: Re-enable the Ubuntu logo for the Applications menu in the GNOME Classic session

Bug #986988 reported by Jeremy Bicha on 2012-04-22
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
light-themes
Fix Released
Undecided
Unassigned
light-themes (Ubuntu)
Undecided
Unassigned
Precise
Wishlist
Benjamin Drung

Bug Description

For GNOME 3, GNOME disabled the distributor logo by default in gnome-panel but provided an easy way for distros to re-enable this. I think this small amount of branding is a good thing (every GNOME 2 distro used it & most KDE distros do as well), so let's re-enable the logo. The branding is useful to be able to tell at a glance if someone is running Ubuntu or something else.

To look good, this also requires fixing bug 986969. I'm attaching a screenshot of what it looks like after that bug is fixed too.

[Test Case]
1) sudo apt-get install gnome-panel
2) Close your current session and start Gnome-Classic Session in LightDM.
3) You should see the Ubuntu logo in the top left corner of the GNOME panel.

[Regression Potential]
The fix can lead to a regression in the visual appearance of the GNOME panel in the Classic session. Other sessions could not be affected.

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: light-themes 0.1.9.1-0ubuntu1 [modified: usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css usr/share/themes/Radiance/gtk-3.0/apps/gnome-panel.css]
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
Date: Sun Apr 22 15:46:12 2012
PackageArchitecture: allSourcePackage: light-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

Branch attached.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

As the only flavour shipping gnome-panel, Edubuntu isn't opposed to the change, though I'd need before/after screenshots of a default Edubuntu gnome fallback session before considering it.

Another problem is that for this to happen, you'd need a gtk3 and a light-themes upload, which are packages part of all gnome/unity based images. So while I'm fine with the change from an Edubuntu point of view and wouldn't mind the respin, I don't think it's reasonable to do it for 12.04 release.

Depending on how it looks in a clean Edubuntu session, we might consider getting that gtk fix and turning on the icon in an SRU to have it for 12.04.1. It's not a big UI change and from our user's point of view, will likely be seen as some kind of regression from the old Ubuntu classic experience.

Jeremy Bicha (jbicha) wrote :

It helps for a UI freeze exception that this is the non-default session for Edubuntu (Unity is default for 12.04) and there is no official documentation for the GNOME Classic session.

If anyone would like to test the fix for this & the GTK tweak out, it's relatively simple.

Add gtk-icon-sizes = panel-menu-bar=24,24 to /etc/gtk-3.0/settings.ini

And for /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css
add
-PanelMenuBar-icon-visible: true;
on a new line right below
PanelMenuBar.menubar.menuitem {

Then restart gnome-panel or log out and back in. I would have proposed this a lot sooner if I had known this was possible.

Jonathan Carter (jonathan) wrote :

I was planning on enabling it in all deployments I do anyway, also add a howto on the Edubuntu site on how to do it.

If it could be enabled by default it would save a lot of people some trouble.

Making another screenshot would be no problem.

+1 from me.

Alkis Georgopoulos (alkisg) wrote :

+1 from me too, it'd be very nice to have one less regression from the 10.04 UI :)

Marc Gariépy (mgariepy) wrote :

+1 from me too, having a nive gnome-fallback session would make transition a lot easier for less technical users.

Jeremy Bicha (jbicha) wrote :
Stéphane Graber (stgraber) wrote :

Thanks. Apparently our theme doesn't override the right distributor-logo, so we end up with the Ubuntu logo instead of Edubuntu's.

Though in black and white, I don't expect many people to actually notice the difference (not to mention that we'd have to create a black and white version of the logo first ;)), so it looks good to me.

I'm happy to have this land in Edubuntu 12.04 as an SRU. You may want to ask for confirmation from an SRU team member before pushing the changes to precise-proposed though.

Martin Pitt (pitti) wrote :

With my SRU hat on this seems fine. It's mostly Edubuntu's decision anyway.

Andrea Cimitan (cimi) on 2012-04-29
Changed in light-themes:
status: New → Fix Committed
Changed in light-themes (Ubuntu):
status: Confirmed → In Progress
Changed in light-themes (Ubuntu Precise):
status: Confirmed → In Progress
Stefano Rivera (stefanor) wrote :

Unsubscribing the release team, this missed the precise release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.2-0ubuntu1

---------------
light-themes (0.1.9.2-0ubuntu1) quantal; urgency=low

  * New upstream snapshot
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
 -- Ken VanDine <email address hidden> Wed, 30 May 2012 14:51:05 -0400

Changed in light-themes (Ubuntu):
status: In Progress → Fix Released
Changed in light-themes:
status: Fix Committed → Fix Released
Changed in light-themes (Ubuntu Precise):
status: In Progress → New
Clint Byrum (clint-fewbar) wrote :

This bug is missing information detailed in https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for it to comply with Stable Release Updates process. Please add information regarding the impact of the bug, a test case for recreating and the regression potential. Once this information is added to all the bugs addressed by the package in -proposed we will approve the upload. Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu Precise):
status: New → Confirmed

@Clint: What more do you want?
There is a fix for Quantal, but you think it's another bug in precise?
It's the same thing. Ubuntu logo next to the Applications menu label is missing in the Gnome classic panel.

Jeremy Bicha in post #5 even offers you the solution. I checked and it works.

Changed in light-themes (Ubuntu Precise):
status: Confirmed → Triaged
assignee: nobody → Jonathan Carter (jonathan)
milestone: none → ubuntu-12.04.1
importance: Undecided → Wishlist
Benjamin Drung (bdrung) on 2012-08-06
Changed in light-themes (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
Changed in light-themes (Ubuntu Precise):
assignee: Jonathan Carter (jonathan) → Benjamin Drung (bdrung)

Hello Jeremy, or anyone else affected,

Accepted light-themes into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/light-themes/0.1.9.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Benjamin Drung (bdrung) wrote :

After installing light-themes 0.1.9.1-0ubuntu1.1, the Ubuntu logo is shown in the Applications menu in the GNOME Classic session.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.1-0ubuntu1.1

---------------
light-themes (0.1.9.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/fix-ambiance-in-gnome-panel.patch:
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
  * debian/patches/greeter-white-border.patch:
     - dropped, applied upstream and the patch wasn't applied
  * Switch dpkg source format from 3.0 (native) to 3.0 (quilt).
 -- Whoopie <email address hidden> Sat, 04 Aug 2012 07:46:14 +0200

Changed in light-themes (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers