Text color under Ambiance in top panel of GNOME Classic is dark gray instead of white

Bug #955376 reported by Christopher Kyle Horton on 2012-03-14
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Salience
Undecided
Christopher Kyle Horton
light-themes (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

See attached screenshot. It's like that, all the way across the top panel.

(Ignore the light submenu, I already mentioned that on Bug #925895 as a separate issue. I was just lazy and recycled my screenshot.)

[Test Case]
1) sudo apt-get install gnome-panel
2) Close your current session and start Gnome-Classic Session in LightDM.
3) Look at the top left GNOME panel.
4) You should see the white text "Applications" and "Places" on dark background.

[Regression Potential]
The fix can lead to a regression in the visual appearance of the GNOME panel in the Classic session. Other sessions could not be affected because these changes apply to a CSS file only used by gnome-panel.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: light-themes 0.1.8.30-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 14 15:17:40 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: light-themes
UpgradeStatus: Upgraded to precise on 2012-03-11 (3 days ago)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Andrea Cimitan (cimi) on 2012-04-29
Changed in light-themes (Ubuntu):
status: Confirmed → Fix Committed
Dmitry Shachnev (mitya57) wrote :

Is this bug still here? I thought I've fixed it with my lp:~mitya57/light-themes/panel-fixes-part-1 branch...

D Fine (define2-0x) wrote :

i'm still having this problem after installing 12.04, installing gnome desktop from ubuntu software center and runing all updates from the update manager

D Fine (define2-0x) wrote :

Dmitry, thanks for looking at this! looks like the artwork packagers need to sign off. Got this status paragraph from your link:
-------------------------------------------------------
Branch merges
Merged into lp:light-themes at revision 214

    Andrea Cimitan: Approve on 2012-03-06
    Ubuntu Artwork Packagers: Pending requested 2012-03-04
    Diff: 79 lines (+29/-0) 2 files modified

Propose for merging
-------------------------------------------------------

Ubuntu Artwork Packagers: PLEASE APPROVE

--I need my gnome2, because my computer is not a phone

No, my branch is already merged. It seems that this occurs only in
Compiz session (with Compiz, it uses the theming for unfocused
windows), so I didn't notice it. Jeremy's branch should fix this,
anyway.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.2-0ubuntu1

---------------
light-themes (0.1.9.2-0ubuntu1) quantal; urgency=low

  * New upstream snapshot
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
 -- Ken VanDine <email address hidden> Wed, 30 May 2012 14:51:05 -0400

Changed in light-themes (Ubuntu):
status: Fix Committed → Fix Released
Julian Clark (julian.clark) wrote :

Now that this bug has been fixed for Quantal, what will we need to do in order to get the same package into precise-proposed? The bug affects me (and, likely, others) specifically in Precise, but I have already indicated that the bug affects me.

Benjamin Drung (bdrung) wrote :

I will prepare an update for precise-proposed.

Clint Byrum (clint-fewbar) wrote :

Per the SRU process at https://wiki.ubuntu.com/StableReleaseUpdates , please add a [Test Case] and [Regression Potential] to the description of this bug. The upload will not be accepted to precise-proposed until that is done. Thanks!

Steve Langasek (vorlon) wrote :

The required information has not been added to the bug despite a request nearly two weeks ago. I'm rejecting light-themes from the upload queue. It can be reuploaded once the linked bugs are in the correct state.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu Precise):
status: New → Confirmed
kroq-gar78 (kroq-gar78) on 2012-07-16
Changed in salience:
status: New → In Progress
milestone: none → 1.0-beta
assignee: nobody → kroq-gar78 (kroq-gar78)
Benjamin Drung (bdrung) on 2012-08-06
Changed in light-themes (Ubuntu Precise):
status: Confirmed → Fix Committed
description: updated
Steve Langasek (vorlon) wrote :
Download full text (3.2 KiB)

Please don't use 'fix committed' for Ubuntu stable release tasks, this value is used by the SRU process with a separate meaning.

The [Regression Potential] here asserts "Other sessions could not be affected" without explanation. It's not at all clear to me in reviewing the delta why that would be. For one thing, there are changes beyond the :backdrop addition:

+@@ -28,6 +32,7 @@
+ PanelApplet > GtkMenuBar.menubar.menuitem,
+ PanelMenuBar.menubar,
+ PanelMenuBar.menubar.menuitem {
++ -PanelMenuBar-icon-visible: true;
+ background-image: -gtk-gradient (linear, left top, left bottom,
+ from (shade (@dark_bg_color, 1.5)),
+ to (shade (@dark_bg_color, 1.05)));
+@@ -41,14 +46,15 @@
+ border-width: 0;
+ }
+
++PanelApplet .button:backdrop,
+ PanelApplet .button {
+ -GtkButton-inner-border: 2;
+
+ background-image: -gtk-gradient (linear, left top, left bottom,
+ from (shade (@dark_bg_color, 1.5)),
+ to (shade (@dark_bg_color, 1.05)));
+-
+- border-color: shade (@dark_bg_color, 0.78);
++ border-color: alpha (shade (@dark_bg_color, 1.0), 0.6);
++ border-left-color: alpha (shade (@dark_bg_color, 1.5), 0.3);
+ border-radius: 0;
+ border-width: 0 1px 0 1px;
+
+@@ -57,37 +63,27 @@
+
+ -unico-border-gradient: none;
+ -unico-glow-radius: 0;
+- -unico-inner-stroke-width: 0;
+- -unico-outer-stroke-width: 0;
++ -unico-inner-stroke-width: 0px;
++ -unico-outer-stroke-width: 0px;
+ }
+
+-PanelApplet .button:prelight:active,
++PanelApplet .button:active:prelight:backdrop,
++PanelApplet .button:active:prelight,
++PanelApplet .button:active:backdrop,
+ PanelApplet .button:active {
+ background-image: -gtk-gradient (linear, left top, left bottom,
+ from (shade (@dark_bg_color, 0.85)),
+ to (shade (@dark_bg_color, 1.0)));
+- border-color: shade (@dark_bg_color, 0.78);
+- border-radius: 0;
+- border-width: 0 1px 0 1px;
+-
+- -unico-border-gradient: none;
+- -unico-glow-radius: 0;
+- -unico-inner-stroke-width: 0;
+- -unico-outer-stroke-width: 0;
++ border-color: shade (@dark_bg_color, 0.9);
+ }
+
++PanelApplet .button:prelight:backdrop,
+ PanelApplet .button:prelight {
+ background-image: -gtk-gradient (linear, left top, left bottom,
+ from (shade (@dark_bg_color, 1.7)),
+ to (shade (@dark_bg_color, 1.25)));
+- border-color: shade (@dark_bg_color, 0.78);
+- border-radius: 0;
+- border-width: 0 1px 0 1px;
+-
+- -unico-border-gradient: none;
+- -unico-glow-radius: 0;
+- -unico-inner-stroke-width: 0;
+- -unico-outer-stroke-width: 0;
++ border-color: alpha (shade (@dark_bg_color, 1.0), 0.6);
++ border-left-color: alpha (shade (@dark_bg_color, 1.5), 0.4);
+ }
+
+ ClockBox {

I'm not comfortable accepting this SRU without a clearer explanation of why *none* of these changes have an impa...

Read more...

Changed in light-themes (Ubuntu Precise):
status: Fix Committed → Incomplete
Steve Langasek (vorlon) wrote :

> ++ -PanelMenuBar-icon-visible: true;

This particular line is explained by bug #986988; the other color changes are not.

Hello Christopher, or anyone else affected,

Accepted light-themes into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/light-themes/0.1.9.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in light-themes (Ubuntu Precise):
status: Incomplete → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) on 2012-08-07
Changed in light-themes (Ubuntu Precise):
importance: Undecided → High
Changed in light-themes (Ubuntu):
importance: Undecided → High

I have just installed the proposed fix from precise-proposed on my 12.04 laptop, and I can confirm that the fix works. I don't notice any further issues. Thanks much!

tags: added: verification-done
removed: verification-needed
Julian Clark (julian.clark) wrote :

I, too, can confirm that the new package resolves the issue described in this bug report. I hope to see it progress from -proposed soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.9.1-0ubuntu1.1

---------------
light-themes (0.1.9.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/fix-ambiance-in-gnome-panel.patch:
    - Add backdrop option, fixes Ambiance theming for menu bar & window
      list (LP: #955376, LP: #981289)
    - Enable the Ubuntu icon for the Applications menu (LP: #986988)
  * debian/patches/greeter-white-border.patch:
     - dropped, applied upstream and the patch wasn't applied
  * Switch dpkg source format from 3.0 (native) to 3.0 (quilt).
 -- Whoopie <email address hidden> Sat, 04 Aug 2012 07:46:14 +0200

Changed in light-themes (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in salience:
milestone: 1.0-beta → 1.0
Changed in salience:
status: In Progress → Fix Committed
kroq-gar78 (kroq-gar78) on 2012-11-29
Changed in salience:
assignee: kroq-gar78 (kroq-gar78) → Christopher Kyle Horton (christhehorton)
Changed in salience:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers