Ubuntu

Panel buttons have dark text on dark bg (GNOME fallback / Ambiance theme)

Reported by Marcus Moeller on 2012-02-16
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
light-themes
Fix Released
Undecided
Unassigned
light-themes (Ubuntu)
Undecided
Unassigned

Bug Description

In GNOME 3 Fallback (Classic) Mode with Ambiance (default) theme
panel buttons (e. g., buttons of opened windows and clock / calendar applet) have dark text on dark background,
making it really hard to read.

Probably, first seen in Precise Daily (i386) 20120216.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Alan Pater (alan-pater) wrote :

Java applications also have a similiar issue with their menus. See Bug #932274.

Bob Bib (bobbib) wrote :

Yes, default Ambiance theme looks ugly in GNOME 3 "Classic" mode.

light-themes 0.1.8.30-0ubuntu3
Ubuntu precise (development branch) 12.04 Beta 1

tags: added: precise regression-release
Bob Bib (bobbib) on 2012-03-11
summary: - window buttons have dark text on dark bg
+ Panel buttons have dark text on dark bg (GNOME fallback / Ambiance
+ theme)
Bob Bib (bobbib) on 2012-03-11
description: updated
Bob Bib (bobbib) wrote :

light-themes (0.1.8.31-0ubuntu1) precise; urgency=low

  * New upstream snapshot
    - Set the background-color for the GtkDrawingArea for notebook (LP: #922516)
    - contact info tooltips not readable in empathy (LP: #929651)
    - Ambiance/Radiance Nautilus Sidepane Invisible Drag & Drop File
      Selection (LP: #945014)
    - gnome-panel: fixed low-contrast labels in window list (LP: #828392)
    - gnome-panel: fixed gradient range for Ambiance
    - gnome-panel: fix cropped icons in bottom panel (LP: #926487)
    - gnome-panel: fix border artifact around applet frames (LP: #920843)
    - gnome-panel: theming for separator (LP: #945644)
 -- Ken VanDine <email address hidden> Wed, 14 Mar 2012 16:08:44 -0400

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Marcus Moeller (marcus.moeller) wrote :

If the bright white window buttons should be the fix, this is a bit unsatisfying. The panel button design in general should be fit the rest of the theme.

This is now the case for radiance, but not for ambiance.

For reference the layout should minic the old GNOME 2 Ambiance design.

Also the start menu text is a bit to dark and should fit the color of the rest of the menu items.

Bob Bib (bobbib) wrote :

marcus.moeller,
1) does it happen when you log into "GNOME Classic (no effects)" session?
("Gnome Classic" uses Compiz, so it becomes even more buggy).
2) you can change the bug status from "Fix Released" to smth. else, if you wish.

Marcus Moeller (marcus.moeller) wrote :

Thanks for the tip. In Fallback session, buttons are now displayed as expected. So my suggestion is to either fix the rendering in the version which uses Compiz, or to remove the Compiz session completly, renaming the fallback session to classic, afterwards.

Adolfo Jayme (fitoschido) wrote :

I don't understand how Compiz could affect the GNOME Panel button's rendering, but if you see the problem again, feel free to reopen this bug.

Re-opened the bug as the problem still exists in Compiz mode (see screenshot I have attached in #6)

Changed in light-themes (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Bob Bib (bobbib) wrote :

Sometimes happens in compiz-less mode too.

Adolfo Jayme (fitoschido) wrote :

This specific issue should be fixed now.

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitoschido) wrote :

Sorry, I'm wrong -- not yet. But Launchpad won't let me reopen this bug...

affects: light-themes (Ubuntu) → light-themes
Bob Bib (bobbib) on 2012-03-29
Changed in light-themes (Ubuntu):
status: New → Confirmed
Bob Bib (bobbib) wrote :

Fitoschido, perhaps we should wait for Marcus Moeller at least :)

Bob Bib (bobbib) on 2012-04-13
affects: light-themes → null
Changed in light-themes:
status: New → Confirmed

The bug, as described by Marcus Moeller in post #6, is still present as of now. (gnome fallback with effects)

definingmoment (wseemann) wrote :

This is a pretty annoying bug. Can anyone provide a temporary workaround until this is fixed?

Adolfo Jayme (fitoschido) wrote :

I will mark thos bug as "Fix Released" again, as the original problem is solved. The issue with the window buttons is being tracked in the bug report 981289, which is "Fix Commited" so we'll be happy very soon!

Changed in light-themes:
status: Confirmed → Fix Released
Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers