12.04 thunderbird colour theme is unreadable

Bug #925907 reported by psypher on 2012-02-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
light-themes (Ubuntu)
High
Andrea Cimitan
Precise
High
Andrea Cimitan
thunderbird (Ubuntu)
High
Chris Coulson
Precise
High
Chris Coulson

Bug Description

Since the latest update the colour theme in thunderbird has caused it to have unreadable menu buttons and open tab headings. The background colour is a dark grey like the Unity top panel but the font is a slightly lighter grey, but too light to be able to read. This is regression, the previous theme was perfect, please repair.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 10.0+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC665 Analog [ALC665 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ruald 7870 F.... pulseaudio
 /dev/snd/controlC0: ruald 7870 F.... pulseaudio
BuildID: 20120130194410
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0c00000 irq 57'
   Mixer name : 'Realtek ALC665'
   Components : 'HDA:10ec0665,1028046c,00100003'
   Controls : 25
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xcbefc000 irq 17'
   Mixer name : 'Nvidia GPU 11 HDMI/DP'
   Components : 'HDA:10de0011,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
Channel: release
Date: Fri Feb 3 09:32:21 2012
EcryptfsInUse: Yes
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
IpAddr: Error: command ['ip', 'addr'] failed with exit code 1: TUNSETIFF: Operation not permitted
IpRoute: Error: command ['ip', 'route'] failed with exit code 1: TUNSETIFF: Operation not permitted
Profiles: Profile0 (Default) - LastVersion=10.0/20120130194410 (Running)
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: Upgraded to precise on 2011-12-21 (43 days ago)
dmi.bios.date: 11/29/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/29/2010:svnDellInc.:pnXPSL701X:pvrA06:rvnDellInc.:rn:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: XPS L701X
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.

psypher (psypher246) wrote :
psypher (psypher246) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed with light-themes 0.1.8.27

affects: thunderbird (Ubuntu) → light-themes (Ubuntu)
Changed in light-themes (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in light-themes (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-release rls-mgr-p-tracking
Changed in light-themes (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Andrea Cimitan (cimi)
Andrea Cimitan (cimi) on 2012-02-03
Changed in light-themes (Ubuntu Precise):
status: Triaged → Invalid
Changed in thunderbird (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Chris Coulson (chrisccoulson)

Created attachment 594152
Use -moz-menubartext rather than MenuText for text on menubar styled elements

Design have changed our dark theme in Ubuntu to have light coloured menu popups with dark text (rather than dark popups with light text, like we had previously). Unfortunately, this exposes a bug in the Thunderbird theme, which styles the tabs in the main window and the toolbars in the compose / addressbook windows with the background of the menubar (which is dark), and the text colour of the menu popups (which used to be light, but is now dark).

It seems that Thunderbird should be using -moz-menubartext rather than MenuText in these cases (Firefox seems to do this already, so it didn't break with our theme change)

affects: light-themes → thunderbird
Changed in thunderbird:
importance: Undecided → Unknown
status: New → Unknown
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in thunderbird (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b1+build2-0ubuntu1

---------------
thunderbird (11.0~b1+build2-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_11_0b1_BUILD2)

  * Update messagingmenu to 0.9.2
    - Fix a failure to initialize in some cases
  * Update globalmenu-extension to 2.0.3
  * Drop patches fixed upstream:
    - remove debian/patches/fix-build-failure-without-yarr-jit.patch
    - remove debian/patches/fix-cursor-handling.patch
    - update debian/patches/series
  * Refresh patches:
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
  * Ensure we include locales in the tarball if they are in shipped-locales
    but not in all-locales
    - update debian/build/create-tarball.py
  * Always set the update channel - not setting it at build-time on release
    builds breaks the extensions.checkCompatibility pref. The only things
    using it at runtime are nsBlocklistService, Test Pilot (beta + aurora)
    and the about dialog (where the channel is hidden anyway)
    - update debian/rules
    - update debian/thunderbird.install.in
  * Fix LP: #898883 - IPC xpcshell tests hang the buildd's. Give all
    xpcshell tests an X display, as plugin-container won't work without one
    - update debian/build/testsuite.mk
  * Turn on all IPC xpcshell tests again (only applicable when the testsuite
    is enabled in the future)
    - update debian/build/testsute.mk
  * Drop the default-apps xml file from lucid and maverick
    - remove debian/firefox.xml.in
    - update debian/firefox-gnome-support.install.in
    - update debian/rules
  * Don't build with --disable-gconf on precise and newer. There won't be
    a hard runtime requirement on this from Firefox 12 anyway, and this
    keeps us closer to the upstream configuration
    - update debian/config/mozconfig.in
    - update debian/rules
  * Update theme-refresh-messenger-toolbar-icons.patch to work with
    tabs-on-top, where the toolbar isn't styled like the menubar
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
  * Refresh shipped locales for beta (addition of Armenian and Croatian)
    - refresh debian/config/locales.shipped
    - refresh debian/config/locales.all
    - refresh debian/control
  * Fix LP: #925907 - 12.04 Thunderbird colour theme is unreadable. Use
    -moz-menubartext rather than MenuText for elements with menubar styled
    backgrounds. Should also fix LP: #856939
    - add debian/patches/use-menubar-text-colour-on-tabbar.patch
    - update debian/patches/theme-refresh-compose-toolbar-icons.patch
    - update debian/patches/theme-refresh-addressbook-toolbar-icons.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 03 Feb 2012 20:20:18 +0000

Changed in thunderbird (Ubuntu Precise):
status: Fix Committed → Fix Released
psypher (psypher246) wrote :

Confirmed, thunderbird and firefox are using the new pop-up menu themes and the panels and tabs fonts are readable again.

BTW I REALLY like the new pop-up menu colour scheme!! Just looks slick. Well done.

SKAL (sir-kalot) wrote :

I'm not sure if it related to this bug,
but since the last update to 11.0~b2+build2-0ubuntu1 TB is not working anymore on my kubuntu 12-04 box. :(
See the attached file

Comment on attachment 594152
Use -moz-menubartext rather than MenuText for text on menubar styled elements

MDN says "-moz-menubartext - Foreground color for text in menu bars. Often similar to MenuText. Should be used on top of Menu background."
So that should be all right here.

Looks good on Light themes (Clearlooks on Fedora) and Dark themes (Ambiance on Ubuntu [2])

1. https://developer.mozilla.org/en/CSS/color_value#Mozilla_System_Color_Extensions
2. http://ubuntuone.com/5rS8S6dIb2LgVlAuC0sJzV

http://hg.mozilla.org/comm-central/rev/a1dbe0bb4266

To make life easier for those checking in patches for you, please follow the instructions below in your future patches. Thanks!
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F

Changed in thunderbird:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.