Ubuntu

(non-overlay) scrollbars are really hard to see

Reported by vervelover on 2010-04-14
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
light-themes
Fix Released
Undecided
Unassigned
light-themes (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: light-themes

Hi,

as the title says, scrollbars in the ambiance/radiance themes are really really hard to see, and I can see no reason for this. Making them invisible is not a way to make them look better. The new themes are great but this is a major usability issue.

Thanks
Alessio

Vish (vish) wrote :

Setting to wishlist as this is a request to change the default intended design

Changed in light-themes (Ubuntu):
importance: Undecided → Wishlist
vervelover (alessiopangos) wrote :

The scrollbars in the very first version did not have this problem but fit the "light" design anyway..

James Henstridge (jamesh) wrote :

This problem seems to have been introduced in the 0.1.6.4 version:

  * Ambiance/Radiance: Adjust scrollbar lighting (LP: #542686).
   - Remove progressbar lightbordershade (LP: #551107).
   - Global trough_shades for scrollbar/progressbar

It isn't clear to me why having the same trough shading for progress bars and scroll bars is a good idea: the progress bar is rendered in a high contrast orange, while the scroll bar thumb is almost the same shade of grey as the trough, and the outline around the thumb is also quite low contrast.

Surely this is a valid usability/accessibility bug rather than a case of someone wanting a change for aesthetic reasons?

Ivan (trurl-master) wrote :

Please put some attention to this, i believe it's important usability issue.

pfrenssen (pieter-frenssen) wrote :

Until this bug is fixed you can give the scrollbars another colour with Gnome Color Chooser.

sudo apt-get install gnome-color-chooser

Ivan (trurl-master) wrote :

Or set colorize_scrollbar to TRUE in theme gtkrc file. But it will work till next theme update :)

Matt Joiner (anacrolix) wrote :

This is driving me nuts. I can't make out the contrast between scroll bar and trough.

Matt Joiner (anacrolix) wrote :

This problem exists in Lucid, Maverick and now also Natty. How can I mark it as affecting those releases?

Changed in light-themes (Ubuntu):
status: New → Confirmed
Ahmed Shams (ashams) wrote :

Confirmed in Papercuts project.

Changed in hundredpapercuts:
importance: Undecided → Medium
status: New → Confirmed
tags: added: accessibility
Ahmed Shams (ashams) wrote :

Changed importance for re-evaluation as it was reported to affect accessibility.

Changed in light-themes (Ubuntu):
importance: Wishlist → Low
Matt Joiner (anacrolix) wrote :

Still can't make out the contrast, this is a very serious visual problem with the default theme.

In the old days when cleanlooks and ubuntu human were popular, this wasn't a problem. Cleanlooks had a bright blue slider, and ubuntu human, orange. The new unity scroll bars are okay for those apps that use them: they have a thin sliver of orange, and a giant popup handle when u get near.

I'm attaching a screenshot of the problem.

Matt Joiner (anacrolix) wrote :

Still an issue in Precise Alpha 2.

What about adding an orange border around the scrollbar thumb? It might make it stand out more, and it would then also be consistent with the appearance of the overlay scrollbars.

Adolfo Jayme (fitoschido) wrote :

A stronger contrast would be enough to fix this bug, without requiring moar orange.

summary: - scrollbars are really hard to see with the ambiance/radiance themes
+ (non-overlay) scrollbars are really hard to see
Changed in light-themes:
status: New → Confirmed
askuhn (askuhn) wrote :

Sorry to revive this topic, but I see this lack of contrast as a major usability issue with the "legacy" scrollbars. Any progress (or attention) on this would be great :)

I accidentally came up with a scrollbar that contrasts while still fitting Ambiance very well (better than default, imo). See my post here: http://askubuntu.com/a/114018/46882

Thanks!

nihop (nihop) on 2012-03-23
tags: added: usability
Ivan (trurl-master) wrote :

In my opinion it's good solution just to set "colorize_scrollbar" to TRUE in theme gtk-2.0/gtkrc file.

@Ivan I'm all for adding some orange, but even I wonder if that might be a tad too much.

Andrea Cimitan (cimi) wrote :

I guess they are more visible now

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in light-themes:
status: Confirmed → Fix Released
Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Adam Niedling (krychek) wrote :

No, nothing has changed in Precise.

Adam Niedling (krychek) wrote :

I can't change this bug back to Confirmed, Andrea please change it back. The colors are still the same in Precise and the scrollbar is still really hard to see.

Adam Niedling (krychek) wrote :

I set this bug as the duplicate of bug #721786. This was the only way to reopen it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers