[10.04 Netbook] close button is on left while maximized

Bug #556686 reported by Paolo Sammicheli on 2010-04-06
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
Unity
Fix Released
Low
Unassigned
light-themes
Invalid
Undecided
Unassigned
window-picker-applet
Undecided
Unassigned
light-themes (Ubuntu)
Wishlist
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: light-themes

Since new Ambiance/Radiance theme affected UNE there's an inconsistency while windows are maximized or de-maximized. (see Screenshot attached)
"Close" button on Window Picker Applet should be at left side, but now it is at right.

Paolo Sammicheli (xdatap1) wrote :

Screenshot with notes

summary: - [Lucid Beta2 Netbook Edition] close button inconsistent while maximized
+ [Lucid Beta2 Netbook Edition] close button inconsistency while maximized
tags: added: iso-testing
Kamus (kamus) on 2010-04-06
Changed in light-themes (Ubuntu):
importance: Undecided → Low

@Kamus: Could you possibly motivate why this bug should be low? And also, since you defined the importance could you possibly confirm this bug?

BTW, Close Button, in a window, is the most used button. A normal user use it hundreds times a day. Why a so dramatic inconsistence like this (the button is in the opposite position if window is maximixed or de-maximized) is Low importance?

Thanks

Vish (vish) wrote :

Paolo Sammicheli , I'm not sure why Kamus has set it to Low , This bug is actually a wishlist .
Pls see , Bug #532633 , which is the main cause of this inconsistency.

The button order is not going to change for lucid , this is however a ture cause for concern , since the UNE has the close on the right , the bug would probably need to be fixed in maximus. Maximus would need to move the button to left as well

Vish (vish) wrote :

Marking theme task as wont fix

Changed in light-themes (Ubuntu):
status: New → Invalid
Vish (vish) wrote :

as per comments on Bug #532633

Changed in light-themes (Ubuntu):
importance: Low → Wishlist
status: Invalid → Won't Fix
Changed in maximus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Paolo Sammicheli (xdatap1) wrote :

@Vish: I'm perfectly aware about Bug #532633 , but there they are discussing if left is better than right for default theme, an Mark already stated the final decision.

Here we're talking about UNE partially apply the changes about button placement and partially not, having an inconsistence in user interface.

Paolo Sammicheli (xdatap1) wrote :

Hi Rick, sorry for bother you. Are you aware about this problem in Ubuntu Netbook Edition?

Thanks in advance

Vish (vish) wrote :

@Paolo Sammicheli , I agree with the inconsistency , hence this needs to be fixed in maximus.
There are nearly 700 odd comments and afaik , this difference was mentioned too and still the decision was taken.

Since the light theme is the same package used for both UNE and Desktop , unfortunately changing it for UNE is not possible without affecting the Desktop.

Paolo Sammicheli (xdatap1) wrote :

@Vish: I agree perfectly with you. What I don't understand is the "Low" priority. This should be fixed before the release IMHO. From the user experience prospective this is a big issue.

Vish (vish) wrote :

@Paolo Sammicheli:
Low means : A cosmetic/usability issue that does not limit the functionality of an application
from https://wiki.ubuntu.com/Bugs/Importance

However , once the actual devs have a look at the bug , they can raise the importance/priority

James Schriver (dashua) wrote :

This would be a change in the window-picker-applet. Maximus or light-themes have nothing to do with this behavior.

Kamus (kamus) wrote :

@Vish and @Paolo, you are right was a mistake for my part, all apologies for that.

Paolo Sammicheli (xdatap1) wrote :

@Kamus: Nothing to apologies for. We're all trying to do our best to make Ubuntu better and making Lucid rock :)

@Vish:
I'm not English native speaker, so forgive me if I'm misunderstanding that wiki page.
IMHO, while Low's example could be cosmetic/usability issue, the main definition of Low is also "Bugs which affect functionality, but to a lesser extent than most bugs". In this case I suppose we've not a "lesser extent" because it affect every user on every window.

Let's see what Rick or somebody else in Desktop Team decide about this bug, my only concern about priority is if this issue isn't valuated in time for fixing it before release.

Ciao!

Didier Roche (didrocks) wrote :

We are paste UI freeze for a month now. It's not the time to change such things. Documentation already make screenshots and such…

affects: maximus (Ubuntu) → window-picker-applet (Ubuntu)
Changed in window-picker-applet (Ubuntu):
status: Confirmed → Triaged

I have no reason to second guess Didier's judgement on this.

Dmitry Shachnev (mitya57) wrote :

Since Mark Shuttleworth decided to move buttons to the left finally (see https://launchpad.net/ubuntu/+bug/532633/comments/564), so please can you fix this bug before 10.04.1 release (July 29th)?

description: updated
description: updated
tags: added: controls window
summary: - [Lucid Beta2 Netbook Edition] close button inconsistency while maximized
+ [10.04 Netbook] close button is on left while maximized
tags: added: ubuntu-une
Didier Roche (didrocks) wrote :

The decision has already been taken and I'll be fixed in maverick, not changing UI for lucid, especially after release. See above comments.

Vish (vish) wrote :

Not a bug in the theme

Changed in light-themes:
status: New → Invalid
Tepee (tepee) wrote :

If you plan for Maverick to put to the left the close button of maximus, it will be great !
All the icons of opened applications and the close button wil be in a near area, this will be more confortable instead of going on each side of the screen all the time.
Thanks !

Dmitry Shachnev (mitya57) wrote :

Yes. Ubuntu Netbook 10.10 will have Unity interface by default (https://launchpad.net/unity), so window controls will be on left, and list of opened applications will be in a dock on the left side of the screen.

Dmitry Shachnev (mitya57) wrote :

Since it's not a bug in light-themes (ubuntu), it should be marked as invalid.

@Vish, > as per comments on Bug #532633,
It's just a discussion about placing buttons to left/right in Metacity title, and final decision was to place them to LEFT.

Also, I think it won't be fixed in Window-Picker-Applet because Ubuntu-Netbook 10.10 will come without it (ubuntu-netbook-unity-default-settings does not depend on it).

Dmitry Shachnev (mitya57) wrote :

Since Ubuntu Netbook 10.10 uses Unity in which it's fixed, mark as Fix Released

Changed in window-picker-applet (Ubuntu):
status: Triaged → Fix Released
affects: window-picker-applet (Ubuntu) → unity (Ubuntu)
affects: window-picker-applet → null
Changed in null:
status: New → Invalid
oriolpont (oriolpont) wrote :

It is fix-released in unity only. The inconsistency of having buttons at the right is still present in window-picker-applet (and note that bug title says 10.04 not 10.10). window-picker-applet is the default in 10.04. Also, it is still useful to many netbook users whose hardware does not meet the requirements of unity.

Changed in unity:
importance: Undecided → Low
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments