Ubuntu

warning spam on stdout: CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed

Reported by Nicolò Chieffo on 2010-03-13
566
This bug affects 121 people
Affects Status Importance Assigned to Milestone
gtk2-engines-murrine (Ubuntu)
Low
Unassigned
Declined for Maverick by Sebastien Bacher
light-themes (Ubuntu)
Medium
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: light-themes

when running amule I get a strange error.
CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed

This messages is printer every 1 second (more or less)
As soon as I go back to Human theme, the error disappears.

Applications known to be affected by this include:
 - amule
 - eclipse
 - emacs23
 - gparted
 - gvim

Reinhard Tartler (siretart) wrote :

confirming bug based on duplicates.

Changed in light-themes (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - amule strange error
+ CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed
description: updated
summary: - CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed
+ warning spam on stdout: CRITICAL **: murrine_style_draw_box_gap:
+ assertion `height >= -1' failed
Robert Hall (reh07) on 2010-03-20
description: updated
Alex Goretoy (a1g) wrote :

I get this too, it doesn't matter what theme I have set in Appearance, it still does it, I have tested this with multiple themes. Which makes sense :/

Note I only see this in python gui application I run(pygtk?). I haven't seen this anywhere else yet.

I've tried to strace this, but that doesn't take me anywhere. I'm not sure what command to run so I can debug this any further. Sorry if not much help.

Jean-Philippe Orsini (jfi) wrote :

with emacs, it only occurs during startup and each time I switch the buffer.

I only reproduce it with Ambiance and Radiance themes

I provided more information in https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/538541

Robert Hall (reh07) on 2010-03-28
description: updated
Ronny Polley (polley) wrote :

** (Eclipse:8738): CRITICAL **: murrine_style_draw_box: assertion `width >= -1' failed
The program 'Eclipse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 22585 error_code 158 request_code 148 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

This is the message when using eclipse. I tried to close the welcome screen and eclipse crashed with this. Also it crashed while using the autocomplete feature.

jjonny (jonas-nygards) on 2010-04-20
description: updated
Jean-Philippe Orsini (jfi) wrote :

No more reproduce with emacs since I update to 10.04 RC

Fabien Tassin (fta) wrote :

I still get this with emacs (up-to-date Lucid) so it's still there.

Jean-Philippe Orsini (jfi) wrote :

After migration of my laptop from 9.10 to 10.04 final, I reproduce the bug
On my desktop, I don't reproduce the bug

I don't know what can explain it, I have the same kind of packages, same desktop theme (without any modification).

Neal McBurnett (nealmcb) wrote :

This happens for me in emacs23 with a clean install of the released version of Lucid desktop 32-bit (not UNR) on my Dell mini netbook - so there is no dependency on upgrading from beta versions.

Lionel de Sa (orionw9) wrote :

Hi! I got the same problem (Lucid 32-bit - fresh install, acer notebook, Ambiance theme, Emacs GTK).
Such messages appears when I move the mouse around the left part of the Minibuffer (on the up/down arrows), or when I redimension the window.

There may be no link, but we never know (that's why I mention it)... it is sometimes (but not always!) impossible to redimension a window from its middle left/right border. Does that mean there's a problem in the way Ambiance defines windows???

Gerv (gerv) wrote :

Also a problem with the editor 'scite'.

Gerv

S.P.Storck (sstorck) wrote :

For me, the warning spam is on stderr, not stdout. I often launch emacs from the same terminal that I'm executing code in, so the error messages are really annoying.

Below is the workaround I'm using for emacs; hopefully this will be useful to others affected by this.

For bash, add this to ~/.bashrc:
emacs_dn () { emacs $* 2> /dev/null ; }
alias emacs='emacs_dn'

For csh, add this to ~/.cshrc:
alias emacs 'emacs \!* >& /dev/null'

-Scott

Liam O'Reilly (aliam13-2) wrote :

This is also happening on my fresh fully up-to-date 64 bit lucid.

Seeing this bug with a fresh up-to-date lucid install.

Omar (omar.jamil) wrote :

Also seeing this bug when launching emacs from a terminal.

kristian (m-kristian) wrote :

just for the record, I seeing this on my compaq laptop after upgrading to lucid with emacs23 and I start it only via a terminal.

Scot Becker (scot-becker) wrote :

Not seeing this on emacs-snapshot here (default Lucid theme), but seeing it when using a fresh build of the Emacs (24) dev sources w/GTK

cfogelberg (cgf-syntilect) wrote :

I'm seeing this for emacs on a fresh install of lucid and emacs23. It seems I can run eclipse from the menu or terminal and it does not seem to generate error messages in either case. Please let me know if I can perform any further tests to help diagnose the problem.

Seeing this in a local emacs 23.2.1 build on 10.04.

Gregoriz (bb-greg-o-riz) wrote :

Next to I have seen, this bug occures when you change the emacs' window's size. Everytime you change the size of the windows, the message appears in the terminal. Moreover, i've put "scroll-bar" on "None" value and noticed that the message stoped to appear as soon as the scrool bar is off.

Moreover, on my side, this bug occures only when i'm under "Ambiance" or "Radiance" theme.

I hope it will help you to solve it and have to apologize for my bad english ^ ^

See you :)

Jean-Philippe Orsini (jfi) wrote :

After adding:
(scroll-bar-mode 0)
in ~/.emacs I no more have the warnings when using emacs

@gregoriz many thanks for the workaround!

Jean-Philippe Orsini (jfi) wrote :

and it was the explanation of my comment #7 (my .emacs is different in the 2 computers)

Alf (antonio-floresta) wrote :

I have been seeing this same problem on emacs23 on Lucid.
After changing the property below from 0 to 1 in gtkrc the problem has gone.
        GtkRange::trough-under-steppers = 1

Gregoriz (bb-greg-o-riz) wrote :

I'm not sur to understand what you are meaning.

I add this line into my .gtkrc file but it does not work as well. Indeed, I have an error of syntax although i've written the line as you've done.

I've seen another thing concerning emacs. Sometimes, the program seems to be frozen, but after one clic on a menu, the program goes back well.

Don't know if I'm clear enough then I've again one to apologize for my english.

See u

Alf (antonio-floresta) wrote :

Hi Gregoriz.
In my post #22 I meant to say that you probably need to modify the gtkrc of the theme which you are using, in order to change the property value below from 0 to 1:
  GtkRange::trough-under-steppers = 1

For example, if you are using the Ambiance theme you should edit (as root) the file /usr/share/themes/Ambiance/gtk-2.0/grkrc and change the property above on line #41.

I've seen the other problem that you are facing too (emacs does not respond to any command) and my workaround is the same as yours: click on a menu.

Regards
Antonio Floresta

Jakob Schiøtz (schiotz) wrote :

I can confirm that editing /usr/share/themes/Ambiance/gtk-2.0/gtkrc as Alf mentions solves the problem. Thanks!

I do not know that other effects changing this variable may have, but it looks like a solution is now known and the bug could in principle be fixed.

Grepping through the gtkrc files of the other themes show that only Ambiance and Radiance have this variable set to 0, a few have it set to 1, and most do not set it.

/Jakob

David M. Lee (leedm777) wrote :

+1 on Alf's workaround.

dave
<><

Meekohi (meekohi) wrote :

Same problem on a fresh install Ubuntu x64 10.04 and Emacs 23.1.1
Workaround was perfect, thanks!

Charlie Bucket (djgeometry) wrote :

Alf's workaround confirmed

Nicolò Chieffo (yelo3) wrote :

Alf's workaround does not work with amule

skrisman (ssandboxx) wrote :

This also affects the package emacs-snapshot on a fresh install of Lucid Lynx

Bob Kline (bkline) wrote :

Unfortunately Alf's workaround is temporary, as Update Manager wipes out the fix from time to time.

Confirmed with amule and a 10.04 fresh install, using ambiance theme.

jf's workaround of adding '(scroll-bar-mode 0)' (without the quotes) into my ~/.emacs file has worked for me. I use emacs throughout the day, and since this fix it has not peeped once.

psylockeer (psylockeer) wrote :

It also affects me with amule after a fresh install of lucid lynx 64. Didn't see it anywhere else

Marius Gedminas (mgedmin) wrote :

With gvim this happens whenever I have a window that is exactly 1-line high. I have scrollbars enabled.

Changed in light-themes:
status: Unknown → Incomplete
Marius Gedminas (mgedmin) wrote :

This patch when applied to gtk2-engines-murrine (0.90.3+git20100323) disables that warning.

tags: added: patch
Changed in gtk2-engines-murrine (Ubuntu):
importance: Undecided → Low
AshleyD (amd405) wrote :

I get this error message when opening emacs from the terminal (upgrade from 8.04 to 10.04). Additionally, emacs is unreadable, as the text is covered in black and gray lines. (The black and gray lines also appear when opening emacs from the menu).

$ lsb_release -rd
Description: Ubuntu 10.04.1 LTS
Release: 10.04

$ apt-cache policy emacs
emacs:
  Installed: (none)
  Candidate: 23.1+1-4ubuntu7
  Version table:
     23.1+1-4ubuntu7 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages

Changed in light-themes:
importance: Unknown → Low
AshleyD (amd405) wrote :

I also get black and gray lines over the menu items when I use openoffice, but I cannot see any output in the terminal when I open openoffice using:
$ soffice
so I can only guess that it's the same error since it produces the same symptom.

$ apt-cache policy openoffice.org
openoffice.org:
  Installed: (none)
  Candidate: 1:3.2.0-7ubuntu4.1
  Version table:
     1:3.2.0-7ubuntu4.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Packages
        500 http://security.ubuntu.com/ubuntu/ lucid-security/universe Packages
     1:3.2.0-7ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/universe Packages

The error message appears when using emacs all the time, but the black and gray lines appear when I have a second monitor plugged in.

skrisman (ssandboxx) wrote :

This workaround is really a shame, I love to use scrollbars.

AshleyD (amd405) wrote :

The workaround doesn't work for me when using dual monitors

Changed in light-themes:
status: Incomplete → New
Changed in gtk2-engines-murrine (Ubuntu):
status: New → Triaged
dino99 (9d9) wrote :

Needs to be updated due to:
https://mail.gnome.org/archives/commits-list/2010-December/msg04989.html

Assertion : murrine_style_draw .... replaced by murrine_engine_draw ....

related report bug #918631

Andrea Cimitan (cimi) wrote :

Won't fix this

Changed in light-themes (Ubuntu):
status: Triaged → Invalid
no longer affects: light-themes
Paul Sladen (sladen) wrote :

Setting Invalid for Light Themes as it's actually in Murrine. Setting Won't Fix for Murrine as it exists, but won't be seen in normal GUI use. Patches welcomed upstream to Murrine.

Changed in gtk2-engines-murrine (Ubuntu):
status: Triaged → Won't Fix
tags: added: light-themes-q-reviewed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.