ardour menu bar text is unreadable with the radiance theme

Bug #535644 reported by vervelover
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: light-themes

As in title, try to use ardour with radiance theme. In ubuntu, every theme interferes with ardour's own theme in some ways (and this should not happen), but with the radiance theme this is particularly annoying since the text in ardour menu bar becomes completely unreadable.

This bug will affect all Lucid ardour users.

It is also explained here:

http://ardour.org/node/3397#comment-20360

This is an ubuntu bug, not ardour, as ardour should have no interference at all from the system theme.

Revision history for this message
Kenneth Wimer (kwwii) wrote :

the latest updates should fix this

Changed in light-themes (Ubuntu):
status: New → Fix Released
Revision history for this message
vervelover (alessiopangos) wrote :

it's not fixed in 1.5.8 (but I'm using karmic koala with updated murrine)

Changed in light-themes (Ubuntu):
status: Fix Released → New
Revision history for this message
Kenneth Wimer (kwwii) wrote :

On my lucid system, ardour (ardour2-gtk) starts using a custom theme (very ugly) so there is no way to work around this problem afaict

Revision history for this message
vervelover (alessiopangos) wrote :

Ardour should use his own theme for everything, ugly or not it's usable. But in Ubuntu, and only in ubuntu, there seems to be some interaction between ardour own theme and the system theme, and if you use a light theme, like radiance, the menu bar text becomes unreadable.

Other distros do not have this issue.

Revision history for this message
vervelover (alessiopangos) wrote :

Also, this is not a bug of the ardour package, since the bug is there even if you build ardour from source.

Revision history for this message
vervelover (alessiopangos) wrote :

Great! with the latest murrine + light-themes 1.6.0 this annoying bug is gone! Thanks for your great job! BTW the new themes are amazing!

Changed in light-themes (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers