Background gradient improperly oriented on vertical panels

Bug #534582 reported by LarryGrover on 2010-03-08
210
This bug affects 44 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
light-themes
Won't Fix
Undecided
Unassigned
gnome-panel (Ubuntu)
Wishlist
Unassigned
light-themes (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: light-themes

Vertical panels that use the theme background (ambiance or radiance) look weird: the gradient is oriented vertically (appropriate for a horizontal panel), but it should reorient horizontally when the panel is vertical. I will attach a sreenshot showing this.

ProblemType: Bug
Architecture: i386
Date: Mon Mar 8 13:52:04 2010
DistroRelease: Ubuntu 10.04
Package: light-themes 0.1.5.4
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: light-themes
Uname: Linux 2.6.32-15-generic i686

LarryGrover (lgrover) wrote :
LarryGrover (lgrover) wrote :
Linux000 (michael-yoyo) on 2010-03-09
Changed in light-themes (Ubuntu):
status: New → Confirmed
Benjamin Drung (bdrung) on 2010-03-09
Changed in light-themes (Ubuntu):
importance: Undecided → Low
Kenneth Wimer (kwwii) wrote :

This is not a bug in the theme but rather a bug in gnome-panel

Jeff Craig (foxxtrot) wrote :

I would disagree with this being not a theme problem. If you make the size of the panel bigger than the default 24 pixels, then the gradient begins to repeat, which looks off.

Perhaps the answer is that gnome-panel needs to support gradients as a background option (instead of only doing solid colors or background images), or image scaling options, but as it stands, the light-themes begin to have fairly glaring visual problems if you don't use the defaults from the Ubuntu install.

Also an issue with horizontal panels set to more than 24 pixels in height.

summary: - background looks weird on vertical panels
+ Background gradient improperly oriented on vertical panels, not
+ stretched to fit larger horizontal panels
Sense Egbert Hofstede (sense) wrote :

When you create a vertical panel the panel background for the horizontal panel is used. This looks awful. Wasn't there a way to provide a separate background for vertical panels? In that case you only have to turn the gradient 90 degrees.

M (mzmcgrat) wrote :

This happens because theme designers "cheat" by creating their desired panel look as an image. As far as I know, there is no way to theme vertical and horizontal panels individually in a gtk theme. If the theme designer does not use an appropriate image, you get problems when the panel is larger than the image, as in comment #5. If you don't use a solid color for the panel background, you get problems with vertical panels. This really is just one bug in a long list associated with vertical Gnome panels, which is a shame since they make sense to use with widescreen displays.

Otus (jan-varho) wrote :

Note that changing the default application font size from 10 up to something like 16 causes panels to expand, making this bug apparent. That is a very common scenario and may be an accessibility issue.

Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream.
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

Changed in gnome-panel (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Angel Abad (angelabad) on 2010-03-29
Changed in gnome-panel:
importance: Undecided → Unknown
status: New → Unknown
Vish (vish) wrote :

Thanks for sending upstream.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged
cerz (robert-finis) wrote :

Just noting that this bug will affect a lot of netbook users- those narrow screens make vertical panels a necessity.

Changed in gnome-panel:
status: Unknown → New
Vish (vish) wrote :

Lets leave this bug only for vertical panels , Bug #532309 is for horizontal panel scaling issues.

summary: - Background gradient improperly oriented on vertical panels, not
- stretched to fit larger horizontal panels
+ Background gradient improperly oriented on vertical panels
Changed in gnome-panel:
importance: Unknown → Medium
David Given (david.given) wrote :

This is still extant in Maverick.

Andrea Cimitan (cimi) on 2012-04-30
Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Changed in light-themes:
status: New → Won't Fix

It is theme problem...

PanelToplevel.horizontal PanelWidget {
// style for horizontal panel
}

PanelToplevel.vertical PanelWidget {
// style for vertical panel
}

Changed in gnome-panel (Ubuntu):
status: Triaged → Invalid
Changed in gnome-panel:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.