minimise icon out of order

Bug #532271 reported by Dimitri John Ledkov on 2010-03-04
76
This bug affects 19 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: light-themes

Minimise icon is out of order on my machine

It's minimise - maximise - close. See my screenshot in bug #532224.

HalfEmptyHero (halfemptyhero) wrote :

This is extremely awkward to use. I hope it wasn't done on purpose.

FrejSoya (frej) wrote :

It's on purpose, moreover installing light-themes modifies system defaults, (gconf), this it is changed for all themes!

The offending packaged file is: /usr/share/gconf/defaults/90_light-themes
Wit contents,
/apps/metacity/general/button_layout :maximize,minimize,close

Reverting the odd change is basicly done with gconf-editor and changing /apps/metacity/general/button_layout to :minimize,maximize,close

Don't forget the ':'

Andrej Rohaŭ (arohau) on 2010-03-05
Changed in light-themes (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

I'm using 0.1.5.2 and after restart it's fine. I now have maximize, minimize and close order.

Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Matthew Gregg (mcg) wrote :

@frejsoya that does correct the order, but breaks the UI ,rounded corners on the ends of the buttons.

FrejSoya (frej) wrote :

@Mathew, it's because the designer was using wrong button order.

@Dmitrijs,
 not here the offending file is still present and the rounded corners are still broken, compare
/usr/share/gconf/defaults/90_light-themes -> maximize,minimize,close:
with
/usr/share/gconf/schemas/metacity.schemas -> ... <default>menu:minimize,maximize,close</default>...

If the correct standard gnome button order is used the theme is wrong. And i havent seen any reason why ubuntu should change button order. It's a really bad thing to do.

Changed in light-themes (Ubuntu):
status: Invalid → New

On 7 March 2010 13:33, FrejSoya <email address hidden> wrote:
>
> If the correct standard gnome button order is used the theme is wrong.
> And i havent seen any reason why ubuntu should change button order. It's
> a really bad thing to do.
>

light-themes (0.1.5.4) lucid; urgency=low

  * debian/gconf-defaults:
    - correctly set the wm buttons on the left corner

And the current theme layout "max, min, close" on the left hand side
is consistent with mockups.

"gnome button order" is themable so neither are correct or wrong, it's
just what Art team decided to go with ;-)

BTW this is reverse order of mac os where it's "close, min, max" on
the left hand side.....

FrejSoya (frej) wrote :

@Dmitruy

  * It is certainly not part of the the themable properties. GConf is for configuration, not theme.
  * Just because you can change defaults, doesn't mean you should.
  * It will be inconsistent with gnome on other systems, including all previous ubuntu releases.

But please, google for muscle memory and see why this is a really really bad decession.

The task of maximizing/close/minize is such a repeated task that for most users it's a a habit and subconscious. Often users won't even notice that the visual hint (icon) has changed and have a habit of clicking 'leftmost/middle/rightmost'. This is also often refered to as muscle memory - ie your hand remembers where the actions are because you don't consciously think about it.

You don't change button orders or locations unless there is a very very very good reason, and frankly 'because the mockup said so' is not a good reason. Please, I'm not pulling this out of my ass ;).

Also, if the change is because the rounded corners aren't possible in dialogs, because minimize button isn't shown, then patch metacity to allow such a theme.

Kenneth Wimer (kwwii) on 2010-03-07
Changed in light-themes (Ubuntu):
importance: Undecided → Wishlist
Dimitri John Ledkov (xnox) wrote :

@FrejSoya =) This turns into a conversation now but anyhow ;-)

On 7 March 2010 19:18, FrejSoya <email address hidden> wrote:
> @Dmitruy
>
>  * It is certainly not part of the the themable properties. GConf is for configuration, not theme.

Hmmm. I'll take that back, light-themes package does change *metacity*
default for all themes not just when ambiance/radiance is enabled. My
fault for not checking that more thoughtfully.

>  * Just because you can change defaults, doesn't mean you should.
>  * It  will be inconsistent with gnome on other systems, including all previous ubuntu releases.
>

+1 it sets us apart from the rest ;-)

> But please, google for muscle memory and see why this is a really really
> bad decession.
>

I'm aware of muscle memory, but because I've switched from Mac and
still dual boot Mac quite often I welcome this change ;-)

>
> You don't change button orders or locations unless there is a very very
> very good reason, and frankly 'because the mockup said so' is not a good
> reason.  Please, I'm not pulling this out of my ass ;).
>

I've heard (ubuntu planet?) that one of the reasons was that OSDnotify
popups are in the top right corner and this way there is less chance
of "blurring" them out since now your mouse most likely will not do
anything there. "Click through" is a harder concept to grasp then
"close button is over there and nothing will cover it up"

> Also, if the change is because the rounded corners aren't possible in
> dialogs, because minimize button isn't shown, then patch metacity to
> allow such a theme.
>

This definitely needs patching =) It looks like the artistic concept
for this theme was worked out first and only later it was engineered.

FrejSoya (frej) wrote :

@Wimmer it's not a feature request, It's a severe which is going to cause problems, just like a crasher.
You just can't change the ordering because the theme/mockup needs it. If you can't fix metacity in time, then change the theme.

Sorry if I don't understand the importance classification correctly.

FrejSoya (frej) wrote :

I just read the duplicate bug report. That's about left/right placement, which might be more visible but far from as bad as changing the order but not the position.I couldn't care less about the position, i have not seen any studies that imply anything is better than the other.

In short:
  * This bug report is about the changing the button order,
  * The duplicate bug is about position.

I'm sorry if I didn't make it clear, but there is a big difference. Thus it would be nice if you could remove duplicate status. I'm trying to avoid the flamefest about left vs right... (boring...).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers