Dark text on Dark background dropdown list firefox

Bug #532259 reported by Dimitri John Ledkov on 2010-03-04
252
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Dust theme
Undecided
James Schriver
Hanso Theme
Undecided
James Schriver
light-themes (Ubuntu)
High
James Schriver

Bug Description

Binary package hint: light-themes

See screenshot

The omni-bar in firefox. Notice that the links are blue on dark background and are very hard to read.

Maybe a bug in firefox-ubuntu

Dimitri John Ledkov (xnox) wrote :
Kiwinote (kiwinote) on 2010-03-04
Changed in light-themes (Ubuntu):
status: New → Confirmed
tags: added: indicator-application
Jorge Castro (jorge) on 2010-03-05
tags: removed: indicator-application
Changed in light-themes (Ubuntu):
importance: Undecided → Low
Kenneth Wimer (kwwii) on 2010-03-09
Changed in light-themes (Ubuntu):
importance: Low → High
assignee: nobody → Alexander Sack (asac)
Per Ångström (autark) on 2010-03-11
summary: - Dark text on Dark backround dropdown list firefox
+ Dark text on Dark background dropdown list firefox
Kenneth Wimer (kwwii) on 2010-03-11
tags: added: gloam

This problem has every single "dark" GTK theme. By dark i mean dark menubar, menus etc. There is only one way how to fix this. Using custom Firefox userChrome.css file. Like the one bundled for example with Shiki-Colors murrine version.

http://gnome-look.org/content/show.php/Shiki-Colors?content=86717

CristianCantoro (kikkocristian) wrote :

Other programs are affected by this, for example Skype presents black text in menus which is completely unreadable with the dark theme. Probably this is a bug in skype... (v. 2.1.0.81-1) but it is in the medibuntu repo if I am not wrong...

godhika (godhika) wrote :

As for Skype, you have to change in options --> appearance from clearlooks to Gtk+ or desktop settings

Nicolò Chieffo (yelo3) wrote :

Also openoffice has this problem

Scott Ritchie (scottritchie) wrote :

Here's an equally bad thing that happens if you move the quick launch toolbar to take up less vertical space.

David Barth (dbarth) wrote :

Milestoning that for beta-2 with Ivanka

Changed in light-themes (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
James Schriver (dashua) on 2010-03-24
Changed in light-themes (Ubuntu):
assignee: Alexander Sack (asac) → James Schriver (dashua)
status: Confirmed → Fix Committed
James Schriver (dashua) wrote :

Should be much easier to read now.

Not sure I like the color of the link text. Maybe a light tannish brown to fit better with Ambiance?

Jak696 (from-the-darkest-past) wrote :

I think this color used with Ambiance doesn't look well integrated, too.

James Schriver (dashua) wrote :

Pull again. Light tan to fit selected_bg_color.

Bernhard (b.a.koenig) wrote :

Isn't is too bright? Brown might be nice but this is too close to the white from the site titles.

Much better. And @Bernhard, to me the link text is noticeably darker than the site titles.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.6.0

---------------
light-themes (0.1.6.0) lucid; urgency=low

  * Adding more button images to solve problems with focused vs ufocused
  * Adding button layout to index.theme to fix appearance capplet problem
  * Adding code to make the terminal theme without a profile
  * Ambiance/Radiance: Fix windows control's right alignment (LP: #548532).
   - Fix trough transparency (LP: #548468).
   - Adjust scrollbar contrast with more distinct borders/add active slider (LP: #537375).
   - Fix menubaritemstyle = 0 (LP: #548735).
  * Ambiance: Fix dropdown list firefox (LP: #532259).
  * Radiance: Fix panel bg[ACTIVE] (LP: #536844).
 -- Kenneth Wimer <email address hidden> Fri, 26 Mar 2010 15:13:30 +0000

Changed in light-themes (Ubuntu):
status: Fix Committed → Fix Released
James Schriver (dashua) on 2010-03-27
Changed in dusttheme:
status: New → Fix Committed
assignee: nobody → James Schriver (dashua)
Changed in hanso:
status: New → Fix Committed
assignee: nobody → James Schriver (dashua)
milestone: none → 0.8
Pascal de Bruijn (pmjdebruijn) wrote :

I just noticed this update... But to me the actual problem is having a dark dropdown box in the first place...

Well there a lot of other black "boxes" in the Ambiance theme. Mainly tooltips. So a black dropdown box in firefox is fitting.

I feel like the orange/red link text is also terribly difficult to read. Why couldn't the links be that cream/light brown color that the text above it (page title) is? Orange/red on black/gray is extremely difficult to read, and the link text is extremely important to be able to read in the "awesome bar".

Jak696 (from-the-darkest-past) wrote :

Jonathan, you preceded me, I think the same thing.
a fix was previously released and the text was readable and nice since few days ago, why has it been changed in red?
for me is difficult and annoying to read too...

Mannerheim (mannerheim) wrote :

I have to agree. The prior version was easier on the eyes.

Matt Giuca (mgiuca) wrote :

I agree with the previous 3 comments.

I just came on here to file a bug against the new orange text, which I thought was a bug because it's even harder to read than blue. (I may as well attach the screenshot I had prepared.) I don't see why it can't be white or light grey. There's nothing left in Firefox which is orange (except the back buttons) so I don't see why the orange colour was introduced back into the theme. Ubuntu is mostly going for a white-on-black look, so maybe make the URLs white or light grey.

Matt Giuca (mgiuca) wrote :

Actually, James Schriver's Screenshot-1.png is spot on. I don't care that it looks too much like the titles (isn't it obvious which is a title and which is a URL?)

My thought is the orange text is supposed to match the color of the
"X" (close) button and the color of focused form input boxes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers