indicator-sound does not respect theme

Bug #532234 reported by Kiwinote on 2010-03-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Dust theme
Undecided
James Schriver
Indicator Display Objects
Fix Released
Undecided
Cody Russell
community-themes
Undecided
Kenneth Wimer
ido (Ubuntu)
Low
Unassigned
Lucid
Low
Sebastien Bacher
light-themes (Ubuntu)
Low
James Schriver
Lucid
Low
Unassigned

Bug Description

TESTCASE:
* install community-themes
* set the desktop theme to the wasp-murrine theme.
* click on the volume indicator

The background has not the right color before the update, it's correct after it

Kiwinote (kiwinote) wrote :
Dimitri John Ledkov (xnox) wrote :

Please explain?

See screenshot it looks like it behaves perfectly fine.

The background of the slider should be dark, rather than having a light box
around the slider.

On Thu, Mar 4, 2010 at 10:52 PM, Dmitrijs Ledkovs
<email address hidden>wrote:

> Please explain?
>
> See screenshot it looks like it behaves perfectly fine.
>
> ** Attachment added: "sound-applet.png"
> http://launchpadlibrarian.net/40205171/sound-applet.png
>
> --
> [ambiance] indicator-sound does not respect theme
> https://bugs.launchpad.net/bugs/532234
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thank you for your bug report, the issue is an ido one and should be fixed with today updates

Changed in light-themes (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Kiwinote (kiwinote) on 2010-03-05
Changed in indicator-sound:
status: New → Fix Released
tekstr1der (tekstr1der) wrote :

This is not fixed yet. See attached screenshot.

$ apt-cache policy indicator-sound
indicator-sound:
  Installed: 0.1.3.1-0ubuntu1
  Candidate: 0.1.3.1-0ubuntu1
  Version table:
 *** 0.1.3.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

tekstr1der (tekstr1der) on 2010-03-13
Changed in indicator-sound:
status: Fix Released → Incomplete
tekstr1der (tekstr1der) wrote :

Should I file a separate bug for this for each theme? This is fixed for ambiance, but still broken on others. See above screenshot.

Conor Curran (cjcurran) on 2010-03-17
Changed in indicator-sound:
assignee: nobody → Kenneth Wimer (kwwii)
Conor Curran (cjcurran) wrote :

Ken, Can I close this bug ?

tekstr1der (tekstr1der) wrote :

Does that mean this is a WONT_FIX? Since it got assigned, I thought it was still being worked on. Seems silly to file a separate bug for the same issue at hand, as shown in my screenshot.

tekstr1der (tekstr1der) on 2010-03-23
summary: - [ambiance] indicator-sound does not respect theme
+ indicator-sound does not respect theme
James Schriver (dashua) on 2010-03-30
Changed in dusttheme:
assignee: nobody → James Schriver (dashua)
status: New → Fix Committed
tekstr1der (tekstr1der) wrote :

Does this need to be fixed in each theme individually? Seeing the issue with Wasp-Murrine.

James Schriver (dashua) on 2010-03-30
Changed in light-themes (Ubuntu):
assignee: nobody → James Schriver (dashua)
status: Invalid → Fix Released
tekstr1der (tekstr1der) wrote :

Looks like this bug is going to slip into the release. Since it is only cosmetic, does that exclude it from ever possibly being fixed as a SRU?

Conor Curran (cjcurran) on 2010-04-26
Changed in indicator-sound:
assignee: Kenneth Wimer (kwwii) → Conor Curran (cjcurran)
affects: indicator-sound → ido
Cody Russell (bratsche) wrote :

What's going on here? I thought we fixed this months ago. Can someone confirm that it's still broken *today* with latest updates, and also please specify what theme you're using?

Conor Curran (cjcurran) wrote :

Cody sorry I just reassigning to your project as it was you who provided the fix. Marked as fix completed and also assigned you to it.

Changed in ido:
status: Incomplete → Fix Committed
assignee: Conor Curran (cjcurran) → Cody Russell (bratsche)
tekstr1der (tekstr1der) wrote :

I can confirm that this is NOT fixed in latest Lucid using wasp-murrine theme as seen in screenshot in comment #5. I previously added the community-themes project as affected. I also asked if this needs to be reported separately in another bug (comment #9)?

Conor Curran (cjcurran) on 2010-04-26
Changed in community-themes:
assignee: nobody → Kenneth Wimer (kwwii)
Bertel King (kmetamorphosis) wrote :

I just install community-themes today and can also confirm that this is not fixed. I am using the wasp-murrine theme.

Sebastien Bacher (seb128) wrote :

the r34 on https://code.edge.launchpad.net/~canonical-dx-team/ido/trunk is supposed to fix the issue

Changed in ido (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :
Changed in light-themes (Ubuntu Lucid):
status: New → Fix Released
importance: Undecided → Low
Changed in ido (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Fix Committed
description: updated
Sebastien Bacher (seb128) wrote :

the issue is fixed with ido 0.1.6, thanks Cody!

Changed in ido:
status: Fix Committed → Fix Released

Accepted ido into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tekstr1der (tekstr1der) wrote :

Thanks! I confirm ido 0.1.6 fixes this issue with community-themes.

Martin Pitt (pitti) on 2010-06-10
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 0.1.6-0ubuntu1

---------------
ido (0.1.6-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version fixing indicator-sound theming issues (lp: #532234)
 -- Sebastien Bacher <email address hidden> Tue, 08 Jun 2010 19:39:32 +0200

Changed in ido (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to maverick

Changed in ido (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

the update created the issue on bug #595435

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers