Disabling screen lock is not possible

Bug #1287255 reported by Sebastian F on 2014-03-03
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
light-locker (Ubuntu)
Medium
Unassigned

Bug Description

I have disabled the following options:
"Lock screen when going for suspend/hibernate" in Settings -> Power Manager -> Extended
"Lock screen before sleep" in Settings -> Session -> Advanced

But the screen gets locked anyway, after every suspend/hibernate or every time the monitor goes to sleep.
xscreensaver is disabled (the behaviour was the same with xscreensaver enabled)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-power-manager 1.2.0-3ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-14.34-generic 3.13.5
Uname: Linux 3.13.0-14-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Mar 3 17:34:29 2014
InstallationDate: Installed on 2014-02-28 (3 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140225)
SourcePackage: xfce4-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Sebastian F (sf-lp) wrote :
affects: xfce4-power-manager (Ubuntu) → light-locker (Ubuntu)

light-locker is the new screen locking program in Xubuntu 14.04. A simple configuration utility will be available soon.

Light-locker Settings UI -> https://launchpad.net/light-locker-settings

In the meantime, simply deactivate light-locker to disable screen locking (settings manager > session and startup > application autostart).

Sebastian F (sf-lp) wrote :

Thanks for the quick response! I hadn't realized that light-locker is used for 14.04 - disabling it is a good temporary solution for me.

Sebastian F (sf-lp) wrote :

Is it possible to hide the configuration options mentioned above in Xubuntu? I think it's already confusing that there are two of them in Xfce.

Simon Steinbeiß (ochosi) wrote :

> Is it possible to hide the configuration options mentioned above in Xubuntu? I think it's already confusing that there are two of them in Xfce.
Unfortunately that's not as easy, it would mean patching a few components of Xfce-core and we don't have enough developers as it is.

The settings in xfce4-power-manager and xfce4-session are currently not taken into account, because as you've mentioned, they're duplicate and it's not clear which one we should evaluate.
With light-locker-settings you get some control over the lock-behavior, but currently light-locker always locks the session on suspend. Maybe we'll make that configurable in the future within light-locker, then there'll be an obvious way to control it.

Closing this bugreport as Invalid meanwhile, as it's not really a bug, but expected behavior.

Changed in light-locker (Ubuntu):
status: New → Invalid
Richard Elkins (texadactyl) wrote :

"lock automatically after screensaver" is a switch. This switch does not work as the creator of this bug report stated. So it really is a bug.

Two possible solutions IMO:
(a) Fix the code so that the switch works as advertised.
(b) Remove the switch.

Please do not leave light-locker as it is because light-locker is enabled by default in Xubuntu 14.04 (why should our users go through the same guessing game?).

Changed in light-locker (Ubuntu):
status: Invalid → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1287255

tags: added: iso-testing
Simon Steinbeiß (ochosi) wrote :

> "lock automatically after screensaver" is a switch. This switch does not work as the creator of this bug report stated. So it really is a bug.

You seem to be mixing things up, the OP never talked about light-locker-settings and only referred to xfce4-session and xfpm settings.

Could you clarify what it is exactly that doesn't work?

Richard Elkins (texadactyl) wrote :

Go to Settings Manager > Light Locker Settings. This brings up the settings panel. There is clearly a switch entitled "Lock automatically after screensaver". This switch does not function in the OFF setting. Once time runs out as governed by the "Screensaver" parameters on the same panel, the screensaver runs. Whether the "Lock automatically after screensaver" switch is ON or OFF, the screen is locked and a password is required to resume the session.

In the OFF position, the screen should *not* be locked when the operator wakes up the machine from the screensaver.

Two possible solutions IMO:
(a) Fix the code so that the switch works as advertised.
(b) Remove the switch.

It has a moderate impact on a core package.

Changed in light-locker (Ubuntu):
importance: Undecided → Medium
Simon Steinbeiß (ochosi) wrote :

The most recent version of light-locker, 1.4.0, was recently uploaded to Trusty and it addresses the issue of not being able to deactivate light-locker on suspending. This is also reflected in light-locker-settings, where you'll find a new switch to disable this behavior.

Note: currently the options in xfpm, xfce4-session and light-locker-settings aren't yet in sync (there's a separate bugreport for that), but we're working on it. Anyhow, this bug – as reported – is fixed.

Changed in light-locker (Ubuntu):
status: Confirmed → Fix Released
Richard Elkins (texadactyl) wrote :

Can no longer reproduce symptoms.

zzarko (zzarko-gmail) wrote :

Disabling Lock in Brightness and Lock settings in 14.04.1 64bit with Unity does nothing. Disabling it from light-locker-settings works.

BRF (bigredfed) wrote :

Disabling in Light Locker settings on lubuntu 14.04, lightlocker version 1.2.1 works, but on restart the setting is not honored so it has to be enabled/disabled again.

Tadas (tadslot) wrote :

rm /etc/xdg/autostart/light-locker.desktop helped for me

I believe the problem is that the user-specific .desktop file, ``~/.config/autostart/light-locker.desktop`` does not override the the system wide .desktop file ``/etc/xdg/autostart/light-locker.desktop``.

When the user changes the light-locker settings to disable light-locker, I believe what happens is that ``~/.config/autostart/light-locker.desktop`` is edited/created so the there is a blank ``Exec=`` line. That is, light-locker is not started.

However, even if light-locker is disabled in the user-specific file, it is still started (with the default configuration) by the system-wide light-locker.desktop file.

The workaround that worked for me was to rename ``/etc/xdg/autostart/light-locker.desktop`` to ``/etc/xdg/autostart/light-locker.desktop.bak``.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers