[SRU] Light-locker-settings crash on startup

Bug #1574544 reported by Jani Alinikula on 2016-04-25
114
This bug affects 45 people
Affects Status Importance Assigned to Milestone
light-locker-settings
Undecided
Unassigned
light-locker-settings (Ubuntu)
High
Julien Lavergne
Xenial
High
Simon Quigley

Bug Description

[Impact]

Getting this fix in Xenial would allow for the user to use light-locker-settings again, without this fix, light-locker-settings is unusable.

[Test Case]

Open a terminal and type the following:

$ light-locker-settings

If the bug is fixed, light-locker-settings should launch normally.

[Regression Potential]

The regression potential is low because it's a trivial fix that upstream has already adopted.

[Original bug description]

I installed Xubuntu 16.04 as a new installation, and light-locker-settings cannot be opened. Starting from command line I get a following backtrace:

/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py:29: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GLib, Gio
Traceback (most recent call last):
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 697, in <module>
    main = LightLockerSettings()
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 98, in __init__
    self.init_settings()
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 454, in init_settings
    if self.check_running_process("xfce4-power-manager"):
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 219, in check_running_process
    for pid in psutil.get_pid_list():
AttributeError: 'module' object has no attribute 'get_pid_list'

There is a similar backtrace in #1323807, but the original case seems different.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker-settings (Ubuntu):
status: New → Confirmed

Upstream psutil had some changes, the fix for this is fairly simple.

Line 219 and 234 need to be changed from psutil.get_pid_list() to psutil.pids()

Sean Davis (bluesabre) wrote :
Changed in light-locker-settings:
status: New → Fix Committed
AZ (m-dev) on 2016-06-18
tags: added: patch-accepted-upstream
Julien Lavergne (gilir) on 2016-07-17
Changed in light-locker-settings (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker-settings (Ubuntu Xenial):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1574544

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-locker-settings - 1.5.0-0ubuntu2

---------------
light-locker-settings (1.5.0-0ubuntu2) yakkety; urgency=medium

  * debian/patches:
   - 90_newer_version_psutil.patch: From upstream, fix a crash with a newer
     version of psutil. (LP: #1574544).

 -- Julien Lavergne <email address hidden> Sun, 17 Jul 2016 10:17:00 +0200

Changed in light-locker-settings (Ubuntu):
status: In Progress → Fix Released
Simon Quigley (tsimonq2) on 2016-07-20
description: updated
summary: - Light-locker-settings crash on startup
+ [SRU] Light-locker-settings crash on startup
Changed in light-locker-settings (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
status: Confirmed → In Progress
Simon Quigley (tsimonq2) wrote :

Attached is the patch for Xenial.

Changed in light-locker-settings (Ubuntu Xenial):
importance: Undecided → High

Hello Jani, or anyone else affected,

Accepted light-locker-settings into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/light-locker-settings/1.5.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in light-locker-settings (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Simon Quigley (tsimonq2) wrote :

This fix works fine.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-locker-settings - 1.5.0-0ubuntu1.1

---------------
light-locker-settings (1.5.0-0ubuntu1.1) xenial; urgency=medium

  * debian/patches:
   - 90_newer_version_psutil.patch: From upstream, fix a crash with a newer
     version of psutil. (LP: #1574544).

 -- Simon Quigley <email address hidden> Tue, 19 Jul 2016 20:10:23 -0500

Changed in light-locker-settings (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for light-locker-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Simon Quigley (tsimonq2) on 2016-07-20
Changed in light-locker-settings:
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1574544

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers