Switch off (dpms) time maybe overwritten by xfce power manager

Bug #1290737 reported by b3nmore on 2014-03-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
light-locker-settings
Undecided
Sean Davis
light-locker-settings (Ubuntu)
Undecided
Sean Davis

Bug Description

The monitor switch off time (dpms) has no effect (or gets overwritten), if xfce power manager is setup to control monitor power management. So light-locker-settings should probably have some way to handle this. Following comes to my mind: use xfconf to either disable dpms in xfpm or sync timings (although then you will need to somehow map 1 timing to the 4 timings xfpm uses).

Related branches

Changed in light-locker-settings (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

Yes, this is unfortunately true, i.e. we were aware of that conflict.

I'm not sure how we can map those 4 settings to 1 in a sensible way. In my mind, those users that find out about the conflict will hopefully be able to make sense of it (i.e. use only xfpm to set that timeout if you want the "sophisticated" power-based version or the simplistic version that light-locker-settings offers).

For T+1 we'll have to improve this somehow, either make xfce4-power-manager handle it all (it has been unmaintained for a long time now) or find a way to deal with the two settings.

b3nmore (b3nmore) wrote :

I've attached a module, which can be used to set/get dpms timings via xfce4-power-manager. It uses /sys/class/power_supply/AC/online to determine the power state if existent or assumes on-ac otherwise.

b3nmore (b3nmore) wrote :

Adapted light-locker-settings.py which uses the new module if xfpm is running.

b3nmore (b3nmore) wrote :

If xfce4-power-manager has never been used to change dpms settings, the default timings are not registered in xfconf. This version makes sure, that the xfconf properties we use, are created if necessary.

b3nmore (b3nmore) wrote :

Same as in #3, but using a more pythonic way.

b3nmore (b3nmore) wrote :

Same as in #4, but using a more pythonic way.

2 remarks:
1) One could easily sync the 'Lock screen when going for suspend/hibernate' setting of xfpm with the enable/disable light-locker setting (or even the lock screen setting in the session settings). However this would be a one way sync, since disabling it in xfpm would not disable light-locker.
2) Xfpm seems to have a very weird bug in that way, that changes made via xfconf are applied, but not reflected by the xfpm ui, unless one had used the ui to changes those settings before. E.g. if one never used the sliders to change dpms timings and one changes the timings via xfconf, xfpm applies the changes but does not adapt its ui to the changes.

Sean Davis (bluesabre) on 2014-04-02
Changed in light-locker-settings:
assignee: nobody → Sean Davis (smd-seandavis)
status: New → In Progress
Sean Davis (bluesabre) wrote :

Fixed upstream in light-locker-settings 1.2.1

Changed in light-locker-settings:
status: In Progress → Fix Committed
milestone: none → 1.2.1
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-locker-settings - 1.2.1-0ubuntu1

---------------
light-locker-settings (1.2.1-0ubuntu1) trusty; urgency=medium

  * New upstream release. (LP: #1302484)
    - Fixes XFCE Power Manager setttings sync (LP: #1290737)
 -- Sean Davis <email address hidden> Fri, 04 Apr 2014 06:46:52 -0400

Changed in light-locker-settings (Ubuntu):
status: Confirmed → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in light-locker-settings (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints