liferea is built without libindicate support in Precise

Bug #976120 reported by Chow Loong Jin on 2012-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)
Undecided
Unassigned

Bug Description

`apt-cache depends liferea | grep libindicate' reveals nothing, indicating that liferea itself is not linked against libindicate, and it does not show its entries in the messaging indicator as it did in Oneiric.

This is because the HAVE_LIBINDICATE macro defined in configure.ac via AC_DEFINE is not included into ui_indicator.c.

Related branches

Chow Loong Jin (hyperair) wrote :

Here's a debdiff that includes two patches to fix this issue. The other patch changes the indicate_indicator_set_property_icon() call to indicate_gtk_indicator_set_property_icon().

Changed in liferea (Ubuntu):
status: New → Confirmed
Maia Everett (linneris) wrote :

As the original author of the libindicate patch, I can confirm Chow's patch works as intended in precise. Need a sponsor to upload it to main.

Marc Deslauriers (mdeslaur) wrote :

ACK on the debdiff. This restores indicator functionnality that was broken with a late Precise liferea upload. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package liferea - 1.8.3-0.1ubuntu2

---------------
liferea (1.8.3-0.1ubuntu2) precise; urgency=low

  * debian/patches:
    - port-to-libindicate-0.7.patch: Replace deprecated
      indicate_indicator_set_property_icon() call with
      indicate_gtk_indicator_set_property_icon() (LP: #976120)
    - indicator_include_config.h.patch: Include config.h for HAVE_LIBINDICATE
      macro
 -- Chow Loong Jin <email address hidden> Sun, 08 Apr 2012 02:13:07 +0800

Changed in liferea (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers