Current drap and drop implementation causes new broken subscriptions

Bug #518801 reported by Mikko Rantalainen on 2010-02-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: liferea

Steps to reproduce:

1) Subscribe something (make sure that some item in the feeds contains at least a few lines of text in the description)
2) Select a few lines of text in the bottom right panel (the preview/feed item content display)
3) Click above the selected text, hold the mouse button down, move the mouse a couple of pixels in random direction and release the button (pretty easy to do by mistake if something is already selected and you click the window to focus it and slightly move the mouse by mistake while the button is down)

Actual results:

One or more "New subscription" feeds appear in the feeds panel and if I try to select any of those, I'll get following in the preview/feed content display panel:

The last update of this subscription failed!
HTTP error code 404: Resource Not Found
Feed: New Subscription
Source: [the actual contents of the selected text here]

It seems that the number of "new subscription" feeds depend on the selected text, perhaps one new subscription per line of text or something like that?

Expected results:

Something sensible, possible choices include:

- do nothing (liferea does not need to accept drag and drop)
- an error dialog saying "unknown protocol: here's some text"
- a confirmation dialog saying something along the lines "Subscribe to feed from address 'here's some text'?" with buttons "Subscribe" and "Cancel".
- do nothing (do not accept multiline text input ever in drag and drop, accept only single line text input which starts with letters "http:" or "https:" (or whatever protocols the current version supports)
- try to load the new subscription silently and if the resource does not seem to be a supported subscription type, display an alert
- only accept drag and drop in the feeds panel (never in the headline/summary/list panel or in the preview/content panel) and in addition implement one of the choices above

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: f0bf0101e3df07a87acfbc156f0db03d
CheckboxSystem: b5acb6c9ca4017b1d44043910f45329d
Date: Mon Feb 8 13:36:16 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate amd64 (20091020.3)
Package: liferea 1.6.0-1ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.152-rt
SourcePackage: liferea
Uname: Linux 2.6.31-9-rt x86_64

Related branches

Mikko Rantalainen (mira) wrote :
Mikko Rantalainen (mira) wrote :

The fix for this bug has been fixed in SVN and will be included in the Liferea release 1.6.3

See: http://sourceforge.net/mailarchive/message.php?msg_name=520b27411002081417m9d22388yd4db13cbf3a295c0%40mail.gmail.com

The svn commit seems to be r5300:
http://liferea.svn.sourceforge.net/viewvc/liferea?view=rev&revision=5300
It's a one line fix in the source, perhaps this could be fixed as 1.6.0-1ubuntu3 package?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package liferea - 1.6.2-1ubuntu3

---------------
liferea (1.6.2-1ubuntu3) lucid; urgency=low

  * debian/patches/fix-dnd-bug: fix drag and drop bug that was creating
    spurious new subscriptions. (LP: #518801)
  * debian/patches/01_ubuntu_feedlists: updated some outdated feeds
    (LP: #341969)
 -- Marc Deslauriers <email address hidden> Tue, 02 Mar 2010 18:20:36 -0500

Changed in liferea (Ubuntu):
status: New → Fix Released
Marc Deslauriers (mdeslaur) wrote :

The patch was reverted upstream, and in new packages I just uploaded, as it caused drag and drop reordering of the feed list to not function correctly.

Changed in liferea (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers