liferea crashes when trying to read certain posts from a particular RSS feed

Bug #502186 reported by Christopher Meyer on 2010-01-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libsoup
Fix Released
Critical
liferea (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: liferea

I use liferea as my RSS feed reader on Ubuntu 9.10 i386 on a 10.1" netbook. The app only crashes when trying to read some posts of a specific RSS feed I subscribe to.

Additional details:
1) lsb_release -rd:
Description: Ubuntu 9.10
Release: 9.10

2) liferea:
  Installed: 1.6.0-1ubuntu2
  Candidate: 1.6.0-1ubuntu2
  Version table:
 *** 1.6.0-1ubuntu2 0
        500 http://gb.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

3) Expecting to be able to read the post

4) Liferea crashed & the window closed

Below is output gathered by liferea when it crashed when started from the console as `liferea --debug-all':

Liferea did receive signal 11 (Segmentation fault).
You have propably triggered a program bug. I will now try to
create a backtrace which you can attach to any support requests.

#0 0x00bc3422 in __kernel_vsyscall ()
#1 0x00b93b3b in waitpid () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x00586bf3 in g_on_error_stack_trace () from /lib/libglib-2.0.so.0
#3 0x08078abc in ?? ()
#4 <signal handler called>
#5 0x005ce047 in g_str_hash () from /lib/libglib-2.0.so.0
#6 0x0059bb78 in g_hash_table_lookup () from /lib/libglib-2.0.so.0
#7 0x0012bafe in soup_cookie_jar_add_cookie () from /usr/lib/libsoup-2.4.so.1
#8 0x0012bd1b in soup_cookie_jar_set_cookie () from /usr/lib/libsoup-2.4.so.1
#9 0x0174c2f0 in ?? () from /usr/lib/libwebkit-1.0.so.2
#10 0x01258cdb in ?? () from /usr/lib/libwebkit-1.0.so.2
#11 0x017cfe3e in ?? () from /usr/lib/libwebkit-1.0.so.2
#12 0x017d24bd in ?? () from /usr/lib/libwebkit-1.0.so.2
#13 0x0102d5c8 in ?? () from /usr/lib/libwebkit-1.0.so.2
#14 0x0694ec86 in ?? ()
#15 0x01035b88 in ?? () from /usr/lib/libwebkit-1.0.so.2
#16 0x010b211f in ?? () from /usr/lib/libwebkit-1.0.so.2
#17 0x011af67a in ?? () from /usr/lib/libwebkit-1.0.so.2
#18 0x013e8801 in ?? () from /usr/lib/libwebkit-1.0.so.2
#19 0x012a1e4c in ?? () from /usr/lib/libwebkit-1.0.so.2
#20 0x001a0d70 in ?? () from /usr/lib/libxml2.so.2
#21 0x001ae05c in ?? () from /usr/lib/libxml2.so.2
#22 0x001af8d5 in xmlParseChunk () from /usr/lib/libxml2.so.2
#23 0x0129f60b in ?? () from /usr/lib/libwebkit-1.0.so.2
#24 0x0129dfa1 in ?? () from /usr/lib/libwebkit-1.0.so.2
#25 0x013ec4e6 in ?? () from /usr/lib/libwebkit-1.0.so.2
#26 0x013ec917 in ?? () from /usr/lib/libwebkit-1.0.so.2
#27 0x00fbae17 in ?? () from /usr/lib/libwebkit-1.0.so.2
#28 0x013e7727 in ?? () from /usr/lib/libwebkit-1.0.so.2
#29 0x013d63cc in ?? () from /usr/lib/libwebkit-1.0.so.2
#30 0x013e7d85 in ?? () from /usr/lib/libwebkit-1.0.so.2
#31 0x01402449 in ?? () from /usr/lib/libwebkit-1.0.so.2
#32 0x0140b39c in ?? () from /usr/lib/libwebkit-1.0.so.2
#33 0x01402694 in ?? () from /usr/lib/libwebkit-1.0.so.2
#34 0x01406106 in ?? () from /usr/lib/libwebkit-1.0.so.2
#35 0x014062be in ?? () from /usr/lib/libwebkit-1.0.so.2
#36 0x013f2a24 in ?? () from /usr/lib/libwebkit-1.0.so.2
#37 0x0140461c in ?? () from /usr/lib/libwebkit-1.0.so.2
#38 0x01403220 in ?? () from /usr/lib/libwebkit-1.0.so.2
#39 0x01406e21 in ?? () from /usr/lib/libwebkit-1.0.so.2
#40 0x01495981 in ?? () from /usr/lib/libwebkit-1.0.so.2
#41 0x014959e2 in ?? () from /usr/lib/libwebkit-1.0.so.2
#42 0x0173a35e in ?? () from /usr/lib/libwebkit-1.0.so.2
#43 0x005a9101 in ?? () from /lib/libglib-2.0.so.0
#44 0x005aae88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x005ae730 in ?? () from /lib/libglib-2.0.so.0
#46 0x005aeb9f in g_main_loop_run () from /lib/libglib-2.0.so.0
#47 0x0593f419 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#48 0x08078851 in main ()

I've attached backtrace details as per the instructions on the Ubuntu Wiki.

Hope this is useful. Please let me know if there's anything else I can provide.

ProblemType: Bug
Architecture: i386
Date: Fri Jan 1 22:03:48 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/liferea
Package: liferea 1.6.0-1ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: liferea
Uname: Linux 2.6.31-16-generic i686

Christopher Meyer (kungfoosion) wrote :
Christopher Meyer (kungfoosion) wrote :

I did a bit more research on this...

A Gentoo user has reported the same issue using Liferea 1.6.0:
http://sourceforge.net/tracker/index.php?func=detail&aid=2873110&group_id=87005&atid=581684

It has been reported to WebKitGTK+ upstream:
https://bugs.webkit.org/show_bug.cgi?id=31658

Chris

Christopher Meyer (kungfoosion) wrote :

I forgot to mention the work-around to prevents Liferea from crashing in these situations:

Goto "Tools -> Preferences -> Browser". Make sure "Disable Javascript" is ticked.

This works for me after closing and restarting Liferea. Hope this is of use to anyone.

Chris

skorasaurus (skoraw) on 2010-02-05
Changed in liferea (Ubuntu):
status: New → Confirmed
affects: liferea → libsoup
Changed in libsoup:
importance: Unknown → Critical
status: Unknown → Fix Released
Mattia Rizzolo (mapreri) wrote :

I think the issue is now fixed, and the fix release, ages ago.
Feel free to reopen this bug and/or report any bug you'll encounter using Ubuntu.

Changed in liferea (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.