Lifera does not works with Gwget

Bug #371004 reported by Toni on 2009-05-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Liferea
Invalid
Undecided
Unassigned
gwget(2)
Fix Released
High
gwget2 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Toni
liferea (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Toni

Bug Description

Using liferea, and when in a rss channel i tell to download an enclosure, having previously configured to use Gwet as download manager, it does not passes the link to gwget and as result i cannot dowload anything at all.

With plain wget it works ok.

Example running liferea from shell

 $ liferea --debug-all
....
CONF: Setting /apps/liferea/enclosure-download-tool to 2
GUI: launch URL: false true 0
UPDATE: downloading http://media.libsyn.com/media/noticias21/Noticias21.com_2009-03-21_26.mp3 to /home/toni/Noticias21.com_2009-03-21_26.mp3...
UPDATE: running "dbus-send --session --dest=org.gnome.gwget.ApplicationService /org/gnome/gwget/Gwget org.gnome.gwget.Application.OpenURI string:'http://media.libsyn.com/media/noticias21/Noticias21.com_2009-03-21_26.mp3' uint32:0"
....

and nothing added in Gwget window

I later try this command alone but adding vervosity with "--print-reply" to know what is wrong:

* $ dbus-send --session --print-reply --dest=org.gnome.gwget.ApplicationService /org/gnome/gwget/Gwget org.gnome.gwget.Application.OpenURI string:'http://media.libsyn.com/media/noticias21/Noticias21.com_2009-03-21_26.mp3' uint32:0

......
Error org.freedesktop.DBus.Error.UnknownMethod: Method "OpenURI" with signature "su" on interface "org.gnome.gwget.Application" doesn't exist
.......
 and nothing added into Gwget download list

I have ubuntu 9.04, liferea is 1.4.26 and gwget is 1.0.1 , Default Ubuntu 9.04 packages.

I dont know if it may be a gwget issue , but willing to send any info if you cannot replicate it.

Thanks in advance.

Related branches

Sig (sig-akasig) wrote :

I can confirm this bug. I have the same config. I encountered the same issue. I ran the dbus-send commands indicated here for diagnosis and had the same UnknownMethod error message.

A thread on liferea-devel suggests to me that this is due to a mismatch between liferea and the 1.0.1 version of gwget we have on ubuntu 9.04. It used to be working with an older version of gwget (a pre 1.0 version).

Sig (sig-akasig) wrote :
Changed in liferea:
status: New → Confirmed
Changed in liferea (Ubuntu):
status: New → Confirmed
Adrian Bunk (bunk) wrote :

Fixed in http://git.gnome.org/cgit/gwget/commit/?id=b34d1bfffda43ab32f472a8264db8d90dfe13929

gwget 1.0.0 and 1.0.1 are the versions that are incompatible with Liferea.

Emilio Pozuelo Monfort (pochu) wrote :

The bug is in gwget, closing the liferea task.

Changed in gwget2 (Ubuntu):
status: New → Fix Committed
Changed in liferea (Ubuntu):
status: Confirmed → Invalid
Changed in liferea:
status: Confirmed → Invalid
Changed in gwget:
status: Unknown → Fix Released
Artur Rona (ari-tczew) wrote :

I made package gwget 1.0.2. It's available on my-ppa. Please test it for check if bug is fixed with gwget 1.0.2.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwget2 - 1.0.2-0ubuntu1

---------------
gwget2 (1.0.2-0ubuntu1) karmic; urgency=low

  * New upstream release (LP: #390580, #371004).
  * Remove all old patches, fixed upstream.
  * Merge debian-dir with unstable's package.
  * debian/control:
    - Replace gvfs by gio in Build-Depends
    - Add missing Build-Depends on intltool
    - Add git fields
    - Update Standards-Version to 3.8.1
  * debian/copyright: Update copyright years
  * debian/rules:
    - Add -Wl,--as-needed to LDFLAGS to drop useless dependencies
  * debian/watch: Fix typo.

 -- Artur Rona <email address hidden> Fri, 04 Sep 2009 19:44:36 +0200

Changed in gwget2 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gwget:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.