liferea won't take idn urls (non-ascii characters)

Bug #298042 reported by Stefan Bethge on 2008-11-14
4
Affects Status Importance Assigned to Milestone
Liferea
Fix Released
Medium
liferea (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: liferea

I tried adding the url http://www.tobiasfünke.de/tobiblog/?feed=rss2 (which has other problems in firefox as well) and liferea
gives an error: "HTTP Fehlercode 0: URL ist ungültig", so something like: "HTTP error code 0: URL is invalid".
It should correctly handle the valid url (as in rfc 3490). Workaround is converting it myself to http://www.xn--tobiasfnke-geb.de/tobiblog/?feed=rss2.

Emilio Pozuelo Monfort (pochu) wrote :

It works fine with HEAD/webkit

Dimitrios Symeonidis (azimout) wrote :

confirmed, importance=low (I think)

Changed in liferea (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

Emilio Pozuelo Monfort wrote:
> It works fine with HEAD/webkit

Not anymore. For 1.6 and newer, this will only be fixed once
http://bugzilla.gnome.org/show_bug.cgi?id=548287 is, since we now use libsoup
for the networking code.

Changed in liferea:
status: Unknown → New
Changed in liferea (Ubuntu):
status: Confirmed → Triaged
Changed in liferea:
importance: Unknown → Medium
status: New → Fix Released
Mattia Rizzolo (mapreri) wrote :

Looks like fixed.
Feel free to report any other bug you'll encounter using Ubuntu.

Changed in liferea (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.