Liferea won't start iconified anymore

Bug #258521 reported by Nicolas Vandeput on 2008-08-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Liferea
Unknown
Unknown
liferea (Debian)
Fix Released
Unknown
liferea (Ubuntu)
Low
Unassigned

Bug Description

Hi,

I've seen more than one bug about the same problem but they're all closed and minimum one year old, so I think the problem re-appeared.

When I type "liferea --mainwindow-state=iconified" or "liferea --mainwindow-state=iconified" like it is described in the help, it still opens in a maximized window. Here is the terminal output:

nico@vaio ~ $ liferea --mainwindow-state=iconified
Obtaining the module object from Python failed.

Traceback (most recent call last):
cant import cStringIO
<type 'exceptions.ImportError'>: /usr/lib/python2.5/lib-dynload/time.so: undefined symbol: PyExc_ValueError

How can I fix this?

package: liferea (1.4.14-0ubuntu4) (hardy)

Emilio Pozuelo Monfort (pochu) wrote :

Works fine for me in intrepid (both iconified and hidden)

Changed in liferea:
importance: Undecided → Low
gumbler (gumbler) wrote :

"mainwindow-state=iconified" throw the same exceptions as you described and started maximized. But "mainwindow-state=hidden" started liferea just with a little icon (and throws the error message too).

What is the difference between iconified and hidden?

Changed in liferea:
status: New → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

Iconified will open Liferea minimized, and hidden will not show the window at all (you have to open it through the tray icon).

I'll see tomorrow if I can reproduce it in Hardy (I can't in Intrepid).

Emilio Pozuelo Monfort (pochu) wrote :

I've reproduced this in Debian with 1.4.18. I guess I couldn't reproduce it in Intrepid before as I was using 1.4.20 for testing purposes.

I've forwarded it to Debian.

Thanks for your report!

Changed in liferea:
status: Confirmed → Triaged
Changed in liferea:
status: Unknown → Confirmed
KevinM (kevbert1) wrote :

In Jaunty kernel 2.6.28-11-generic 32 bit both mainwindow-state=hidden and mainwindow-state=iconified do not work as liferea is just launched as it would if just issuing 'liferea' in terminal. Liferea version is 1.4.26.

Changed in liferea (Debian):
status: Confirmed → Fix Released
Mattia Rizzolo (mapreri) wrote :

I believe this was fixed ages ago, as the remote bug tracker shows.
Closing as fixed.

Changed in liferea (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.