liferea-add-feed segfault

Bug #1669117 reported by Aaron Skomra on 2017-03-01
This bug affects 2 people
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)

Bug Description

1.Description: Ubuntu 16.04.2 LTS
Release: 16.04
2. liferea:
  Installed: 1.10.17-1ubuntu2
  Candidate: 1.10.17-1ubuntu2
  Version table:
 *** 1.10.17-1ubuntu2 500
        500 xenial/universe amd64 Packages
        100 /var/lib/dpkg/status
3. Expected to add a feed to liferea
4. Instead segfault

To reproduce on Ubuntu 16.04:



Segmentation fault (core dumped)

liferea-add-feed is just a script calling liferea --add-feed

This looks like it may be fixed in later releases of liferea:

If I run in gdb:

Thread 1 "liferea" received signal SIGSEGV, Segmentation fault.
0x00007ffff28e76f1 in ?? () from /usr/lib/x86_64-linux-gnu/

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: liferea 1.10.17-1ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-64.85-generic 4.4.44
Uname: Linux 4.4.0-64-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 1 12:16:05 2017
InstallationDate: Installed on 2017-02-10 (18 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: liferea
UpgradeStatus: No upgrade log present (probably fresh install)

Aaron Skomra (skomra) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in liferea (Ubuntu):
status: New → Confirmed
d❤vid (kwill) wrote :

Confirmed this still occurs in liferea 1.10.19-2ubuntu1 on Ubuntu 16.10. It looks like this will be resolved when Liferea 1.12 is released:

Paul Gevers (paul-climbing) wrote :

liferea (1.12~rc2-2ubuntu1) zesty; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - debian/patches/add_X-Ubuntu-Gettext-Domain.patch:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
    - debian/patches/ubuntu-example-feeds.patch:
      + Use Ubuntu feedlists instead of Debian.
  * Drop changes:
    - Add Unity support.
    - Port to messaging menu.
    That code has been removed upstream, probably it will
    be added again as plugin (patches are now commented)

 -- Gianfranco Costamagna <email address hidden> Fri, 10 Feb 2017 12:24:11 +0100

Changed in liferea (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.