[UVFe] Liferea 1.4.3b fixed two critical bugs, and is a bug-fix-only release.

Bug #145326 reported by Emilio Pozuelo Monfort on 2007-09-26
8
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)
High
Emilio Pozuelo Monfort

Bug Description

Binary package hint: liferea

This is just a bug fix release, which fixes a lot of issues, including a crash when following links (Bug #141250) and two critical bugs, which are:

        * Fixes a data loss problem that causes flagged
          items to be dropped out of cache. Normally
          flagged items are never to be dropped.
          (reported by Keith Curtis)

and

        * Fixes a grave bug that caused continuous feed
          downloads when the default update interval is
          set to 0, which is to mean disabled.

I've been running it for an entire day, and it's pretty stable.

Thanks,
Emilio

2007-09-25 Lars Lindner <email address hidden>

        Version 1.4.3b (Stable)

        * Fixes a data loss problem that causes flagged
          items to be dropped out of cache. Normally
          flagged items are never to be dropped.
          (reported by Keith Curtis)

2007-09-24 Lars Lindner <email address hidden>

        Version 1.4.3 (Stable)

        * Fixes a grave bug that caused continuous feed
          downloads when the default update interval is
          set to 0, which is to mean disabled.
        * Fixes assertions in db_item_check() and
          db_query_to_sql() for search folders that
          do not have rules. (reported by pochu)
        * Fixes SF #1798880: problem when using Ctrl-u
          inside a search folder matching unread items.
        * Fixes Debian #430782: better handling of RSS 2.0
          LiveJournal feeds which use lj: prefix for some
          HTML elements. (reported by Daniel Jacobowitz)
        * Fixes SF #1799476: crash when following links.
          (reported by jphendrix)

2007-09-19 Lars Lindner <email address hidden>

        Version 1.4.2b (Stable)

        * Fixes compilation problems of GtkHTML2 rendering.
        * Fixes SF #1798158: problem with 'mark as read'
          option in popup window (reported by zodmaner)
        * Now removes leading/trailing white spaces from
          feed list node titles. (patch from Christian Dywan)
        * Fixes broken HTTP authentication. Auth info was
          just not passed with HTTP requests. (reported
          by Jim Henderson)
        * Fixes Debian #442798: update interval values
          isn't correctly updated. Interval unit is lost.
          (reported by Yannick Palanque)

Related branches

Changed in liferea:
assignee: nobody → pochu
importance: Undecided → High
Martin Pitt (pitti) wrote :

Approved.

Changed in liferea:
status: New → Confirmed
Sebastian Dröge (slomo) wrote :

Just for the record, this is already uploaded and only waits for approval.

Steve Langasek (vorlon) wrote :

Please note that what was requested, and approved, was a UVFe for the bugs that were fixed upstream, whereas what was uploaded included a new merge from Debian that brought in unrelated changes - including a switch from lua 5.0 to lua 5.1 which is not appropriate during this stage of the release cycle. It will also make liferea fail to build, because lua 5.1 is not part of gutsy/main.

Emilio Pozuelo Monfort (pochu) wrote :

liferea (1.4.3b-0ubuntu1) gutsy; urgency=low

  * New upstream release. (UVFe LP: #145326)
  * Version 1.4.3b (Stable)
     - Fixes a data loss problem that causes flagged
       items to be dropped out of cache. Normally
       flagged items are never to be dropped.
       (reported by Keith Curtis)

  * Version 1.4.3 (Stable)
     - Fixes a grave bug that caused continuous feed
       downloads when the default update interval is
       set to 0, which is to mean disabled.
     - Fixes assertions in db_item_check() and db_query_to_sql() for search
       folders that do not have rules. (reported by pochu)
     - Fixes SF #1798880: problem when using Ctrl-u
       inside a search folder matching unread items. (LP: #102161)
     - Fixes Debian #430782: better handling of RSS 2.0
       LiveJournal feeds which use lj: prefix for some
       HTML elements. (reported by Daniel Jacobowitz)
     - Fixes SF #1799476: crash when following links.
       (reported by jphendrix) (LP: #141250)

    Version 1.4.2b (Stable)
     - Fixes compilation problems of GtkHTML2 rendering.
     - Fixes SF #1798158: problem with 'mark as read'
       option in popup window (reported by zodmaner)
     - Now removes leading/trailing white spaces from
       feed list node titles. (patch from Christian Dywan)
     - Fixes broken HTTP authentication. Auth info was
       just not passed with HTTP requests. (reported
       by Jim Henderson)
     - Fixes Debian #442798: update interval values
       isn't correctly updated. Interval unit is lost.
       (reported by Yannick Palanque)

  * Merge with Debian, remaining Ubuntu changes:
    - debian/control:
      + Added firefox-dev and intltool to build-deps.
      + Removed libxul-dev from build-deps.
      + Changed Maintainer field to match DebianMaintainerSpec.
      + Added firefox to liferea dependencies.
      + Do not build transitional packages (not required due to Conflicts/
        Provides/Replaces)
    - debian/rules:
      + Call intltool-update -p to generate translation template for Rosetta
      + Call dh_iconcache
      + Don't disable gecko
    - debian/patches/00list:
      + Do not apply expand_treeview.dpatch, since it's fixed since 1.4.2.

 -- Emilio Pozuelo Monfort <email address hidden> Tue, 25 Sep 2007 16:56:01 +0200

Changed in liferea:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches