liferea-add-feed does nothing in firefox

Bug #131743 reported by Matt Philmon on 2007-08-11
8
Affects Status Importance Assigned to Milestone
Liferea
Invalid
Undecided
Unassigned
Mozilla Firefox
Invalid
Undecided
Unassigned
firefox (Debian)
Invalid
Undecided
Unassigned
firefox (Ubuntu)
High
Alexander Sack
liferea (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: liferea

To have new "subscriptions" automatically picked up by liferea, you're supposed to set the external application (within firefox) to "/usr/bin/liferea-add-feed". Clicking this however, does nothing since my fresh install of Gutsy Tribe 4.

@mozilla.org/browser/shell-service;1 is apparently not resolvable, Components.classes["@mozilla.org/browser/shell-service;1"].getService(Components.interfaces.nsIShellService_MOZILLA_1_8_BRANCH) fails.

Error that can be found in the console error when trying to use liferea-add-feed :

Error: [Exception... "ServiceManager::GetService returned failure code:" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///usr/lib/firefox/components/FeedConverter.js ::
FRS_addToClientReader :: line 338" data: no]
Source File: file:///usr/lib/firefox/components/FeedConverter.js
Line: 338

Code near line 338 of /usr/lib/firefox/components/FeedConverter.js :

switch (handler) {
    case "client":
      var clientApp =
        prefs.getComplexValue(PREF_SELECTED_APP, Ci.nsILocalFile);
//@line 393 "/build/buildd/firefox-2.0.0.6+2/build-tree/mozilla/browser/components/feeds/src/FeedConverter.js"
      var ss =
          Cc["@mozilla.org/browser/shell-service;1"]. < bugging line
          getService(Ci.nsIShellService_MOZILLA_1_8_BRANCH);
      ss.openApplicationWithURI(clientApp, spec);
      break;

Related branches

Thank you for your bug report. I can reproduce this, I'm marking this as triaged.

Changed in liferea:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged

In fact this is a bug with the firefox version of Ubuntu which should be fixed soon.

Changed in liferea:
status: Triaged → Invalid
description: updated
description: updated
Alexander Sack (asac) wrote :

this is a beta blocker (at least)

Changed in liferea:
status: New → Invalid
Changed in firefox:
status: New → Confirmed
assignee: nobody → asac
importance: Undecided → High
Alexander Sack (asac) wrote :

firefox (2.0.0.6+2-0ubuntu4) gutsy; urgency=low

  * patch shaping: rename patches and include there bugzilla id
    where available; document bzXXX-dont-reset-user-prefs-on-upgrade and
    force-no-pragma-visibility-for-gcc-4.2_4.3 patches.
  * debian/patches/bz389801-theme-crash-with-GtkOptionMenu-indicator_size-and-indicator_spacing.patch:
    prefetch latest patch from bugzilla 389801 to fix top-crasher
    (LP: #129007).
  * debian/firefox-gnome-support.install: properly install gnome support files
    previously missing in firefox-gnome-support package (LP: #131743).

 -- Alexander Sack <email address hidden> Wed, 19 Sep 2007 18:16:37 +0200

Changed in firefox:
status: Confirmed → Fix Released
Kay Parker (kayparker) wrote :

 liferea-add-feed still does nothing in firefox 2.0.0.8 (Gutsy final release)

Emilio Pozuelo Monfort (pochu) wrote :

Kay, it works pretty fine here.

Do you have firefox-gnome-support? If not, install it and restart firefox, and see if it still happens.

Have you configured firefox to use /usr/bin/liferea-add-feed in Preferences>Feeds?
Does it fail with every feed? Or only with some?

Kay Parker (kayparker) wrote :

I configured liferea-add-feed in Preferences>Feeds and installed firefox-gnome-support. Even a liferea-add-feed <URL> doesn't add the feed to lifereas feed list.

Lee Braiden (lee-braiden) wrote :

I've seen this problem on both ubuntu and now debian. This is what I get on debian:

$ export LD_LIBRARY_PATH="/usr/lib/iceweasel:$LD_LIBRARY_PATH"
$ strace &> log /usr/lib/iceweasel/firefox-bin

(Here, I go to a site witha feed, click the rss icon, click the checkbox to always subscribe to feeds using liferea-add-feeds, and then click subscribe. Note that the chosen checkbox option never gets saved either.)

$ grep liferea log
access("/usr/bin/liferea-add-feed", F_OK) = 0
stat64("/usr/bin/liferea-add-feed", {st_mode=S_IFREG|0755, st_size=660, ...}) = 0
stat64("/usr/bin/liferea-add-feed", {st_mode=S_IFREG|0755, st_size=660, ...}) = 0

So, it seems to look at the liferea-add-feed file, but never attempts to run it.

Lee Braiden (lee-braiden) wrote :

Hmm. I thought it might not be executing scripts that need shebang line interpretation, but having just compiled a simple c program that prints its args, and temporarily replaced /usr/bin/liferea-add-feed with it, I see that this doesn't get called either. iceweasel/firefox seem to be very broken. I don't know how you'd go about reassigning this bug to firefox, but that should be done, imho. I've ran liferea-add-feed url, and that does work for me.

Lee Braiden (lee-braiden) wrote :

re-opening, as although I'm not using ubuntu right now, I've seen this in ubuntu's latest packages after the patch above, just as Kay says above.

Changed in firefox:
status: Fix Released → Incomplete
Emilio Pozuelo Monfort (pochu) wrote :

Closing upstream's tasks which don't have a bug watch.

Changed in firefox:
status: New → Invalid
status: New → Invalid
Emilio Pozuelo Monfort (pochu) wrote :

WorksForMe in latest Hardy with Firefox 3.0 beta 3 from the repositories.

Are you using that?

I use Firefox 2.0.0.12 on ubuntu Gutsy and it doesn't work.

Giorgio Sironi wrote:
> I use Firefox 2.0.0.12 on ubuntu Gutsy and it doesn't work.
>

You need firefox-gnome-support. Do you have it installed?

With firefox-gnome-support it works. In Xubuntu is not installed by default, so it's possible to add a dependency? (Note liferea already depends on firefox as I see at http://packages.ubuntu.com/gutsy-updates/liferea)...

Emilio Pozuelo Monfort (pochu) wrote :

Giorgio Sironi wrote:
> With firefox-gnome-support it works. In Xubuntu is not installed by
> default, so it's possible to add a dependency? (Note liferea already
> depends on firefox as I see at http://packages.ubuntu.com/gutsy-
> updates/liferea)...
>

No, since Liferea works fine without firefox. It should be firefox who
recommends firefox-gnome-support though (if it doesn't does that yet).

Cheers

Firefox suggests firefox-gnome-support. Sorry for verbosity but...

giorgio@Indy:~$ dpkg -s liferea | grep firefox
Depends: libatk1.0-0 (>= 1.13.2), libc6 (>= 2.6-1), [...], gconf2 (>= 2.10.1-2), firefox

So how can it work fine without firefox? :-(

Emilio Pozuelo Monfort (pochu) wrote :

Giorgio Sironi wrote:
> Firefox suggests firefox-gnome-support. Sorry for verbosity but...
>
> giorgio@Indy:~$ dpkg -s liferea | grep firefox
> Depends: libatk1.0-0 (>= 1.13.2), libc6 (>= 2.6-1), [...], gconf2 (>= 2.10.1-2), firefox
>
> So how can it work fine without firefox? :-(
>

I mean that Liferea works fine without firefox (and that's fixed in Hardy, where
it doesn't depend on firefox anymore) so Liferea shouldn't and won't depend on
firefox-gnome-support for liferea-add-feed to work in Firefox.

Perhaps what firefox could recommend firefox-gnome-support instead of suggest
it, although I'm afraid that may be a bad idea for non-GNOME users now that
Recommends are installed by default.

Alexander Sack (asac) wrote :

firefox 2 wont see fixes like this. with -gnome-support package it probably works. if you still see this with firefox 3 please open a new bug or add a firefox-3.0 target to this one.

Changed in firefox:
status: Incomplete → Won't Fix
nebi (ciceksepetiniz) wrote :

helo very very thanksssss

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.