Doubleclick and Spacebar do not open links in external browser

Bug #1299649 reported by Mario Vukelic on 2014-03-30
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)
Undecided
Unassigned
Nominated for Trusty by Adolfo Jayme

Bug Description

Both issues are fixed in 1.10.5
http://sourceforge.net/p/liferea/bugs/1098/
http://sourceforge.net/p/liferea/bugs/1089/

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: liferea 1.10.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 30 01:51:17 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-09-15 (560 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
SourcePackage: liferea
UpgradeStatus: Upgraded to trusty on 2014-03-29 (0 days ago)

Mario Vukelic (mario-vukelic) wrote :
Mattia Rizzolo (mapreri) wrote :

FWIW there is also https://sourceforge.net/p/liferea/bugs/1056/ (bts #725281).
This will be fixed with the next merge from debian.

Is the release team happy if I go to merge liferea 1.10.8-1 from debian unstable? According to the upstream git commits log [1] this is mostly a bugfix only release, and since this is a quite annoying bug I'd would be happy to merge liferea from debian and fix this.

[1] https://github.com/lwindolf/liferea/compare/5fbb516...8216d64

Changed in liferea (Ubuntu):
status: New → Confirmed
Holger Mauermann (mauermann) wrote :

Would be great if we can get the fixed package from debian for trusty too. This bug is really annoying.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package liferea - 1.10.8-1ubuntu1

---------------
liferea (1.10.8-1ubuntu1) utopic; urgency=low

  * Merge from Debian unstable (LP: #1208776). Remaining changes:
    + debian/patches/ubuntu-example-feeds.patch.
    + debian/patches/port-to-messaging-menu.patch.
    + debian/patches/libunity.patch: refreshed.
    + debian/control: build-depends on libmessaging-menu-dev libunity-dev.
    + debian/rules: enable messaging-menu.
  * Upstream changes:
    + Fix a issue in opening link in a external browser (LP: #1299649)

liferea (1.10.8-1) unstable; urgency=low

  [ David Michael Smith ]
  * New upstream release [March 2014] (Closes: #742009)
  * Fix a problem related to opening items in an external browser.
    (Closes: #725281)
  * Update watch file, upstream moved from SF to github.
  * debian/rules: Add intltoolize to override_dh_autoreconf to work around
    missing Makefile. See: http://sourceforge.net/p/liferea/bugs/1143/
  * Adopt package (Closes: #738099)

  [ Paul Gevers ]
  * Remove Dmitry Smirnov from uploaders (his own request)
  * Add myself as uploader
 -- Mattia Rizzolo <email address hidden> Tue, 29 Apr 2014 16:12:32 +0200

Changed in liferea (Ubuntu):
status: Confirmed → Fix Released
Andris Berzins (pkix) wrote :

Just now upgraded to 14.04 and experienced the same bug. Will this update be available for trusty ?

On Jun 3, 2014 8:02 PM, "Andris Berzins" <email address hidden> wrote:
> Just now upgraded to 14.04 and experienced the same bug. Will this
> update be available for trusty ?
>

Unlikely. I'm not going to do so for sure. Anybody is free to backport the
relevant changes, of course. And you can also install the utopic package in
trusty, of course.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers