liferea is unable to display images in feed items

Bug #109342 reported by Akshat Aranya on 2007-04-23
2
Affects Status Importance Assigned to Milestone
liferea (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: liferea

I upgraded liferea recently to the latest version in Feisty (1.2.10). I think my liferea is now using mozilla for rendering instead of gtkhtml and it is unable to show images in the feed items.

This might be related to a problem found with Firefox with certain proxy servers where the user agent string containing "ist" from Feisty would cause the connection to get reset. I fixed my Firefox by removing "Feisty" from the user agent string.

For liferea, I tried changing the user agent string by putting this in my ~/.liferea_1.3/mozilla/liferea/prefs.js:

user_pref("general.usergent.override", "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3)");

but this doesn't seem to help either. I'll be willing to try out other workarounds, if needed.

Akshat Aranya (aaranya+ubuntu) wrote :

Update: I found a typo in my useragent, It said "general.usergent.override" instead of "general.useragent.override". Nonetheless, bug# 94241 is still an issue. Setting the user agent string for firefox is not that hard, but setting it for liferea, or other applications that use mozilla/firefox is non-trivial.

Akshat Aranya (aaranya+ubuntu) wrote :

Argh, I mean bug# 95241.

Emilio Pozuelo Monfort (pochu) wrote :

So this is no longer an issue?

Akshat Aranya (aaranya+ubuntu) wrote :

This is not an issue in the sense that it could be considered a duplicate of bug# 95241. However, I think this bug somewhat increases the severity of bug# 95241 because in this case, the workaround is not so easy. I don't know how many people are affected by this issue, but if they are, the workaround is, IMO, somewhat beyond the capabilities of naive users.

I hope this issue will at least be documented as a known issue even if it is not considered a Feisty bug.

Emilio Pozuelo Monfort (pochu) wrote :

So with a clean profile it fails?

What I don't understand is the fact that it fails with the images, but not with the rest of the feeds. Is that correct?

Akshat Aranya (aaranya+ubuntu) wrote :

Yes, it fails with a clean profile. What happens is that anything contained within the feed is displayed, but anything that requires liferea to go and fetch something over http fails. I think what happens is that the original feed is fetched by liferea itself and then the feed item is handed over to the mozilla component to render. As a part of rendering, mozilla has to fetch the a href'ed images, which it is unable to do.

I'm afraid we can't do anything from liferea's side.

This should be fixed either in Firefox or in the proxy (wherever the bug
is).

So I'm marking this as a duplicate of that bug, and reopening that one.

Regards
Emilio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers