package libxslt1-dev 1.1.26-8ubuntu1 failed to install/upgrade: './usr/bin/xslt-config' is different from the same file on the system

Bug #1014197 reported by George Masters on 2012-06-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libxslt (Debian)
Fix Released
Unknown
libxslt (Ubuntu)
High
Unassigned
Precise
High
Stéphane Graber

Bug Description

[rational]
libxslt1-dev is architecture specific, so shouldn't be marked for multi-arch.

[test case]
Try to install both libxslt1-dev:i386 and libxslt1-dev:amd64, apt should refuse to let you do that.

In the past it'd be allowed and would fail to install.

[regression potential]
If something depends on these being co-installable, it's already broken anyway, so won't be any worse.

I was installing the Koha Integrated Library System 3.8.1 Within this package is a list of packages to install using dpkg and dselect.

The steps in the Koha documentation are:

From the Koha 3.8.1 directory:

sudo dpkg --set-selections<install_mis/ubuntu.packages

the
sudo dselect

WIthin dselect select [I]Install to tinstall the packages. It did not finish installing all the packages when this particular file failed as referenced in the summary. Had it installed the next setp would be to [Q]uit

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libxslt1-dev 1.1.26-8ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Sat Jun 16 22:03:11 2012
DuplicateSignature:
 Unpacking libxml2-dev:i386 (from .../libxml2-dev_2.7.8.dfsg-5.1ubuntu4.1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libxml2-dev_2.7.8.dfsg-5.1ubuntu4.1_i386.deb (--unpack):
  './usr/bin/xml2-config' is different from the same file on the system
ErrorMessage: './usr/bin/xslt-config' is different from the same file on the system
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: libxslt
Title: package libxslt1-dev 1.1.26-8ubuntu1 failed to install/upgrade: './usr/bin/xslt-config' is different from the same file on the system
UpgradeStatus: No upgrade log present (probably fresh install)

George Masters (gmasters2) wrote :
tags: removed: need-duplicate-check
Sebastien Bacher (seb128) wrote :

It's fixed in quantal:

"libxslt (1.1.26-12) unstable; urgency=low
...
  * debian/control: mark libxslt1-dev as not M-A (Closes: #671902)."

Changed in libxslt (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Changed in libxslt (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
importance: Undecided → High
status: New → Triaged
tags: added: multiarch
Changed in libxslt (Debian):
status: Unknown → Fix Released
Changed in libxslt (Ubuntu Precise):
assignee: nobody → Stéphane Graber (stgraber)
Changed in libxslt (Ubuntu Precise):
status: Triaged → In Progress
description: updated

Hello George, or anyone else affected,

Accepted libxslt into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libxslt/1.1.26-8ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libxslt (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Confirmed, packages are no longer co-installable.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxslt - 1.1.26-8ubuntu1.1

---------------
libxslt (1.1.26-8ubuntu1.1) precise-proposed; urgency=low

  * debian/control: mark libxslt1-dev as not M-A (LP: #1014197).
 -- Stephane Graber <email address hidden> Wed, 18 Jul 2012 15:01:41 -0400

Changed in libxslt (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.