libx11 causes kwin to crash on login (over NX protocol)

Bug #985202 reported by Iordan Iordanov on 2012-04-18
184
This bug affects 33 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
libxrandr (Ubuntu)
High
Unassigned
Precise
High
Timo Aaltonen

Bug Description

[Impact]

xserver crash with kwin and NX

[Test Case]

install NX server, log in remotely using kde session

[Regression Potential]

small, patch has been in raring for a couple of weeks now without issues

--

This behavior is 100% reproducible. I have freenx-server installed from here:
https://launchpad.net/~freenx-team/+archive/ppa

And am logging in from a remote machine with the newest nxclient from nomachine.org. What happens is that upon login or shortly thereafter, kwin crashes with a segfault. After restarting, it crashes at regular intervals as well.

I reported a bug to the KDE4 tracker:
https://bugs.kde.org/show_bug.cgi?id=298370

And it was marked a duplicate of a bug NOT related to NX:
https://bugs.kde.org/show_bug.cgi?id=293209

Judging from the backtrace, and from the comments in bug 293209, the problem is related to Xorg, and the people at KDE seem to think that the problem might even be Ubuntu 12.04 specific. So I decided to re-report the bug here and give you pointers to the relevant KDE bugreports.

We are really desperate to get Kwin working under NX and are willing to test whatever you like!

Many thanks in advance.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libx11-6 2:1.4.99.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu4
Architecture: i386
Date: Wed Apr 18 16:18:16 2012
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 SHELL=/bin/bash
SourcePackage: libx11
UpgradeStatus: No upgrade log present (probably fresh install)

Iordan Iordanov (iiordanov) wrote :
bugbot (bugbot) on 2012-04-19
tags: added: kubuntu
Iordan Iordanov (iiordanov) wrote :

I decided to go try downgrading some libraries to Oneiric to see whether kwin will stop crashing, and indeed, after downgrading this set of libraries to the ones from Oneiric:

libx11-6_1.4.4-2ubuntu1_i386.deb
libxdamage1_1.1.3-2_i386.deb
libxext6_1.3.0-3_i386.deb
libxfixes3_5.0-4_i386.deb
libxi6_1.4.3-3ubuntu1_i386.deb
libxrandr2_1.3.0-3_i386.deb
libxrandr2_1.3.2-2_i386.deb
libxrender1_0.9.6-2_i386.deb

kwin no longer crashes. I thought this information might be useful.

Thanks!

Basically, anybody who updates their Kubuntu Oneiric to the 12.04 Beta 2 is affected by this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libx11 (Ubuntu):
status: New → Confirmed

The KUBUNTU 12.04 release is imminent and this bug is still not fixed...

Uwe Mock (u-mock) wrote :

Same thing here in Kubuntu 12.04 Release with NX client and server from NoMachine, version 3.5.0-7. This setup also shows the "NX connection very, very slow" bug (I can see how the window borders are drawn).

Andrea Moro (andrea8moro) wrote :

same thing here with kubuntu 12.04 64bit and server from NoMachine, version 3.5.0-7. "NX connection very, very slow" bug

Henrik Harmsen (henrik-harmsen) wrote :

This bug makes my server unusable. Again. Using NX to log in and kwin crashes all the time.

wedgeshot (wedgeshot) wrote :

I can confirm the KWin repeatedly crashes also on my recent upgrade 12.04 LTS.

Daniel Kulesz (kuleszdl) wrote :

I just did a clean, fresh-install of the final Kubuntu 12.04 (amd64) and only installed openssh-server and nomachine's NX. I am experiencing exactly this bug here as well.

agenkin (agenkin-p) wrote :

Has anyone reported this to NoMachine yet?

Daniel Kulesz (kuleszdl) wrote :

I don't know, but they seem to have also serious performance problems on 12.04 which they at least know about:

https://bugs.launchpad.net/ubuntu/+source/libx11/+bug/985202

http://www.nomachine.com/tr/view.php?id=TR01J02646

From my POV it is a shame that they list Ubuntu 12.04 as "supported" on their downloads page, although this serious performance bug and this kwin issue here exists. Sometimes I am really wondering what type of testing they do before making such announcements in their download section. I have lost a bunch of time with downgrading back to 10.04 because of these two issues.

I switched from nomachine to TigerVNC. When changing X resolution with xrandr -s WxH, kwin crashes again. So, no direct connection to nomachine. (Kubuntu 12.04)

Timothy Pearson (kb9vqf) wrote :

This bug also affects the Trinity Desktop Environment. I suspect that all XRandR-aware programs will crash if active when an XRandR change event is received and processed via XRRUpdateConfiguration() on certain Xorg drivers.

For the record, downgrading xlibs and associated packages to their respective Oneiric versions did resolve the problem for now.

Timothy Pearson (kb9vqf) wrote :

At the request of an Ubuntu user I am posting the method I used to downgrade xlibs and friends:

From a terminal:

mkdir ~/x11downgrade
cd ~/x11downgrade
wget http://mirror.pnl.gov/ubuntu/pool/main/m/mesa/libgl1-mesa-glx_7.11-0ubuntu3_amd64.deb
wget http://mirror.pnl.gov/ubuntu/pool/main/m/mesa/libglapi-mesa_7.11-0ubuntu3_amd64.deb
wget http://mirror.pnl.gov/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-0_2.24.6-0ubuntu5_amd64.deb
wget http://mirror.pnl.gov/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-common_2.24.6-0ubuntu5_all.deb
wget http://mirror.pnl.gov/ubuntu/pool/main/libx/libx11/libx11-6_1.4.4-2ubuntu1_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxcomposite/libxcomposite1_0.4.3-2_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxdamage/libxdamage1_1.1.3-2_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxext/libxext6_1.3.0-3_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxfixes/libxfixes3_5.0-4_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxi/libxi6_1.4.3-3ubuntu1_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxinerama/libxinerama1_1.1.1-3_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxrandr/libxrandr2_1.3.2-2_amd64.deb
wget http://mirror.pnl.gov/ubuntu//pool/main/libx/libxrender/libxrender1_0.9.6-2_amd64.deb
sudo dpkg -i *.deb

Note that this may install packages that you did not originally have installed, and that I have only tested this under TDE--I have no idea if this will work with Gnome.

wedgeshot (wedgeshot) wrote :

The latest updates from nomachine fixes the repeated crashing, experienced two Kwin crashes just after the initial connection but I have not had more than two Kwin crashes during my last two sessions. I also updated to latest patches from Ubuntu 12.04 LTS so I'm at the current latest as of 5/28.

--------------------------------------- from apt term.log update over the weekend ------------------------
Setting up libnx-xorg (1:3.5.0-9-2-1-2-0~ppa1~precise2) ...
Setting up nxagent (1:3.5.0-9-2-1-2-0~ppa1~precise2) ...
Setting up nx-common (0.7.3.zgit.120322.977c28d-0~ppa11) ...
Setting up freenx-server (0.7.3.zgit.120322.977c28d-0~ppa11) ...
NX> 100 NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.5.0)
NX> 122 Service started
NX> 999 Bye
Setting up freenx-vnc (0.7.3.zgit.120322.977c28d-0~ppa11) ...
Setting up freenx-smb (0.7.3.zgit.120322.977c28d-0~ppa11) ...
Setting up freenx-session-launcher (0.7.3.zgit.120322.977c28d-0~ppa11) ...
Setting up freenx-rdp (0.7.3.zgit.120322.977c28d-0~ppa11) ...
Setting up freenx (0.7.3.zgit.120322.977c28d-0~ppa11) ...

wedgeshot (wedgeshot) wrote :

Ugh.... spoke too soon, resizing of the main NX window still causes Kwin crashes but does recover.

jth (jth) wrote :
Download full text (4.9 KiB)

Hi
Same for me, current precise with recommended updates.

Application: Kwin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8b112f7780 (LWP 25307))]
<cut>
Thread 1 (Thread 0x7f8b112f7780 (LWP 25307)):
[KCrash Handler]
#6 __GI___libc_free (mem=0x1) at malloc.c:2968
#7 0x00007f8b0e557819 in XFree (data=<optimized out>) at ../../src/XlibInt.c:1701
#8 0x00007f8b0e0ff2ee in XRRUpdateConfiguration (event=0x7fff66a34f10) at ../../src/Xrandr.c:446
#9 0x00007f8b10e49a30 in KWin::Workspace::workspaceEvent (this=0x1e83d50, e=0x7fff66a34f10) at ../../kwin/events.cpp:460
#10 0x00007f8b10e3b288 in KWin::Application::x11EventFilter (this=0x7fff66a35220, e=0x7fff66a34f10) at ../../kwin/main.cpp:359
#11 0x00007f8b0b728b85 in qt_x11EventFilter (ev=0x7fff66a34f10) at kernel/qapplication_x11.cpp:441
#12 qt_x11EventFilter (ev=0x7fff66a34f10) at kernel/qapplication_x11.cpp:429
#13 0x00007f8b0b737f98 in QApplication::x11ProcessEvent (this=0x7fff66a35220, event=0x7fff66a34f10) at kernel/qapplication_x11.cpp:3444
#14 0x00007f8b0b762b3a in QEventDispatcherX11::processEvents (this=0x1d7cad0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#15 0x00007f8b0c335c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#16 0x00007f8b0c335ed7 in QEventLoop::exec (this=0x7fff66a35160, flags=...) at kernel/qeventloop.cpp:204
#17 0x00007f8b0c33af67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#18 0x00007f8b10e3da06 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:541
#19 0x00007f8b10a4176d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff66a35948, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff66a35938) at libc-start.c:226
#20 0x0000000000400661 in _start ()

Will try some random code changes and see what it does and if I find something.

int XFree (void *data)
{ Xfree (data);
 return 1;
}

int XRRUpdateConfiguration(XEvent *event)
{ XRRScreenChangeNotifyEvent *scevent;
    XConfigureEvent *rcevent;
    Display *dpy = event->xany.display;
    XExtDisplayInfo *info;
    XRandRInfo *xrri;
    int snum;

    /* first, see if it is a vanilla configure notify event */
    if (event->type == ConfigureNotify) {
        rcevent = (XConfigureEvent *) event;
        snum = XRRRootToScreen(dpy, rcevent->window);
        if (snum != -1) {
            dpy->screens[snum].width = rcevent->width;
            dpy->screens[snum].height = rcevent->height;
            return 1;
    } }

    info = XRRFindDisplay(dpy);
    RRCheckExtension (dpy, info, 0);

    switch (event->type - info->codes->first_event) {
    case RRScreenChangeNotify:
        scevent = (XRRScreenChangeNotifyEvent *) event;
        snum = XRRRootToScreen(dpy,
                               ((XRRScreenChangeNotifyEvent *) event)->root);
        if (scevent->rotation & (RR_Rotate_90 | RR_Rotate_270)) {
                dpy->screens[snum].width = scevent->height;
                dpy->screens[snum].height = scevent->width;
                dpy->screens[snum].mwidth = s...

Read more...

Peter M. Clausen (pclausen) wrote :

An interesting observation:

using xterm has the expected performance (as good as it gets)
using konsole: performance slow, sluggish, hanging....

could it be some kind of font issue, which in the end brings kwin down?

My systems:
host: newly installed kubuntu 12.04 64-bit
client: xubuntu 11.10 32-bit

I also have a Ubuntu 10.04 host - runs perfectly

tags: added: amd64
Bahh (kmeaghermd) wrote :

Kwin crash with kubuntu 12.04 (brand new install) and nomachine NX free addition windows client 3.5.0.9

Paul Coray (paul-coray) wrote :

Same with us: Kubuntu 12.04, fully patched, FreeNX 0.7.3.zgit.120322.977c28d-0~ppa11 from FreeNX team at launchpad, keeps crashing Kwin, no matter which version or platform the NX client (Nomachine) runs on.

This is critical for us, as we are about to roll out an upgrade of all our terminal servers for our ~200 users at the university library, based on this combo.

Daniel Kulesz (kuleszdl) wrote :

I just did another fresh full reinstall and used the latest nomachine server/client/node, but as already reported here it still crashes, but this time it seems to recover. It also crashes on each attempt to resize the NX window as also reported here already.

Another thing that I noticed is that KDE apps run MUCH slower than they used to do in 10.04. I have a direct comparison because I have two NX KDE sessions (one with a 10.04 host, one with a 12.04 host) side by side and the slowness in 12.04 is quite striking! Interestingly, GTK applications seem to perform quite well, i.e. when minimizing/maximizing a firefox window vs. minimizing/maximizing a rekonq window.

Daniel Kulesz (kuleszdl) wrote :

I can confirm that Timothys Hack with downgrading the mentioned packages is a working workaround for the kwin crash issue (no more crashes when resizing the window etc. as well. (Unfortunately it does not tackle the performance issue in QT applications which I hoped was correlated with this problem but should be probably better discussed in another bug.)

Russell Brown (russell-lls) wrote :

Just another data point.

Fresh install of Ubuntu Precise Pangolin AMD64, FreeNX and while local displays and LTSP X-Terminals are fine, connecting via NX always results in kwin seg faulting making remote access via NX impossible.

The backtrace shows it crashing in free() like everyeone else reported.

#5 0x00007f9d3a66502c in free () from /lib/x86_64-linux-gnu/libc.so.6
#6 0x00007f9d3aef5819 in XFree () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#7 0x00007f9d372ce2ee in XRRUpdateConfiguration () from
/usr/lib/x86_64-linux-gnu/libXrandr.so.2
#8 0x00007f9d3b416f40 in TQApplication::x11ProcessEvent(_XEvent*) () from
/usr/lib/libtqt-mt.so.3

Upgraded to 12.04 and KDE over X2go is now unusable. I can provide whatever information or testing anyone wants.

ronny (ronny-standtke) wrote :

I just run into the same issue while logging in to my desktop via a "normal" X11 thin client (xdmcp).

Helmer Teles (helmer-teles) wrote :

This bug is still present on almost stable Kubuntu 12.10 as of 2012-10-17.

This bug prevents us from deploying KDE4 with any nx based technology.

Denis (link011) wrote :

suggested fix above (with downgrading packages) broke my thunderbird and ff:
/usr/lib/thunderbird/thunderbird: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0: undefined symbol: _XGetRequest

Helmer Teles (helmer-teles) wrote :

Hi Link, hi to all

I've been working in a DaaS with kubuntu 12.10 and i've sucessfully managed to resolve the kwin crashes with only replacing one lib.

It goes like this:

rm /usr/lib/i386-linux-gnu/libXfixes.so.3
ln -s /usr/lib/i386-linux-gnu/libXfixes.so.3.1.0 /usr/lib/i386-linux-gnu/libXfixes.so.3

This lib was retrieved following the steps above from Mr Pearson himself but instead of replacing all libs and debs, i extracted only libXfixes and replaced the lib - in my case i'm working with i386 kubuntu instead of amd64.

Hope this helps - i'm starting a new VM with kubuntu 12.04 and will test the same procedure but it works with 12.10 in a full blow desktop with libreoffice, firefox ESR and Thunderbird ESR.

regards,
hteles
http://hteles.wordpress.com

agenkin (agenkin-p) wrote :

Yes, downgrading all libraries for the whole systems causes lots of problems, including with some gnome applications and programs that use OpenGL. We have developed a better workaround, that modifies the environment of the `kwin' binary only. The rest of the programs run unaffected with the default libraries as provided by Ubuntu.

I'm attaching the wrapper script for kwin that we are using (read the comments at the top of the script).
I'm also going to attach the output of "ls -lR" for the directory where the downgraded libraries are kept.

agenkin (agenkin-p) wrote :

Some more notes.

(1) In the above workaround, the symlink /usr/bin/kwin-ld to /lib/i386-linux-gnu/ld-2.15.so is not necessary, as the line "exec /usr/bin/kwin-ld --library-path" can be replaced with "exec /lib/i386-linux-gnu/ld-2.15.so --lbrary-path ...". But then the kwin process appears as "ld-2.15.so" in the process list, and we didn't like that (we have lots of users with simultaneous NX sessions). With the symlink as above the kwin process appears as "kwin-ld", which works for us better.

(2) We think that Helmer Teles is right that only libXfixes needs to be replaced. So, one can modify our solution to only have libXfixes library in the directory. However, we already had all of the other older libraries replaced, and kwin was stable. So we decided to play it safe and still replace all of those libraries, but limit their visibility to only the kwin binary.

(3) We are using the run-time linker to set the library path in the wrapper, rather than doing it via LD_LIBRARY_PATH environment variable because we don't want the environment variable propagating to kwin's child processes. We want all processes except kwin to run with unmodified versions of X libraries.

Helmer Teles (helmer-teles) wrote :

Hi,

it seems that Canonical is looking to provide Linux DaaS to its portfolio of products.

So maybe this is the time to look at this bug once and for all since people here almost gave them the solution.

More info here from the great x2go team.

http://blog.x2go.org/index.php/2012/11/07/co-operation-between-canonical-x2go-edubuntu-and-fleten-net-in-denmark/#comment-85

Hi,
Im rebuilding our corporate desktop with Kubuntu 12.04 with i386 arch.

Kwin excellently crashes with:
FreeNX 0.73 (recent version from FreeNX Stable PPA)
Nomachine NX Server (nxserver_3.5.0-11)

To work around i replaced libxfixes3 with version from oneiric:
http://ubuntu.mirror.cambrium.nl/ubuntu//pool/main/libx/libxfixes/libxfixes3_5.0-4_i386.deb

After that NX and FreeNX are working fine.

I hope someone is fixing this soon, its pretty ugly for a LTS version ... :-(

tnx

chris

I'm running x2go, too.
Just applied Timothy Pearson #15 (thank you Timothy)
Except for a few crashes printerapplet, synapticsconfig everything is fine, as long as i don't try to apt-get install anything.

With oneiric going EOL pretty soon, having an LTS release being this dysfunctional is pretty lame :(

Reinhard Tartler (siretart) wrote :

I can reproduce this issue. Following the suggestion from comment #34, I can also confirm that downgrading libxfixes to version 5.0-4 avoids the crash in kwin.

Raof, I see that you have introduced the latest changes to libxfixes. Could you please have a look at this? Thanks!

affects: libx11 (Ubuntu) → libxfixes (Ubuntu)
Changed in libxfixes (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Reinhard Tartler (siretart) wrote :

fun fact: recompiling libxfixes 5.0-4 in a raring environment avoids the segfaults in kwin, but silently breaks kwin's randr, i.e., kwin does no longer react to screen resizes.

Reinhard Tartler (siretart) wrote :

Another, less intrusive workaround is to start x2goagent/nxagent with the command-line option "-extension XFIXES", which disables the XFIXES extension completely in the x server. KDE does not seem to badly require it, I guess some effects won't work anymore.

In x2go, you have to change two locations in /usr/bin/x2gostartagent. This should also do with plain NX and FreeNX, but I'm not sure what script start the nxagent.

It seems that the segfault comes from the fact that Qt passes an X11 event with a bogus "root" field member. This way, the XRRRootToScreen call is not able to find the screen number. the librandr call above does not expect this case and just segfaults.

Iordan Iordanov (iiordanov) wrote :

Would disabling xfixes affect the ability of the window manager to detect a resize of the NX client window?

On Fr, Dez 14, 2012 at 17:32:16 (CET), Iordan Iordanov wrote:

> Would disabling xfixes affect the ability of the window manager to
> detect a resize of the NX client window?

No, that would happen if you disable XRANDR. In my first, quick tests, I
could not observe any visible change.

see http://en.wikipedia.org/wiki/XFixes for what XFIXES provides

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Gareth Clay (gareth-clay) wrote :

Reinhard, thanks for your excellent workaround - this seems far less intrusive than downgrading libs.

In case it helps anyone else, after a bit of searching I found the file to change to add the nxagent command line arg to a plain NoMachine NX install.

The file is /usr/NX/etc/node.cfg. The property to modify is AgentExtraOptions.

molostoff (molostoff) wrote :

BTW, got this today

r300: DRM version: 2.24.0, Name: ATI RV515, ID: 0x7210, GB: 1, Z: 1
r300: GART size: 509 MB, VRAM size: 128 MB
r300: AA compression RAM: YES, Z compression RAM: NO, HiZ RAM: NO
r300: DRM version: 2.24.0, Name: ATI RV515, ID: 0x7210, GB: 1, Z: 1
r300: GART size: 509 MB, VRAM size: 128 MB
r300: AA compression RAM: YES, Z compression RAM: NO, HiZ RAM: NO
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV515
OpenGL version string: 2.1 Mesa 9.1-devel (git-afec10d precise-oibaf-ppa)
OpenGL shading language version string: 1.20
Driver: R300G
GPU class: R500
OpenGL version: 2.1
GLSL version: 1.20
Mesa version: 9.1
X server version: 1.11.3
Linux kernel version: 3.7
Direct rendering: yes
Requires strict binding: yes
GLSL shaders: limited
Texture NPOT support: limited
kwin(5070): Shaders are not supported
r300_emit.c:104:r300_emit_dsa_state: Assertion `cs_count == 0' failed.

Reinhard Tartler (siretart) wrote :

On Di, Jan 08, 2013 at 05:32:21 (CET), molostoff wrote:

> BTW, got this today

[...]

> r300_emit.c:104:r300_emit_dsa_state: Assertion `cs_count == 0' failed.

This issue does not seem related to this bug, so please file another
one. As workaround, try disabling GLX in nxagent.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

HansHook (hans-hook) wrote :

Unfortunately I had no success with free NX using Reinhards suggestions.
I tried to add "-extension XFIXES" to nxloadconfig like this:
AGENT_EXTRA_OPTIONS_X="-extension XFIXES -nolisten tcp -dpi 96"

(Ubuntu 2d works though... i.e. only KDE crashes.)

Regards

Reinhard Tartler (siretart) wrote :

On Mi, Jan 09, 2013 at 09:56:24 (CET), HansHook wrote:

> Unfortunately I had no success with free NX using Reinhards suggestions.
> I tried to add "-extension XFIXES" to nxloadconfig like this:
> AGENT_EXTRA_OPTIONS_X="-extension XFIXES -nolisten tcp -dpi 96"

Did you really verify that the nxagent process gets this option passed?

Please paste the full command line of the actual running nxagent
instance as found in /proc/$PIDOFAGENT/cmdline

Btw, the latest release of x2goagent disables both GLX and XFIXES by
default because of this issue.
--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

HansHook (hans-hook) wrote :

I managed to get a short glimps of the commandline...

using:
cd proc
watch "find . -name cmdline -exec grep -a nxagent {} + | grep -va grep"

(There must be a better way...)
This is the result:

/usr/bin/nxagent-persistent-D-nameNX - notroot@mandela3:2001 - Mandela2 (GPL Edition)-options/home/notroot/.nx/C-mandela3-2001-022E9EDA4C4D2AFF7DDFDDFFE36FB6E5/options-extensionXFIXES-nolistentcp-dpi96:2001

The option is there but not in the right place ... right?

Regards

HansHook (hans-hook) wrote :

>Btw, the latest release of x2goagent disables both GLX and XFIXES by
>default because of this issue.

I can verify this.
x2go is now providing me with a working KDE remote desktop!

This is indeed very promising!

Regards

Created attachment 73555
proposed patch

kwin crashes on xrandr event .

from src/Xrandr.c
    switch (event->type - info->codes->first_event) {
    case RRScreenChangeNotify:
        scevent = (XRRScreenChangeNotifyEvent *) event;
        snum = XRRRootToScreen(dpy,
                               ((XRRScreenChangeNotifyEvent *) event)->root);
<--- snum is returned as -1 here on nx server
        if (scevent->rotation & (RR_Rotate_90 | RR_Rotate_270)) {
                dpy->screens[snum].width = scevent->height;

reference:
https://bugs.launchpad.net/ubuntu/+source/libxfixes/+bug/985202

affects: libxfixes (Ubuntu) → libxrandr (Ubuntu)
Ritesh Khadgaray (khadgaray) wrote :

needs review. fixes the issue on my system.

tags: added: patch

The attachment "proposed patch for precise" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in libxrandr (Ubuntu):
importance: Undecided → High
Changed in libxrandr (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxrandr - 2:1.4.0-1ubuntu1

---------------
libxrandr (2:1.4.0-1ubuntu1) raring; urgency=low

  * fix-kwin-crashes-on-xrandr-update-on-NX.diff: Fix kwin crashing on
    xrandr update (LP: #985202)
 -- Timo Aaltonen <email address hidden> Wed, 06 Mar 2013 17:27:48 +0200

Changed in libxrandr (Ubuntu):
status: Confirmed → Fix Released
HansHook (hans-hook) wrote :

I am using ubuntu 12.04 but bug remains just as before....

dpkg -l | grep libxrandr
ii libxrandr-dev-lts-quantal 2:1.4.0-1~precise1 X11 RandR extension library (development headers)
ii libxrandr-ltsq2 2:1.4.0-1~precise1 X11 RandR extension library
ii libxrandr2 2:1.4.0-1 X11 RandR extension library
ii libxrandr2:i386 2:1.4.0-1 X11 RandR extension library

The new packages do seem to help! :-)

I downloaded and installed the new libxrandr2 packages (i386 and amd64) from https://launchpad.net/ubuntu/+source/libxrandr and they do indeed seem to resolve this issue.

I have logged in via vnc and tested change of desktop resolution via xrandr -s. Kwin did not crash any more, nor did kded4. Very nice. I hope it works for all of you logging in via NX. (I recently gave up completely on NX and x2go since there is always something not working, like authentication for some system settings...)

Timo Aaltonen (tjaalton) on 2013-02-14
Changed in libxrandr (Ubuntu Precise):
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in libxrandr (Ubuntu):
assignee: Chris Halse Rogers (raof) → nobody
Timo Aaltonen (tjaalton) on 2013-02-19
Changed in libxrandr (Ubuntu Precise):
status: Triaged → In Progress
Timo Aaltonen (tjaalton) on 2013-02-19
description: updated
HansHook (hans-hook) wrote :

Unfortunately still unable to make NX server work with kde in 12.04 :-(

I have tired the libxrandr2 packages from Ringtale without success.

What would probably work is to find the correct spot for adding:
-extension XFIXES
to nx scripts since X2go works quite well.

Has anyone been able to successfully add '-extension XFIXES' to nx scripts and in that case where and how?

Regards

HansHook (hans-hook) wrote :

FreeNX in kubuntu 12.10 is also not possible - same symptoms...

also

'-extension XFIXES 'does definitively not fix it for NX in 12.04

This is all very sad.

Dave Walker (davewalker) wrote :

HansHook, Are you saying that this patch in the queue is not suitable?
http://launchpadlibrarian.net/131627487/libxrandr_2%3A1.3.2-2_2%3A1.3.2-2ubuntu0.1.diff.gz

Thanks.

Timo Aaltonen (tjaalton) wrote :

Hans: please run 'apt-cache policy libxrandr2' and paste the output here. 1.4.0-1 doesn't have the fix, and you probably need to test _without_ the backport stack.

agenkin (agenkin-p) wrote :

I have tried the following on a clean install of Ubuntu 12.04:
1. Installed nxnode_3.5.0-9_i386.deb and nxserver_3.5.0-11_i386.deb from nomachine.com
2. Installed libxrandr2_1.4.0-1ubuntu1_i386.deb from https://launchpad.net/ubuntu/+source/libxrandr (under Raring) - note that I'm installing a Raring binary package on a Precise system, but it seems to work fine.

I can confirm that the Kwin crash is gone, from as much as I could test. However, I've noticed another problem:

When the main NX window is resized, the Kwin desktop does not get resized with it. The root window does change the resolution, though, which is evidenced by the fact that windows can be dragged into the newly added area. See the attached screenshot for a visual explanation of the problem.

I discovered that downgrading libxfixes3 package to the one from Oneric (isntall package libxfixes3_5.0-4_i386.deb) enables the Kwin desktop window to be resized together with the main NX window.

Iordan Iordanov (iiordanov) wrote :

I just started a new bug about Kwin not resizing itself to fit within the NX window (when the NX window is resized). This can be reproduced when NOT in full-screen only.

Here is a link to the new bug in case people want to follow the developments, share experiences, and help:
https://bugs.launchpad.net/ubuntu/+source/libxfixes/+bug/1152754

HansHook (hans-hook) wrote :

Dave:

I do not know the answer to your question.
What I did do was (as agenkin) install the libxrandr2 packages from Raring.

# dpkg -l | grep libxra
ii libxrandr-dev 2:1.4.0-1ubuntu1 X11 RandR extension library (development headers)
ii libxrandr2 2:1.4.0-1ubuntu1 X11 RandR extension library
ii libxrandr2:i386 2:1.4.0-1ubuntu1 X11 RandR extension library
ii libxrandr2-dbg 2:1.4.0-1ubuntu1 X11 RandR extension library (debug package)
ii libxrandr2-dbg:i386 2:1.4.0-1ubuntu1 X11 RandR extension library (debug package)

This (unfortuanately) does not prevent freeNX from freenx-team PPA ftom crashing with KDE.

How do I apply the patch you are referring to?

Timo:

# apt-cache policy libxrandr2
libxrandr2:
  Installerad: 2:1.4.0-1ubuntu1
  Kandidat: 2:1.4.0-1ubuntu1
  Versionstabell:
 *** 2:1.4.0-1ubuntu1 0
        100 /var/lib/dpkg/status
     2:1.3.2-2 0
        500 http://se.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

I am a bit confused here....
.... test _without_ the backport stack ...

What am I missing out on?
How do I get the fixed libs into my 64bit Ubuntu 12.04?

It seems I am *very* close to getting this working and since NX has been one of my best friends
and I've been using it since before Ubuntu 6.06 ... without any major issues, I am indeed grateful
for any help!

Regards

Hans Höök

Hello Iordan, or anyone else affected,

Accepted libxrandr into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libxrandr/2:1.3.2-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libxrandr (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Kero (kero) on 2013-03-21
tags: added: verification-failed
removed: verification-needed
Kero (kero) on 2013-03-22
tags: added: verification-done
removed: verification-failed
Kero (kero) wrote :

Hi,

I just tested libxrandr 2:1.3.2-2ubuntu0.1 from the proposed repo...at first I thought it didn't help. But it seems I confused the crash messages.

I updated to the newest kernel and rebooted...after that I looked again at the crash message, kwin doesn't crash anymore, it seems it was the printer widget thing that keeps crashing.

HansHook (hans-hook) wrote :

Hi,

I can also verify that the nomachine "free" NX server is not crashing KDE with the proposed repo enabled in 12.04.

Unfortunately the FreeNX server from the ppa:freenx-team/ppa does not.

Regards

Hans Höök

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxrandr - 2:1.3.2-2ubuntu0.1

---------------
libxrandr (2:1.3.2-2ubuntu0.1) precise-proposed; urgency=low

  * fix-kwin-crashes-on-xrandr-update-on-NX.diff: Fix kwin crashing on
    xrandr update (LP: #985202)
 -- Timo Aaltonen <email address hidden> Tue, 19 Feb 2013 09:50:02 +0200

Changed in libxrandr (Ubuntu Precise):
status: Fix Committed → Fix Released
Mike Gabriel (sunweaver) wrote :

Hi all,

I just tested the new libxrandr2 package on precise with X2Go and nx-libs 2:3.5.0.20.

The kwin crashes are gone, indeed. So far so good. However, the NX capability of resizing a non-fullscreen desktop session window is completely gone now.

Expected behaviour:

  o Start a (KDE) session with a geometry of 1024x768 in non-full screen mode
  o Resize the NX agent window (i.e. maximize it or drag with the mouse pointer on one of the window corners
  o Expectation: the desktop shell inside resizes all its elements and adapts to the new desktop size

What happens:

  o the desktop shell stubbornly remains at its initial geometry (1024x768 in this example) and refuses to adapt its
     elements to the new desktop session window size

Greets,
Mike (from X2Go upstream)

Iordan Iordanov (iiordanov) wrote :

Please join the bug-report for the new bug related to Kwin not resizing itself to fit within the NX window.
https://bugs.launchpad.net/ubuntu/+source/libxfixes/+bug/1152754

Seems to be fixed by commit 4e4bbb85499cff052ce03e173b88f1083ba83f86

Changed in xorg-server:
status: Confirmed → Fix Released
Ritesh Khadgaray (khadgaray) wrote :
Ritesh Khadgaray (khadgaray) wrote :
Timo Aaltonen (tjaalton) on 2013-09-02
Changed in libxrandr (Ubuntu):
status: Fix Released → Fix Committed
Changed in libxrandr (Ubuntu Precise):
status: Fix Released → Fix Committed
Ritesh Khadgaray (khadgaray) wrote :

I see this fix has been released with precise-security updates.

Changed in libxrandr (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.