[disco-proposed] The list of applications in Ubuntu Software is empty

Bug #1817223 reported by Edson José dos Santos on 2019-02-21
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libxmlb (Ubuntu)
High
Mario Limonciello
Disco
High
Mario Limonciello

Bug Description

Hi

The COMPLETE LIST of applications in Ubuntu Software is not showing up

See attached image

Thank you

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: gnome-software 3.31.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.19.0-13.14-generic 4.19.20
Uname: Linux 4.19.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Feb 21 19:11:23 2019
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2019-02-11 (10 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190203)
InstalledPlugins:
 gnome-software-plugin-flatpak N/A
 gnome-software-plugin-snap 3.31.2-0ubuntu1
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add your journalctl log to the bug?

Changed in gnome-software (Ubuntu):
importance: Undecided → High
status: New → Incomplete

clear

See attachment

Changed in gnome-software (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Thanks, confirmed in disco-proposed (you shouldn't use proposed, it's meant to be a temporary pocket used for packages validation)

tags: added: block-proposed
summary: - The COMPLETE LIST of applications in Ubuntu Software is not showing up
+ [disco-proposed] The list of applications in Ubuntu Software is empty
Changed in gnome-software (Ubuntu):
status: New → Confirmed
assignee: nobody → Robert Ancell (robert-ancell)

Hi Sebastian,

But is this disk-proposed option that is available not for anyone who wants to report any issues?

If it is not to use because it exists then?

Thank you

After some initialization, this message only appears below in the ESET event log.

Look:

22/02/2019 08:14:13 Media control access Can not unblock removable media (org.freedesktop.udisks2.filesystem-mount)

The rest are gone :)

Waiting for new instructions

Thank you

Please

Disregard the last report above

Sebastien Bacher (seb128) wrote :

> But is this disk-proposed option that is available not for anyone who wants to report any issues?

The option is mostly for developers, also it's useful on stable series where proposed is used for SRU verifications

Hi Sebastian Bacher

The option is mostly for developers, also it's useful on stable series where proposed is used for SRU verifications

The faster the problem is detected, no matter who it is, the faster the solution will be. It's what I think.

Thank you

Jeremy Bicha (jbicha) wrote :

Here's a 'gnome-software --verbose' log.

I can also reproduce this bug with gnome-software 3.31.90 on Debian. I didn't upload that version to experimental yet because of this issue (but my work is in Salsa).

Jeremy Bicha (jbicha) on 2019-02-25
Changed in libxmlb (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged

Hello guys

The problem still continues to be attached

********************
Olá Pessoal

O Problema ainda continua vide anexo

Changed in libxmlb (Ubuntu Disco):
assignee: nobody → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

Closing as wontfix for disco, we decided to stay on 3.30, it's too much work and not enough testing now to land the new version this cycle (see bug #1819779)

Changed in gnome-software (Ubuntu Disco):
status: Triaged → Won't Fix
Changed in libxmlb (Ubuntu Disco):
status: Triaged → Won't Fix

How to roll back to 3.30 ? all the package below:

ii gnome-software 3.31.2-0ubuntu1
ii gnome-software-common
ii gnome-software-plugin-flatpak
ii gnome-software-plugin-snap

On Mar 13 2019, at 5:38 am, Sebastien Bacher <email address hidden> wrote:
> Closing as wontfix for disco, we decided to stay on 3.30, it's too much
> work and not enough testing now to land the new version this cycle (see
> bug #1819779)
>
> ** Changed in: gnome-software (Ubuntu Disco)
> Status: Triaged => Won't Fix
>
> ** Changed in: libxmlb (Ubuntu Disco)
> Status: Triaged => Won't Fix
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1817223
>
> Title:
> [disco-proposed] The list of applications in Ubuntu Software is empty
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1817223/+subscriptions
>

$ sudo apt install gnome-software=3.30.6-2ubuntu2 gnome-software-common=3.30.6-2ubuntu2 gnome-software-plugin-flatpak=3.30.6-2ubuntu2 gnome-software-plugin-snap=3.30.6-2ubuntu2
[sudo] password for fenris:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  ubuntu-software
The following packages will be DOWNGRADED:
  gnome-software gnome-software-common gnome-software-plugin-flatpak gnome-software-plugin-snap
0 upgraded, 0 newly installed, 4 downgraded, 1 to remove and 0 not upgraded.
Need to get 3,058 kB of archives.
After this operation, 5,278 kB disk space will be freed.
Do you want to continue? [Y/n]

$ sudo apt install gnome-software=3.30.6-2ubuntu2 gnome-software-common=3.30.6-2ubuntu2 gnome-software-plugin-flatpak=3.30.6-2ubuntu2 gnome-software-plugin-snap=3.30.6-2ubuntu2 ubuntu-software=3.30.6-2ubuntu2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be DOWNGRADED:
  gnome-software gnome-software-common gnome-software-plugin-flatpak gnome-software-plugin-snap ubuntu-software
0 upgraded, 0 newly installed, 5 downgraded, 0 to remove and 0 not upgraded.
Need to get 3,083 kB of archives.
After this operation, 4,919 kB disk space will be freed.
Do you want to continue? [Y/n]

I can confirmed after downgrade, Ubuntu Software working again.

Hi guys

Ubuntu Software continues to crash, as can be seen in the appendix.
What should we do? Wait for updates or a downgrade done by you?

Thank You

Hi guys

After the dowgnrade of ubuntu software and updates throughout the day, the login request for Cha February disappeared. Everything working normally

Thank You

Steve Langasek (vorlon) wrote :

This bug is blocking the promotion of libxmlb 0.1.8-1 from disco-proposed, but despite the fact that the root bug is in libxmlb, my understanding is that it only affected gnome-software 3.31 which has been dropped from -proposed.

This cannot possibly be a regression in libxmlb 0.1.8-1, which was not yet uploaded when this bug was filed.

I'm therefore dropping the block-proposed tag.

tags: removed: block-proposed
Sebastien Bacher (seb128) wrote :

@Steve, ack, that makes sense, sorry we forgot to do that when we decided to delete the new gnome-software

Changed in libxmlb (Ubuntu):
status: Triaged → Fix Released
Changed in libxmlb (Ubuntu Disco):
status: Won't Fix → Fix Released
Changed in libxmlb (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Mario Limonciello (superm1)
Robert Ancell (robert-ancell) wrote :

Closing the gnome-software tasks as we downgraded.

no longer affects: gnome-software (Ubuntu)
no longer affects: gnome-software (Ubuntu Disco)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.