package libxml-sax-perl 0.16+dfsg-3 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Bug #366969 reported by amitm on 2009-04-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libxml-sax-perl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libxml-sax-perl

After upgrading from Intrepid 8.10 to Jaunty 9.04, everytime I run Synaptic or install any package (in 'apt' also), I get this error messages-->
libxml-sax-perl: subprocess post-installation script returned error exit status 1

For example when I try to install some perl XML libraries (libxml-...-perl), the installation is unsuccessful with these error messages - {produced as it is from the error pop-out window in Synaptic}
E: libxml-sax-perl: subprocess post-installation script returned error exit status 1
E: libxml-libxml-perl: dependency problems - leaving unconfigured
E: libxml-sax-expat-perl: dependency problems - leaving unconfigured
E: libxml-filter-buffertext-perl: dependency problems - leaving unconfigured
E: libxml-sax-writer-perl: dependency problems - leaving unconfigured
E: libpod-sax-perl: dependency problems - leaving unconfigured
E: libxml-filter-sort-perl: dependency problems - leaving unconfigured
E: libxml-libxslt-perl: dependency problems - leaving unconfigured
E: libxml-sax-expat-incremental-perl: dependency problems - leaving unconfigured
E: libxml-sax-machines-perl: dependency problems - leaving unconfigured
E: libxml-simpleobject-libxml-perl: dependency problems - leaving unconfigured

My system information-
{uname -a}
Linux megh 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

Release of Ubuntu -
{lsb_release -rd}
Description: Ubuntu 9.04
Release: 9.04

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: libxml-sax-perl 0.16+dfsg-3
PackageArchitecture: all
SourcePackage: libxml-sax-perl
Title: package libxml-sax-perl 0.16+dfsg-3 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.28-11-generic i686

amitm (amit491) wrote :
SteveH (stephen-huggins) wrote :

Please could someone give us an update on this issue.

It's been open for 5 or 6 weeks already and is still "new".

Thanks in advance.

SteveH (stephen-huggins) wrote :

I added this bug report as a duplicate of bug #329652 as they both have their origin in an error in the post-installation script of libxml-sax-perl.

This other bug has already been confirmed.

Evan Carroll (evancarroll) wrote :

update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX::Parser with priority 50...
Fatal: cannot call XML::SAX->save_parsers_debian().

found in dpkg terminal log

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers