Ubuntu

The program 'gnome-settings-daemon' received an X Window System error. During on a FreeNX server suring a session.

Reported by mabawsa on 2009-08-05
172
This bug affects 25 people
Affects Status Importance Assigned to Milestone
FreeNX Server
Undecided
Unassigned
gnome-settings-daemon
Fix Released
Critical
libxklavier (Ubuntu)
High
Chris Coulson
Jaunty
High
Unassigned
Karmic
High
Chris Coulson

Bug Description

Binary package hint: gnome-settings-daemon

The only side effect is that theming and icons display incorrectly. It has only recently started to happen so there may be a regression somewhere.
After logging into freenx and Typing gnome-settings-daemon returns the following:

** (gnome-settings-daemon:21810): WARNING **: Unable to start xrandr manager: unhandled X error while getting the range of screen sizes
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadClass, invalid event class'.
  (Details: serial 155 error_code 133 request_code 131 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Disabling the keyboard plugin stops the error and the themes load correctly.
$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ apt-cache policy gnome-settings-daemon
gnome-settings-daemon:
  Installed: 2.26.1-0ubuntu2
  Candidate: 2.26.1-0ubuntu2
  Version table:
 *** 2.26.1-0ubuntu2 0
        500 http://ubuntu-ashisuto.ubuntulinux.jp jaunty-updates/main Packages
        100 /var/lib/dpkg/status
     2.26.0-0ubuntu4 0
        500 http://ubuntu-ashisuto.ubuntulinux.jp jaunty/main Packages

$ apt-cache policy freenx
freenx:
  Installed: 0.7.3+teambzr104-0freenxteam1
  Candidate: 0.7.3+teambzr104-0freenxteam1
  Version table:
 *** 0.7.3+teambzr104-0freenxteam1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status

Expect to happen: Themes to render correctly.
Instead: gnome-settings daemon crashes

Related branches

mabawsa (mabawsa) on 2009-08-06
summary: The program 'gnome-settings-daemon' received an X Window System error.
+ During on a FreeNX server suring a session.
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Please try to obtain a backtrace as described in your error above and following the instructions at https://wiki.ubuntu.com/DebuggingProgramCrash (run "gnome-settings-daemon --sync" in GDB, and then set a breakpoint on gdk_x_error, and obtain the backtrace when this function is called).

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
mabawsa (mabawsa) wrote :

OK I tried to follow the instructions and got the following attachment.
However even though the debugging symbols are installed (see the attached synaptic image) gdb throws up a lot of (no debugging symbols found) so I am not too sure what where I am going wrong.

Sebastien Bacher (seb128) wrote :

it seems you didn't install libgtk2.0-0-dbg

mabawsa (mabawsa) wrote :

Thanks for the tip. I installed libgtk2.0-0-dbg and it reduced the '(no debugging symbols found)' messages, but it still isn't reporting any backtrace.

Sebastien Bacher (seb128) wrote :

weird, the ""gdk_x_error" not defined." usually indicates that gdk debug symbols are not there

Soundman (hccpub) wrote :

Hello. I notice that, before gnome-settings-daemon fails as described, it says:
Xlib: extension "Generic Event Extension" missing on display ":1003.0".
Xlib: extension "Generic Event Extension" missing on display ":1003.0".
Xlib: extension "Generic Event Extension" missing on display ":1003.0".
Xlib: extension "Generic Event Extension" missing on display ":1003.0".
Xlib: extension "Generic Event Extension" missing on display ":1003.0".

It also reproduces for me using the commercially packaged nxserver from nomachine.com. Perhaps this means that gnome-settings-daemon is looking for an X extension that Jaunty's X has, but that nxserver does not support? If this is the case, then would it be possible to make gnome-settings-daemon not depend on this X extension, as the ability to fully use nx sessions is very important to some users?

I was also unable to get a debugging callstack using gdb, but am hoping that this error message makes it clear why it doesn't work.

Aaron Kelley (aaronkelley) wrote :

I see those errors all the time when starting applications in an NX session. For instance, starting gedit from the terminal gives errors like that. I don't think it's related to this bug, because it's been happening as long as I can remember.

Soundman (hccpub) wrote :

In the original problem description, mabawsa wrote:
"Disabling the keyboard plugin stops the error and the themes load correctly."

Keyboard plugin to what? How does one disable this?

I agree that the warnings about Generic Event Extension missing are probably not related. Sorry about that mislead.

mabawsa (mabawsa) wrote :

To do this u can use gconf-editor:

$ gconf-editor

Then navigate to the appropriate key (see attached image)

Sebastien Bacher (seb128) wrote :

Would be interesting to try on karmic

vinicius.vbf (vinicius-vbf) wrote :

We should nominate this bug as "The Infamous Highlander Bug".
Just kidding :)
Affecting me too since last year. I'm using the original NoMachine NX Server and Client.
Disabling the keyboard plugin works perfectly.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

gnome-settings-daemon:
  Installed: 2.26.1-0ubuntu2
  Candidate: 2.26.1-0ubuntu2
  Version table:
 *** 2.26.1-0ubuntu2 0
        500 http://br.archive.ubuntu.com jaunty-updates/main Packages
        100 /var/lib/dpkg/status
     2.26.0-0ubuntu4 0
        500 http://br.archive.ubuntu.com jaunty/main Packages

Sebastien Bacher (seb128) wrote :

the issue there is clearly a bug in gnome-settings-daemon when some xserver feature are not available, having a gdb stacktrace would be useful though

mabawsa (mabawsa) wrote :

Any ideas on how I can get the stack trace??

Sebastien Bacher (seb128) wrote :

you can install libgtk2.0-0-dbg and do
- gdb gnome-settings-daemon
(gdb) break gdk_x_error
(gdb) run --sync --no-daemon
get the crash
(gdb) bt full

it should stop on the error

I have the same problem.

mabawsa (mabawsa) wrote :

OK the -no-daemon did the trick. Is this enough or should I install the other symbols?

Sebastien Bacher (seb128) wrote :

could you get one with libgnome-desktop2-dbgsym and libx11-6-dbgsym installed?

mabawsa (mabawsa) wrote :

OK

Sebastien Bacher (seb128) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → New
status: New → Triaged
Changed in gnome-settings-daemon:
status: Unknown → New
Chris Coulson (chrisccoulson) wrote :

I'm not sure that trace is showing the real error there, as the error shown in your trace should be trapped correctly and not cause g s-d to exit (and your debug output suggests this is the case as well). Would you mind trying again, but after encountering the first gdk_x_error in GDB, could you please type "cont" and see if GDB catches a second error? If it does, please attach the backtrace for this second error ("bt full").

Thanks

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Incomplete
mabawsa (mabawsa) wrote :

OK

Chris Coulson (chrisccoulson) wrote :

Thank you. That trace there seems to be the right one now, showing the error that triggers the crash. (XSelectExtensionEvent causes the BadClass error, which seems plausible according to the libxi documentation). There are still a few missing symbols though which could make it more useful. Would you mind please obtaining the same backtrace again, but with the following extra packages installed too:

libglib2.0-0-dbg, libxklavier12-dbgsym and libxi6-dbg

Once you've done this, I will forward this upstream. Thanks, and sorry for all the round-trips ;)

Chris Coulson (chrisccoulson) wrote :

Could you also please attach your /var/log/Xorg.0.log? I want to see if you have XInputExtension. It seems that the mouse plugin had a similar issue and was fixed by this change:

http://bugzilla.gnome.org/attachment.cgi?id=123812&action=view

There is similar code in xklavier used by the keyboard plugin (which is where this error is coming from) but there doesn't seem to be a check if XInputExtension is there or not (or the logic isn't working correctly):

#ifdef HAVE_XINPUT
 if (xkl_engine_priv(engine, features) | XKLF_DEVICE_DISCOVERY) {
  DevicePresence(display, xitype, xiclass);
  XSelectExtensionEvent(display,
          xkl_engine_priv(engine, root_window),
          &xiclass, 1);

That might be the issue here. Would it also be possible for you to try this on Karmic?

Thanks

mabawsa (mabawsa) wrote :

Thanks for your time Chris and Sebastien. Here is the new gdb file and my Xorg log.
Unfortunately I don't have Karmic installed on the nx servers I have and as they are calculation servers used by 5-6 users I don't want to install a development version. I do have a spare machine which I will try to install Karmic and test this on but this will take time.

mabawsa (mabawsa) wrote :
Chris Coulson (chrisccoulson) wrote :

Thanks. The Xorg.0.log actually isn't that much use as you're using FreeNX, so it doesn't have the information I was looking for (my fault). Anyway, I did some reading online, and FreeNX doesn't support XInputExtension AFAICT, which is what triggers your issue here.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → Triaged
Chris Coulson (chrisccoulson) wrote :

Hi,

Could you please post the output of "xdpyinfo -ext XInputExtension"?

Could you also please run "XKL_DEBUG=200 gnome-settings-daemon --sync --debug --no-daemon 2>&1 | tee g-s-d.log" up until the point that it crashes?

Thanks

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Incomplete
mabawsa (mabawsa) wrote :
Download full text (4.2 KiB)

$ xdpyinfo -ext XInputExtension
name of display: :1000.0
version number: 11.0
vendor string: The X.Org Foundation
vendor release number: 60900000
X.Org version: 6.9.0
maximum request size: 16777212 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
number of supported pixmap formats: 7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range: minimum 8, maximum 255
focus: window 0x4e00004, revert to Parent
number of extensions: 26
    BIG-REQUESTS
    DAMAGE
    DEC-XTRAP
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    GLX
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RANDR
    RECORD
    RENDER
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFIXES
    XFree86-Bigfont
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number: 0
number of screens: 1

screen #0:
  dimensions: 1280x800 pixels (433x271 millimeters)
  resolution: 75x75 dots per inch
  depths (7): 24, 1, 4, 8, 15, 16, 32
  root window id: 0x8f
  depth of root window: 24 planes
  number of colormaps: minimum 1, maximum 1
  default colormap: 0x75
  default number of colormap cells: 256
  preallocated pixels: black 0, white 16777215
  options: backing-store YES, save-unders YES
  largest cursor: 1280x800
  current input event mask: 0xfa8033
    KeyPressMask KeyReleaseMask EnterWindowMask
    LeaveWindowMask ExposureMask StructureNotifyMask
    SubstructureNotifyMask SubstructureRedirectMask FocusChangeMask
    PropertyChangeMask ColormapChangeMask
  number of visuals: 8
  default visual id: 0x6d
  visual:
    visual id: 0x6d
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x6e
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x6f
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x70
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x71
    class: DirectColor
    depth: 24 planes
    available colormap entries: 256 per subfi...

Read more...

mabawsa (mabawsa) wrote :
Download full text (4.2 KiB)

$ xdpyinfo -ext XInputExtension
name of display: :1000.0
version number: 11.0
vendor string: The X.Org Foundation
vendor release number: 60900000
X.Org version: 6.9.0
maximum request size: 16777212 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
number of supported pixmap formats: 7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range: minimum 8, maximum 255
focus: window 0x4e00004, revert to Parent
number of extensions: 26
    BIG-REQUESTS
    DAMAGE
    DEC-XTRAP
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    GLX
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RANDR
    RECORD
    RENDER
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFIXES
    XFree86-Bigfont
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number: 0
number of screens: 1

screen #0:
  dimensions: 1280x800 pixels (433x271 millimeters)
  resolution: 75x75 dots per inch
  depths (7): 24, 1, 4, 8, 15, 16, 32
  root window id: 0x8f
  depth of root window: 24 planes
  number of colormaps: minimum 1, maximum 1
  default colormap: 0x75
  default number of colormap cells: 256
  preallocated pixels: black 0, white 16777215
  options: backing-store YES, save-unders YES
  largest cursor: 1280x800
  current input event mask: 0xfa8033
    KeyPressMask KeyReleaseMask EnterWindowMask
    LeaveWindowMask ExposureMask StructureNotifyMask
    SubstructureNotifyMask SubstructureRedirectMask FocusChangeMask
    PropertyChangeMask ColormapChangeMask
  number of visuals: 8
  default visual id: 0x6d
  visual:
    visual id: 0x6d
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x6e
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x6f
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x70
    class: TrueColor
    depth: 24 planes
    available colormap entries: 256 per subfield
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    significant bits in color specification: 8 bits
  visual:
    visual id: 0x71
    class: DirectColor
    depth: 24 planes
    available colormap entries: 256 per subfi...

Read more...

mabawsa (mabawsa) wrote :

Sorry for the double posting.

Chris Coulson (chrisccoulson) wrote :

Thanks for the info.

That's interesting anyway - it seems you do have XIE there. We've identified and fixed one bug in libxklavier now that could cause a crash when XIE is missing, but that isn't going to fix your issue though. I'm completely stuck now - I think my next step is to run FreeNX here and do some debugging locally.

Mind helping me set that up? (I've really got no idea how to)

Spooky (roederja) wrote :

This guide covers it pretty well: https://help.ubuntu.com/community/FreeNX

Chris Coulson (chrisccoulson) wrote :

As pointed out a few comments ago, the actual code in libxklavier where this error occurs is this:

#ifdef HAVE_XINPUT
 if (xkl_engine_priv(engine, features) | XKLF_DEVICE_DISCOVERY) {
  DevicePresence(display, xitype, xiclass);
  XSelectExtensionEvent(display,
          xkl_engine_priv(engine, root_window),
          &xiclass, 1);

There is an error with that function in it's current form (the if statement always evaluates true, even if the X server has no XIE). However, that isn't your issue here. The log from g-s-d clearly shows that your X server has XIE loaded:

[1250597338,150,xklavier_xkb.c:xkl_xkb_init/] XInputExtension found (131, 66, 129)

...and your output of xdpyinfo supports this too. With that in mind, I can't think of any reason why this code section would cause this error, other than an issue with NX itself. I've spoken with the maintainer of libxklavier too, and we agreed that this should be assigned to FreeNX now (at least until we see a similar issue with Xorg)

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Invalid
Chris Coulson (chrisccoulson) wrote :

Spooky - thanks for the info. I will take a look at that when I get the chance

Chris Coulson (chrisccoulson) wrote :

Jens has pointed out in the upstream bug report that the presence of XIE does not necessarily mean that DevicePresence is supported. So, this can be fixed in libxklavier after all

affects: gnome-settings-daemon (Ubuntu) → libxklavier (Ubuntu)
Changed in libxklavier (Ubuntu):
status: Invalid → Triaged
Changed in freenx-server:
status: New → Invalid
Kamilion (kamilion) wrote :

Getting bit by this as well.
Have up to date karmic on a fresh new 16 core with no user data on it yet.
Let me know how I can help test.

Stéphane Graber (stgraber) wrote :

Adding the regression-update tag as the bug appeared with 3.9-0ubuntu2 in jaunty-updates.
Downgrading that single package to 3.9-0ubuntu1 solves the issue without needing any kind of gconf configuration.

That command will revert to a working libxklavier12:
apt-get install --reinstall libxklavier12=3.9-0ubuntu1

It must be noted that the reverting to that version will make dynamic changes of keyboard stop working.
It's also probably a good idea of holding that package to that specific version until we get a fixed package using:

echo libxklavier12 hold | dpkg --set-selections

tags: added: regression-update
Chris Coulson (chrisccoulson) wrote :

Good spot there - thanks! The extra build-dep on libxi-dev enables the code which trigger this.

Changed in libxklavier (Ubuntu Jaunty):
importance: Undecided → High
status: New → Triaged
Stéphane Graber (stgraber) wrote :

I have been successful at reproducing the issue with Karmic.

Changed in libxklavier (Ubuntu Karmic):
importance: Low → High
Stéphane Graber (stgraber) wrote :

Here's the error output when starting g-s-d on karmic:
stgraber@orilla:~$ gnome-settings-daemon
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 102 error_code 1 request_code 150 minor_code 8)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Stéphane Graber (stgraber) wrote :

Marked the task as invalid as my conclusion was wrong.
The result although being extremely similar comes because of the xrandr plugin this time and not the keyboard plugin as it used to be in jaunty.

I'll file another bug against gnome-settings-daemon for that issue (xrandr plugin not starting in NX session).

Changed in libxklavier (Ubuntu Karmic):
status: Triaged → Invalid
Stéphane Graber (stgraber) wrote :

I guess some are going to hate me for all that noise, sorry for that.
Working again on a clean system, there are actually two issues on Karmic.

First: Our usual libxklavier bug when built with Xinput support (that I didn't see at first as I was running a patched version)
Second: g-s-d crashing when the xrandr plugin is enabled in a NX session

I restored the bug status for Karmic to reflect that. Sorry again

Changed in libxklavier (Ubuntu Karmic):
status: Invalid → Triaged
Stéphane Graber (stgraber) wrote :

And here's the actual error on Karmic (the Xinput issue, not the xrandr one):

The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'XI_BadClass (invalid Class parameter)'.
  (Details: serial 149 error_code 133 request_code 131 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Chris Coulson (chrisccoulson) wrote :

Here's a patch for Karmic

Changed in libxklavier (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxklavier - 4.0-0ubuntu4

---------------
libxklavier (4.0-0ubuntu4) karmic; urgency=low

  * debian/patches/92_handle_xi_errors.patch:
    - Upstream CVS change to trap XI errors resulting from missing
      features in FreeNX, and not crash gnome-settings-daemon
      (LP: #409621)
  * debian/patches/93_correct_xi_detection.patch:
    - Upstream CVS change to correct the logic used in XIE detection

 -- Chris Coulson <email address hidden> Thu, 15 Oct 2009 01:56:00 +0100

Changed in libxklavier (Ubuntu Karmic):
status: Fix Committed → Fix Released
mabawsa (mabawsa) wrote :

I just upgraded to Karmic. There is a new xrand bug that stops gsd loading and that plugin needs to be disabled; I should report a new bug maybe. Anyway the keyboard plugin patch appeared to work as when I enabled the plugin gsd started. However on subsequent restarts gsd crashes (even with xrand disabled) so perhaps the fix needs further testing. Or maybe its another bug.

mabawsa (mabawsa) wrote :

btw this is the output I get from gsd with the "fixed" libxklavier (4.0-0ubuntu4) and keyboard plugin enabled:
~$ gnome-settings-daemon
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
Xlib: extension "Generic Event Extension" missing on display ":1000.0".
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'XI_BadClass (invalid Class parameter)'.
  (Details: serial 149 error_code 133 request_code 131 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

mabawsa (mabawsa) wrote :

OK I made similar logs to last time (with and without xrand enabled)

mabawsa (mabawsa) wrote :
mabawsa (mabawsa) wrote :
mabawsa (mabawsa) wrote :
mabawsa (mabawsa) wrote :

btw the last two files have xrand disabled.

Chris Coulson (chrisccoulson) wrote :

Thanks for testing, I can see why it's not working.

Would you mind reporting the xrandr issue separately please, and obtain the backtrace with libxrandr2-dbg installed please?

Thanks

Changed in libxklavier (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
status: Fix Released → Triaged
Changed in libxklavier (Ubuntu Karmic):
status: Triaged → In Progress
Björn Harrtell (bjorn-wololo) wrote :

I'm using NX from NoMachine and I'm guessing this same problem happens with their client/server too.

Anyhow, attaching the output I get from trying to start gnome-settings-deamon since it's slightly different from mabawsa.

Chris Coulson (chrisccoulson) wrote :

Björn - your is not the same issue

Chris Coulson (chrisccoulson) wrote :

mabawsa - I've just uploaded an updated libxklavier in my PPA. Please test this and see if it fixes your crash with the keyboard plugin.

My PPA can be found here: https://edge.launchpad.net/~chrisccoulson/+archive/ppa

You'll need to wait a little while for the package to build

Thanks!

Björn Harrtell (bjorn-wololo) wrote :

Hmm ok, but the end result of my issue is the same as described, "theming and icons display incorrectly." and I've been affected but this since Jaunty if I remember correctly.

Is there anything else I could do to provide a better error report?

mabawsa (mabawsa) wrote :

OK for me your ubuntu5 package works great.
I have reported the xrandr bug (Bug #454487)

Thanks for all your work on this Chris.

Chris Coulson (chrisccoulson) wrote :

Excellent - thanks for testing

Chris Coulson (chrisccoulson) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxklavier - 4.0-0ubuntu5

---------------
libxklavier (4.0-0ubuntu5) karmic; urgency=low

  * debian/patches/92_handle_xi_errors.patch:
    - Updated to trap all XI errors, and not just the first error code.
      Really fix LP: #409621

 -- Chris Coulson <email address hidden> Sat, 17 Oct 2009 15:55:56 +0100

Changed in libxklavier (Ubuntu Karmic):
status: In Progress → Fix Released
Hajime Fujita (hfujita) wrote :

I'm experiencing the very same issue with Björn on FreeNX/Karmic/amd64.
Unfortunately libxklavier (4.0-0ubuntu5) did not work for me.
I'm willing to provide more information about my environment upon request.

As a workaround, as suggested in http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=1236402 ,
put the following two lines into ~/.gtkrc-2.0 worked for me.
  gtk-theme-name="Human"
  gtk-icon-theme-name = "Human"

Chris Coulson (chrisccoulson) wrote :

Hajime - this bug is fixed. If you're still experiencing a crash, then it's a different issue and you should open a new bug report for that. Certainly, your workaround suggests that it is a completely unrelated issue

Björn Harrtell (bjorn-wololo) wrote :

I've opened a bug report for the separate (but similar?) issue in #462257.

vinicius.vbf (vinicius-vbf) wrote :

Great! Upgrading gnome-settings-daemon from Chris Coulson's PPA fixed the issue for me too.
Thank you Chris!

Martin Pitt (pitti) on 2010-02-04
Changed in libxklavier (Ubuntu Jaunty):
status: Triaged → Won't Fix
Changed in gnome-settings-daemon:
importance: Unknown → Critical
Jeremy Wilkins (wjeremy) wrote :

I thought this bug was fixed, why is it still active?

Changed in gnome-settings-daemon:
status: New → Fix Released
To post a comment you must log in.