When trying to install libxkbfile1:i386 the pkg manager asks to remove too many important packages [Multi-arch]

Bug #890928 reported by Alf on 2011-11-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libxkbfile (Ubuntu)
Undecided
Unassigned
Precise
Low
Unassigned

Bug Description

[Impact]
Some third party applications require the use of i386 libxkbfile in their amd64 environment, for example, Lotus Notes.

[Test Case]
Install i386 version on a amd64 system and attempt to link to library.

[Regression Potential]
Minimal as only changes to build procedure are addressed.

On Ubuntu 11.10 (Oneiric) AMD64 version, when I try to install the i386 version of the libxkbfile1 the package manager asks to remove too many important packages, as show below:

$ sudo apt-get install libxkbfile1:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  gnome-control-center gnome-screensaver gnome-session gnome-settings-daemon
  indicator-datetime indicator-power indicator-session libgnomekbd7
  liblightdm-gobject-1-0 libxkbfile1 libxklavier16 nvidia-current
  ubuntu-desktop ubuntuone-client-gnome unity-greeter x11-apps x11-xkb-utils
  xorg xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware
The following NEW packages will be installed:
  libxkbfile1:i386
0 upgraded, 1 newly installed, 49 to remove and 0 not upgraded.
Need to get 67.4 kB of archives.
After this operation, 196 MB disk space will be freed.
Do you want to continue [Y/n]?

Colin Watson (cjwatson) on 2011-11-16
tags: added: multiarch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxkbfile (Ubuntu):
status: New → Confirmed
Tom Ellis (tellis) wrote :

This is because libxkbfile has not yet been converted to multi-arch.

I've worked out an experimental package and will submit a diff shortly.

The experimental package is my ppa here: https://launchpad.net/~tellis/+archive/multiarch/+packages

Tom Ellis (tellis) wrote :

I've had a go at a simple conversion based on: http://wiki.debian.org/Multiarch/Implementation

Please have a look at let me know where it could be improved.

The attachment "libxkbfile_1.0.7-1ubuntu1.1.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Bryce Harrington (bryce) on 2012-04-19
summary: When trying to install libxkbfile1:i386 the pkg manager asks to remove
- too many important packages
+ too many important packages [Multi-arch]
Marcin Juszkiewicz (hrw) wrote :

1.0.8-1 in Debian has multiarch fix too

dorpm (dorpmueller) wrote :

Still a problem in precise. The paket manager wants to remove
driconf
gnome-settings-daemon
kde-workspace
kde-workspace-bin
kdebase-workspace
kubuntu-desktop
libgnomekbd7
libxkbfile1
libxklavier16
x11-apps
x11-xkb-utils
xbase-clients
 xorg xserver-common
xserver-xorg
xserver-xorg-core
xserver-xorg-input-all
xserver-xorg-input-evdev
xserver-xorg-input-mouse
xserver-xorg-input-synaptics
 xserver-xorg-input-vmmouse
xserver-xorg-input-wacom
xserver-xorg-video-ati
xserver-xorg-video-mach64
xserver-xorg-video-r128
xserver-xorg-video-radeon
xserver-xorg-video-vesa
xserver-xorg-video-vmware

Is there any workaround?

Florian

dorpm (dorpmueller) wrote :

I found a workaround: Install libxkbfile (amd and i386) from https://launchpad.net/~tellis/+archive/multiarch/+packages. That solves the problem for the moment.

Florian

Micah Gersten (micahg) wrote :

Already fixed in 1:1.0.8-1 in quantal

Changed in libxkbfile (Ubuntu):
status: Confirmed → Fix Released
Micah Gersten (micahg) wrote :

Trying this with a few modifications which I'll document when I'm done

Changed in libxkbfile (Ubuntu Precise):
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
importance: Undecided → Low
Micah Gersten (micahg) wrote :

In precise-proposed unapproved
I fixed some spacing in debian/rules, fixed the version 1.0.7-1ubuntu0.1, closed the bug in the changelog, and made 3 multiarch fixes that I found in the debian version
   [ Micah Gersten <email address hidden> ]
   * Install udeb into usr/lib/ as Debian did in 1:1.0.8-1
     - update debian/libxkbfile1-udeb.install
   * Mark libxkbfile1-dbg Multi-Arch: same and don't add Pre-Depends to
     libxkbfile-dev since it doesn't ship a shared library
     - update debian/control

Changed in libxkbfile (Ubuntu Precise):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello! This bug is attached to an upload in the queue for precise-proposed. However, it does not contain the requisite fields for the SRU team to process the upload. Please add them per the process outlined here. To be more succinct, make sure the bug description lists these fields: "Impact, Dev Fix, Stable Fix, Regression Potential, Test case".

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

The upload will likely not be looked at by the SRU team until these fields are present.

Thank you!

Chris Halse Rogers (raof) wrote :

For the Impact: section I'd particularly like to know what use-case there for a parallel-installable i386 libxkbfile1. As far as I can tell none of the rdepends of libxkbfile1 are interestingly for multiarch.

Tom Ellis (tellis) wrote :

Hi Chris,
This is required for a 3rd party application outside of the Ubuntu archive, namely Lotus Notes.

Cheers,
Tom

Brian Murray (brian-murray) wrote :

This bug is still missing Impact, Regression Potential and Test Case information in the bug description.

Clint Byrum (clint-fewbar) wrote :

Its been 2 weeks now since requesting the necessary fields. Note that policy has relaxed a bit, so just add Test Case and Regression Potential. Please respond soon, this upload is in danger of being rejected!

Adam Stokes (adam-stokes) wrote :

Ill get something for you shortly. Thanks!

Changed in libxkbfile (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
description: updated

Hello Alf, or anyone else affected,

Accepted libxkbfile into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Thanks. In order to direct the regression-testing effort, here's the list of rdepends:
  scim-kmfl-imengine
  remmina-plugin-nx
  libinput-pad1
  kde-workspace-bin
  fcitx-module-x11
  x11-xkb-utils
  x11-apps
  libxklavier16
  libgnome-desktop-3-4
  libfreerdp1

Are you aware of anything that dlopens libxkbfile or does funky things with it that should also be on this list?

Adam Stokes (adam-stokes) wrote :

I will make sure to check into this further to proactively identify any issues that may arise.

Thanks,
Adam

Sebastien Bacher (seb128) wrote :

This SRU is in the queue for 13 days, could we get it verified?

Adam Stokes (adam-stokes) wrote :

Looks good to me

zef@precise:~$ dpkg -l libxkbfile1:i386 libxkbfile1;dpkg -L libxkbfile1:i386 libxkbfile1:amd64
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=======================-=======================-==============================================================
ii libxkbfile1 1:1.0.7-1ubuntu0.1 X11 keyboard file manipulation library
ii libxkbfile1:i386 1:1.0.7-1ubuntu0.1 X11 keyboard file manipulation library
/.
/usr
/usr/lib
/usr/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu/libxkbfile.so.1.0.2
/usr/share
/usr/share/doc
/usr/share/doc/libxkbfile1
/usr/share/doc/libxkbfile1/changelog.Debian.gz
/usr/share/doc/libxkbfile1/copyright
/usr/lib/i386-linux-gnu/libxkbfile.so.1

/.
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/libxkbfile.so.1.0.2
/usr/share
/usr/share/doc
/usr/share/doc/libxkbfile1
/usr/share/doc/libxkbfile1/changelog.Debian.gz
/usr/share/doc/libxkbfile1/copyright
/usr/lib/x86_64-linux-gnu/libxkbfile.so.1

---

I've done some simple grepping through the rdepends packages and nothing stands out as directly accessing this library through dlopen

Sebastien Bacher (seb128) wrote :

no regression detected here either, setting as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxkbfile - 1:1.0.7-1ubuntu0.1

---------------
libxkbfile (1:1.0.7-1ubuntu0.1) precise-proposed; urgency=low

  [ Tom Ellis <email address hidden> ]
  * Rebuild with multi-arch support (LP: #890928)

  [ Micah Gersten <email address hidden> ]
  * Install udeb into usr/lib/ as Debian did in 1:1.0.8-1
    - update debian/libxkbfile1-udeb.install
  * Mark libxkbfile1-dbg Multi-Arch: same and don't add Pre-Depends to
    libxkbfile-dev since it doesn't ship a shared library
    - update debian/control
 -- Tom Ellis <email address hidden> Tue, 22 May 2012 02:13:13 -0500

Changed in libxkbfile (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers