Xinerama cursor problem in second monitor

Bug #163482 reported by Rich Wales on 2007-11-18
6
Affects Status Importance Assigned to Milestone
libxinerama (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Feisty on a Dell Optiplex GX280. I recently upgraded the video system with a dual-head Radeon card and two 1680x1050 monitors, and it's almost working fine using Xinerama. The only problem is that the mouse pointer isn't updating its appearance properly when I'm positioned in the secondary (right-hand) monitor. Whatever shape the cursor had in the primary (left-hand) monitor, it keeps that same shape no matter what I'm doing on the right. For example, if the mouse pointer is the default arrow shape when I move it onto the right-hand monitor, it keeps the arrow shape even if it ought to be changing to a pointing finger (for a web link), or a "resize", or a "please wait".

In particular, this makes it very difficult to resize a window on the secondary monitor, because I can't tell when the cursor is in exactly the right position to drag the window border.

Any ideas what might be causing this sort of misbehaviour?

FWIW, I did try using Big-Desktop, but I abandoned that method because it wouldn't give me a combined screen resolution higher than 2048x768 (yecch).

Hans van Kranenburg (knorrie) wrote :

I can confirm this behaviour, using a fresh new installed gutsy system with fglrx and Xinerama enabled.

The mouse pointer does get altered, (e.g. when pointing to the lower right corner of a window, ) but the image used doesn't change.

The coordinates of the cursor's hot spot get altered like it should (e.g. when pointing to the lower right corner of a window), but the image stays the same.

~$ uname -a
Linux knorrie 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

~$ dpkg -l | grep fglrx
ii xorg-driver-fglrx 7.1.0-8.37.6+2.6.22.4-14.10 Video driver for ATI graphics accelerators

Rich Wales (richw) wrote :

As an aside, can anyone confirm if Big-Desktop does in fact impose a maximum combined screen resolution of 2048x768?

Or does this sound like a problem with my Xorg configuration when I was trying to use Big-Desktop -- in which case perhaps I should go back and try Big-Desktop again and see if the cursor problem goes away?

Again, I have two 1680x1050 Dell monitors, so nothing less than 3360x1050 combined resolution is acceptable to me. I didn't really notice whether I had any cursor problems with Big-Desktop or not, since the 2048x768 resolution limit turned me off completely.

Also, the dual-head video card in this machine (my desktop at work) is a Dell OEM card with an ATI chipset; I do NOT have the option of switching to an Nvidia card and using TwinView.

Tom Bragg (tom-4ckc) wrote :

Behaviour confirmed here, too on 64-bit.

~$ dpkg -l | grep fglrx
ii xorg-driver-fglrx 7.1.0-8.37.6+2.6.22.4-14.10 Video driver for ATI graphics accelerators

~$ uname -a
Linux lin2 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

Bryce Harrington (bryce) wrote :

Hi richw,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in libxinerama:
status: New → Incomplete
Rich Wales (richw) wrote :

No, I haven't been having this problem for several months now.

I'm currently running 8.04 (2.6.24-21-generic) -- same video card and monitors, still Xinerama -- and the cursor works just fine on both monitors.

I don't remember exactly when the problem went away, but I think it would probably have been after I upgraded from Feisty to Gutsy. Sorry I forgot to come back here and update the bug report at the time.

And FWIW, I never had this problem on my home machine (where I'm using an Nvidia card and Twinview -- something I don't have the option of doing on my work desktop).

Bryce Harrington (bryce) wrote :

Okay, great thanks for letting us know. Feel free to reopen the bug if you notice the issue again.

Changed in libxinerama:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers