evolution run on a remote machine crashes

Bug #781391 reported by David Ronis on 2011-05-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Unknown
Critical
libxi (Ubuntu)
Medium
Unassigned

Bug Description

I've reported this to the evolution folks (https://bugzilla.gnome.org/show_bug.cgi?id=649757) but they say that it's not their fault. Basically I open a remote terminal from my ubuntu box on a remote server (various slackware 12.2/13.0 boxes) and run
evolution on the server from the command line. The application crashes (see the bugzilla.gnome.org) for a backtrace.

This only started happening after I upgraded to 11.04 from 10.04. I t worked `100% of the time and now fails 100% of the time.

The remote machines are all running git/master versions of Xorg.
See the url above for a backtrace.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,move,compiztoolbox,mousepoll,grid,snap,imgpng,place,regex,vpswitch,resize,wall,staticswitcher,gnomecompat,animation,session,expo,workarounds,fade,scale]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAGr9IwAAAAAAESAQOAFg14CrmllllXkSgfUFQAAAABAQEBAQEBAQEBAQEBAQEBUBQAQEFYLCAYiDEA330AAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTAxQVcwMyBWMCAKADw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed May 11 17:11:22 2011
DistUpgraded: Log time: 2011-04-28 11:56:43.046268
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: blcr, 0.8.2: added
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:034a]
   Subsystem: Acer Incorporated [ALI] Device [1025:034a]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: Gateway LT21
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=e9fba85f-4ffb-4215-aa6b-059f1be955f8 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to natty on 2011-04-29 (12 days ago)
dmi.bios.date: 12/15/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: LT21
dmi.board.vendor: Acer
dmi.board.version: V1.10
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.10
dmi.modalias: dmi:bvnAcer:bvrV1.10:bd12/15/2009:svnGateway:pnLT21:pvrV1.10:rvnAcer:rnLT21:rvrV1.10:cvnAcer:ct10:cvrV1.10:
dmi.product.name: LT21
dmi.product.version: V1.10
dmi.sys.vendor: Gateway
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

David Ronis (david-ronis) wrote :
IKT (ikt) on 2011-05-12
affects: ubuntu → evolution (Ubuntu)
Changed in evolution:
importance: Unknown → High
status: Unknown → Incomplete
Changed in evolution (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
David Ronis (david-ronis) wrote :
Download full text (35.9 KiB)

I ran (on the remote box) under valgrind. Now the main GUI maps but evolution seems to hang trying to fetch mail from my various accounts (none of them work). Ultimately I have to kill evolution. Here's what I see on the console:

Script started on Wed 18 May 2011 02:29:39 PM EDT
{ronispc:1:Gar} valgrind evolution
==319== Memcheck, a memory error detector
==319== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==319== Using Valgrind-3.5.0 and LibVEX; rerun with -h for copyright info
==319== Command: evolution
==319==
==319== Invalid write of size 4
==319== at 0x538AD64: copy_classes (in /usr/lib/libXi.so.6.1.0)
==319== by 0x538C198: XIQueryDevice (in /usr/lib/libXi.so.6.1.0)
==319== by 0x51F7B74: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:413)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319== Address 0x5f0d738 is 0 bytes after a block of size 200 alloc'd
==319== at 0x40238EC: malloc (in /usr/local/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==319== by 0x538C182: XIQueryDevice (in /usr/lib/libXi.so.6.1.0)
==319== by 0x51F7B74: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:413)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319==
==319== Invalid write of size 4
==319== at 0x538AD6A: copy_classes (in /usr/lib/libXi.so.6.1.0)
==319== by 0x538C198: XIQueryDevice (in /usr/lib/libXi.so.6.1.0)
==319== by 0x51F7B74: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:413)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319== Address 0x5f0d73c is 4 bytes after a block of size 200 alloc'd
==319== at 0x40238EC: malloc (in /usr/local/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==319== by 0x538C182: XIQueryDevice (in /usr/lib/libXi.so.6.1.0)
==319== by 0x51F7B74: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:413)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319==
==319== Invalid read of size 4
==319== at 0x51F62AF: translate_device_classes (gdkdevicemanager-xi2.c:206)
==319== by 0x51F65A0: add_device (gdkdevicemanager-xi2.c:295)
==319== by 0x51F7BAF: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:419)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319== Address 0x5f0d738 is 0 bytes after a block of size 200 alloc'd
==319== at 0x40238EC: malloc (in /usr/local/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==319== by 0x538C182: XIQueryDevice (in /usr/lib/libXi.so.6.1.0)
==319== by 0x51F7B74: gdk_x11_device_manager_xi2_constructed (gdkdevicemanager-xi2.c:413)
==319== by 0x5A350D9: g_object_newv (gobject.c:1521)
==319== by 0x5A35B22: g_object_new_valist (gobject.c:1610)
==319==
==319== Syscall param writev(vector[...]) points to uninitialised byte(s)
==319== at 0x5D73414: writev (in /lib/libc-2.7.so)
==319== by 0x4B79194: w...

David Ronis (david-ronis) wrote :

One more observation: Other gnome/X applications (e.g., gnumeric, firefox) work as expected when run on the same remote machines.

Changed in evolution:
status: Incomplete → Confirmed
Changed in evolution:
status: Confirmed → Fix Released
David Ronis (david-ronis) wrote :

I've tried updating via ubuntu's update manager--nothing comes up. What exactly was fixed? My suspicion is that this is an Xorg issue, not an evolution one. I've just noticed that my inital posting had the wrong gnome bug #. It should have been 649345

https://bugzilla.gnome.org/show_bug.cgi?id=649345. Sorry for any confusion.

For what it's worth, I'm running the git master of evolution and related packages, updated a few hours ago. The problem remains.

Well, even that other bug report is closed, so let's reassign to X and see. If you could, please report this on bugs.freedesktop.org as requested in the GNOME bug you linked.

Changed in evolution:
importance: High → Unknown
status: Fix Released → Unknown
affects: evolution (Ubuntu) → libxi (Ubuntu)
Changed in libxi (Ubuntu):
status: Triaged → New
Bryce Harrington (bryce) wrote :

Hey david-ronis,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in libxi (Ubuntu):
status: New → Incomplete
David Ronis (david-ronis) wrote :

Hi Bryce,

I've upgraded to 11.10 a while back and have kept it updated. After seeing your commentI tried launching evolution from a remote machine. The problem still exists.

David Ronis (david-ronis) wrote :

One more thing: I had filed a bug in Xorg, see,

https://bugs.freedesktop.org/show_bug.cgi?id=38645

but they said it's probably not their issue.

Rob Clark (rob-ti) wrote :

btw, I notice the same thing when I try to run gnome-settings-daemon or gnome-session w/ rebuild from git master xorg. Since the crash seems to be around libxi, I wonder a bit about the out of tree multitouch stuff that is normally in ubuntu xorg (and maybe effects headers the gnome stuff was compiled with).
-------------------------
*** glibc detected *** /usr/bin/gnome-session: malloc(): memory corruption: 0x00066318 ***

Program received signal SIGABRT, Aborted.
__libc_do_syscall () at ../ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S:50
50 ../ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S: No such file or directory.
 in ../ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
(gdb) bt
#0 __libc_do_syscall () at ../ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S:50
#1 0x4080bdd2 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:67
#2 0x4080e1ae in __GI_abort () at abort.c:92
#3 0x4082f12c in __libc_message (do_abort=2, fmt=0x408ac3b8 "*** glibc detected *** %s: %s: 0x%s ***\n")
    at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#4 0x40835e26 in malloc_printerr (action=3, str=0x408ac85c "malloc(): memory corruption", ptr=<optimized out>) at malloc.c:6283
#5 0x40837222 in _int_malloc (av=0x408c2258, bytes=1012) at malloc.c:4396
#6 0x40838bbc in __GI___libc_malloc (bytes=1012) at malloc.c:3660
#7 0x4090b462 in XIQueryDevice () from /usr/lib/arm-linux-gnueabihf/libXi.so.6
#8 0x40495654 in gdk_x11_device_manager_xi2_constructed (object=0x43590) at /build/buildd/gtk+3.0-3.3.6/./gdk/x11/gdkdevicemanager-xi2.c:414
#9 0x406dbb1e in g_object_newv () from /usr/lib/arm-linux-gnueabihf/libgobject-2.0.so.0
#10 0x406dbd5a in g_object_new_valist () from /usr/lib/arm-linux-gnueabihf/libgobject-2.0.so.0
#11 0x406dbebc in g_object_new () from /usr/lib/arm-linux-gnueabihf/libgobject-2.0.so.0
#12 0x404939c0 in _gdk_x11_device_manager_new (display=0x60000) at /build/buildd/gtk+3.0-3.3.6/./gdk/x11/gdkdevicemanager-x11.c:66
#13 0x40496c96 in _gdk_x11_display_open (display_name=<optimized out>) at /build/buildd/gtk+3.0-3.3.6/./gdk/x11/gdkdisplay-x11.c:1251
#14 0x404958de in gdk_x11_display_manager_open_display (manager=0x3b130, name=0x0)
    at /build/buildd/gtk+3.0-3.3.6/./gdk/x11/gdkdisplaymanager-x11.c:55
#15 0x40481614 in gdk_display_manager_open_display (manager=<optimized out>, name=<optimized out>)
    at /build/buildd/gtk+3.0-3.3.6/./gdk/gdkdisplaymanager.c:383
#16 0x40273ba8 in post_parse_hook (context=<optimized out>, group=<optimized out>, data=0x37d48, error=0xbefff598)
    at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkmain.c:770
#17 0x4076ae06 in g_option_context_parse () from /lib/arm-linux-gnueabihf/libglib-2.0.so.0
#18 0x40273e68 in gtk_init_with_args (argc=0xbefff504, argv=0xbefff500, parameter_string=0x27f48 " - the GNOME session manager", entries=0x35848,
    translation_domain=0x26aa0 "gnome-session-3.0", error=0xbefff598) at /build/buildd/gtk+3.0-3.3.6/./gtk/gtkmain.c:909
#19 0x00011482 in ?? ()
#20 0x00011482 in ?? ()

Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.