X doesn't load in Quantal, downgrading libxfont1 to Precise version fixes it : could not open default font 'fixed'

Bug #992745 reported by Jeremy Bicha on 2012-05-01
124
This bug affects 29 people
Affects Status Importance Assigned to Milestone
libxfont (Ubuntu)
Critical
Unassigned

Bug Description

As was first pointed out in http://ubuntuforums.org/showthread.php?t=1965997&page=11 X won't start any more in Quantal. A workaround is to install libxfont1 1:1.4.4-1 from Precise instead of the 1:1.4.5-1 currently in Quantal.

I reproduced this bug myself just by logging out after upgrading. Virtual terminals wouldn't work for me either.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libxfont1 1:1.4.4-1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue May 1 13:34:26 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-23-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-24-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff66]
   Subsystem: Toshiba America Info Systems Device [1179:ff66]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: TOSHIBA Satellite L305
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=88023b9c-d126-43b8-9c43-93e3a4635f2d ro quiet splash
SourcePackage: libxfont
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/23/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.10:bd09/23/2009:svnTOSHIBA:pnSatelliteL305:pvrPSLB8U-05202F:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite L305
dmi.product.version: PSLB8U-05202F
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Jeremy Bicha (jbicha) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxfont (Ubuntu):
status: New → Confirmed
Harry (harry33) wrote :

Confirming this issue.
Workaround goes by downgrading libxfont1 to the previous version (1.4.4-1).

Confirming also

Bryce Harrington (bryce) on 2012-05-01
Changed in libxfont (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
cpatrick08 (cpatrick08) wrote :

workound works for me

summary: X doesn't load in Quantal, downgrading libxfont1 to Precise version
- fixes it
+ fixes it : could not open default font 'fixed'
dino99 (9d9) wrote :

Affect also Lubuntu i386

tags: added: i386 lubuntu
dino99 (9d9) wrote :

Old report with the same issue : https://bugs.launchpad.net/ubuntu/+source/libxfont/+bug/226156
This has been explained how to fix it and why.

Already changed into edgers ppa:

libxfont (1:1.4.5-1+edgers1) quantal; urgency=critical

  * Remove -Wl,-Bsymbolic-functions from LDFLAGS
 -- Rico Tzschichholz <email address hidden> Tue, 01 May 2012 14:03:09 +0200

Timo Aaltonen (tjaalton) wrote :

the fix is now uploaded to debian, and will soon get synced to quantal

Changed in libxfont (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxfont - 1:1.4.5-2

---------------
libxfont (1:1.4.5-2) unstable; urgency=low

  * Ease sync for Ubuntu: strip -Bsymbolic-functions from LDFLAGS
    (LP: #992745).

 -- Cyril Brulebois <email address hidden> Thu, 03 May 2012 19:59:46 +0200

Changed in libxfont (Ubuntu):
status: Fix Committed → Fix Released
Gabriel Batato (gbatato) wrote :

Ubuntu Server 14.04 libxfont problem cannot startx

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers