can't install kdebase-dev

Bug #48190 reported by dresnu on 2006-06-03
10
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
libxfixes (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kdebase-dev

I'm using Kubuntu 6.06 and have upgraded to kde 3.5.3 via the official kubuntu repository. I can't install package kdebase-dev because I get this whenever I try to install it with apt-get:"Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  kdebase-dev: Depends: kate (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: kdesktop (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: kicker (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: konqueror-nsplugins (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: konqueror (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: ksysguard (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: kwin (= 4:3.5.2-0ubuntu26) but 4:3.5.3-0ubuntu0.1 is to be installed
               Depends: kdelibs4-dev (>= 4:3.5-rc1) but it is not going to be installed
E: Broken packages"

dresnu (dresnu) wrote :

After following all dependencies I reached "libxfixes3" which seems to be the problem because the newer version cannot be found in the kde 3.5.3 kubuntu repositories. I get "libxfixes3 (= 1:3.0.1.2-0ubuntu3) but 1:4.0-0ubuntu1 is to be installed"

dresnu (dresnu) wrote :

(SOLVED)

Changed in libxfixes:
status: Unconfirmed → Fix Committed
Changed in kdebase-dev:
status: Unconfirmed → Fix Committed
Changed in libxfixes:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers