Whisker menu doesn't always take into account "Edit Application..."

Bug #1783758 reported by Benitron on 2018-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libxfce4util
Fix Released
Medium
libxfce4util (Ubuntu)
Undecided
Unassigned
xfce4-whiskermenu-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, thanks for the amazing job !

With a right click on an application in the whisker-menu (xfce 4-12), you can "Edit Application...".

Although it mostly works, it is not always the case (As you can see on the screenshoot I joined).

I tested on a brand new version (Xubuntu 18.04, 64 bits), and elements such as the game "Mines" don't take the changes from "Edit Application..." into account (to translate it in French as it was in English).

I noticed that it is the same for Simple Scan. And also for "Eye of Gnome" and "Inkscape", I installed later. But not for everything...

No idea where it comes from, but with Menu Editor (Alacarte), we can "Edit Application..." and it finally works.

Description: Ubuntu 18.04.1 LTS
Release: 18.04
xfce 4-12

Created attachment 7421
Screenshot of the issue

Since upgrading the package gnome-calculator to 3.26.0, the item in the application menu is no longer localized.
Please see the attached screenshot. "Calculator" should be "Taschenrechner", like with previous versions.

I have noticed that the order of the "Name" fields is different in the .desktop file.

Working:
[Desktop Entry]
Name=Calculator
Name[de]=Taschenrechner
...

Not working:
[Desktop Entry]
Name[de]=Taschenrechner
Name=Calculator
...

According to desktop-file-validate both versions are valid. So this seems to be a bug in either xfce-panel or Garcon.

System:
Arch Linux (up-to-date)
xfce-panel 4.12.1
garcon 0.6.1

Could you quickly confirm that this bug is also exposed in xfdesktop's application menu?

Both xfdesktop and the panel use garcon to handle these menus so I would presume the bug is with garcon, but by trying out the above you could very quickly confirm that. Thanks!

The application menu shown when right-clicking on the desktop has the same bug.

Ok, thanks. Moved the issue to Garcon.

The bug is not in Garcon but libxfce4util, reassigned.

Created attachment 7763
Simple reproducer for this bug report

Created attachment 7764
Patch to fix this issue

Created attachment 7765
And another (unrelated) cleanup patch

*** Bug 13683 has been marked as a duplicate of this bug. ***

In , Gitbot (gitbot) wrote :

Thomas Lange referenced this bugreport in commit ffc7a0a8bd63c154563f27c268183576e61c9d24

Allow language-specific keys before language-neutral ones (Bug #13979)

https://git.xfce.org/xfce/libxfce4util/commit?id=ffc7a0a8bd63c154563f27c268183576e61c9d24

Thank you for the patches and the reproducer !

Benitron (benlarcher-1) wrote :
affects: xfce4-panel (Ubuntu) → xfce4-whiskermenu-plugin (Ubuntu)

Fixed in libxfce4util 4.13.2 (Ubuntu 18.10 dev).

affects: exo (Ubuntu) → libxfce4util (Ubuntu)
Changed in xfce4-whiskermenu-plugin (Ubuntu):
status: New → Invalid
Changed in libxfce4util:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.